Loading ...
Sorry, an error occurred while loading the content.

Got error when open MacVim from Finder

Expand Messages
  • imcom
    Hey guys, I got an error recently, when I use MacVim to open files in Finder. It states: Error detected while processing command line: E486: Pattern not
    Message 1 of 3 , Nov 7, 2011
    • 0 Attachment
      Hey guys, I got an error recently, when I use MacVim to open files in Finder. It states:
      "Error detected while processing command line:"
      "E486: Pattern not found: a string"
      But this would not happen if I open the file in terminal by command "mvim"

      Any ideas?

      Thanks in advance!

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • björn
      ... Can you outline some steps on how to reproduce the problem? (I ve never come across this problem myself.) You can try troubleshooting the problem yourself
      Message 2 of 3 , Nov 8, 2011
      • 0 Attachment
        On 7 November 2011 16:46, imcom wrote:
        > Hey guys, I got an error recently, when I use MacVim to open files in
        > Finder. It states:
        > "Error detected while processing command line:"
        > "E486: Pattern not found: a string"
        > But this would not happen if I open the file in terminal by command "mvim"
        > Any ideas?

        Can you outline some steps on how to reproduce the problem? (I've
        never come across this problem myself.)

        You can try troubleshooting the problem yourself by going through [1].

        Björn

        [1] https://github.com/b4winckler/macvim/wiki/Troubleshooting

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • anilg
        ... I ve got this issue too. I attempted to post to this thread before I understood current forum arrangements. I ended up starting a new thread which does
        Message 3 of 3 , Jul 18, 2013
        • 0 Attachment
          On Tuesday, 8 November 2011 02:46:46 UTC+11, imcom wrote:
          > Hey guys, I got an error recently, when I use MacVim to open files in Finder. It states:
          > "Error detected while processing command line:"
          > "E486: Pattern not found: a string"
          > But this would not happen if I open the file in terminal by command "mvim"

          I've got this issue too. I attempted to post to this thread before I understood current forum arrangements. I ended up starting a new thread which does explain how this happens:

          https://groups.google.com/forum/#!topic/vim_mac/9UtgsU9r6Xs

          It's because MacVim injects the flags +/ and -o when calling vim command. More in the above thread.

          --
          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_mac" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_mac+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.