Loading ...
Sorry, an error occurred while loading the content.

Re: MacVim does not build with Xcode 4.2

Expand Messages
  • björn
    ... Building from the repo should work _unless_ you specify the --with-macsdk flag is passed to configure, see [1]. You do need the very latest commit
    Message 1 of 5 , Oct 14, 2011
    • 0 Attachment
      On 14 October 2011 16:26, Tim Gray wrote:
      > On Oct 13, 2011 at 02:47 PM -0800, Tim Johnson wrote:
      >>
      >> This time I have Xcode 4.2. MacVim did not build.
      >> Got these (selected) error messages:
      >> /Developer/usr/bin/gcc-4.2 -v -E -dM -arch x86_64 -x c -c /dev/null 2>&1
      >>  :info:build Check dependencies
      >>  :info:build Unsupported compiler 'GCC 4.2' selected for architecture
      >> 'x86_64'
      >>  :info:build (1 failure)
      >>  :info:build make[1]: *** [macvim] Error 65
      >
      > I've been building MacVim here locally, from git, for awhile now.  I haven't
      > had much in the way of issues, but I can confirm that with Xcode 4.2, my
      > normal build process fails.  I'm not quite sure where your above error
      > messages are occuring, but here's what I got:

      Building from the repo should work _unless_ you specify the
      --with-macsdk flag is passed to configure, see [1]. You do need the
      very latest commit however.

      Björn


      [1] http://code.google.com/p/macvim/issues/detail?id=375

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Tim Gray
      ... I do have the latest commit (I think). My configure line was: ./configure --with-features=huge --enable-rubyinterp --enable-pythoninterp
      Message 2 of 5 , Oct 14, 2011
      • 0 Attachment
        On Oct 14, 2011 at 07:00 PM +0200, björn wrote:
        >Building from the repo should work _unless_ you specify the
        >--with-macsdk flag is passed to configure, see [1]. You do need the
        >very latest commit however.

        I do have the latest commit (I think). My configure line was:

        ./configure --with-features=huge --enable-rubyinterp \
        --enable-pythoninterp --enable-perlinterp --enable-cscope

        It's possible I have some cruft left over from some previous tinkering.
        Also, there's no rush for me to get a build working. I previously built
        a post snapshot-61 build and have been using that. I'm sure any build
        issues with Xcode 4.2 will be sorted out soon.

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Tim Gray
        ... I spoke too soon. Running `make distclean` and trying to build again cleared everything up. -- You received this message from the vim_mac maillist. Do
        Message 3 of 5 , Oct 14, 2011
        • 0 Attachment
          On Oct 14, 2011 at 07:00 PM +0200, björn wrote:
          >Building from the repo should work _unless_ you specify the
          >--with-macsdk flag is passed to configure, see [1]. You do need the
          >very latest commit however.

          I spoke too soon. Running `make distclean` and trying to build again
          cleared everything up.

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.