Loading ...
Sorry, an error occurred while loading the content.

How to change font with a space in the font?

Expand Messages
  • Blueplastic
    Hi guys, I want to change my default font to one with a space in the middle. How do I do this? what is the correct syntax for the .gvimrc file? set
    Message 1 of 4 , Sep 10, 2011
    View Source
    • 0 Attachment
      Hi guys,

      I want to change my default font to one with a space in the middle.
      How do I do this? what is the correct syntax for the .gvimrc file?

      set guifont=Anonymous Pro:h12

      or

      set guifont="Anonymous Pro":h12

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Israel Chauca F.
      ... Escape the space: set guifont=Anonymous Pro:h12 Israel -- You received this message from the vim_mac maillist. Do not top-post! Type your reply below
      Message 2 of 4 , Sep 10, 2011
      View Source
      • 0 Attachment
        On Sep 10, 2011, at 12:39 PM, Blueplastic wrote:

        > Hi guys,
        >
        > I want to change my default font to one with a space in the middle.
        > How do I do this? what is the correct syntax for the .gvimrc file?
        >
        > set guifont=Anonymous Pro:h12
        >
        > or
        >
        > set guifont="Anonymous Pro":h12

        Escape the space:

        set guifont=Anonymous\ Pro:h12

        Israel

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Tony Mechelynck
        On Sep 10, 10:19 pm, Israel Chauca F. ... yes, in general any space, double quote, vertical bar or backslash in the arguments of
        Message 3 of 4 , Sep 10, 2011
        View Source
        • 0 Attachment
          On Sep 10, 10:19 pm, "Israel Chauca F." <israelvar...@...>
          wrote:
          > On Sep 10, 2011, at 12:39 PM, Blueplastic wrote:
          >
          > > Hi guys,
          >
          > > I want to change my default font to one with a space in the middle.
          > > How do I do this? what is the correct syntax for the .gvimrc file?
          >
          > > set guifont=Anonymous Pro:h12
          >
          > > or
          >
          > > set guifont="Anonymous Pro":h12
          >
          > Escape the space:
          >
          > set guifont=Anonymous\ Pro:h12
          >
          > Israel

          yes, in general any space, double quote, vertical bar or backslash in
          the arguments of the :set, :setlocal and :setglobal statements must be
          backslash-escaped. But for backslashes Vim tries to determine if a
          Windows file path was meant and adds some black magic.

          See :help option-backslash


          About how to set the 'guifont' option portably (so that it will
          continue to work on other platforms and with other Vim versions), see
          http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI (which includes
          several examples of font names with spaces in them).


          Best regards,
          Tony.
          --
          There are also a lot of nice buildings in Haiphong. What their
          contributions are to the war effort I don't know, but the desire to
          bomb a virgin building is terrific.
          -- Commander Henry Urban Jr.

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Blueplastic
          Thanks! -- You received this message from the vim_mac maillist. Do not top-post! Type your reply below the text you are replying to. For more information,
          Message 4 of 4 , Sep 18, 2011
          View Source
          • 0 Attachment
            Thanks!

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          Your message has been successfully submitted and would be delivered to recipients shortly.