Loading ...
Sorry, an error occurred while loading the content.
 

Re: Wide unicode symbols are truncated in MacVim

Expand Messages
  • björn
    ... WIth the experimental renderer enabled MacVim will clip each glyph to one display cell to avoid rendering artifacts when scrolling. This has to with how
    Message 1 of 3 , Aug 30, 2011
      On 26 August 2011 07:56, HU Junfeng wrote:
      > It does solve the problem if I clear 'listchars', but I really like my current 'listchars' setting. So I still look for other solutions. As I said in my original post, Vim in Terminal.app can show the whole symbols even when 'ambiwidth' is set to "single". I suspect MacVim might have issues that cause the problem.

      WIth the experimental renderer enabled MacVim will clip each glyph to
      one display cell to avoid rendering artifacts when scrolling. This
      has to with how the Vim GUI code works. If you disable the
      experimental renderer the problem you are having probably goes away
      (of course, the default renderer is much slower so it is not something
      I'd recommend).

      It would not be easy to fix this problem in a non-hacky way (meaning,
      you will have to live with it for now). Sorry.

      Björn

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.