Loading ...
Sorry, an error occurred while loading the content.

Re: lion fullscreen bugs and thoughts

Expand Messages
  • rgabo
    One issue that I think is absolutely crazy to the point that I might be missing obvious is: 6. Fire up MacVim and enter fullscreen on a machine that has a
    Message 1 of 7 , Aug 1 5:12 AM
    • 0 Attachment
      One issue that I think is absolutely crazy to the point that I might be
      missing obvious is:

      6. Fire up MacVim and enter fullscreen on a machine that has a secondary
      screen attached. Oops, you just lost half of your screen estate as there is
      no way to do anything on the secondary screen when Lion puts something full
      screen on the primary screen. WTF?!

      My usual flow is to have MacVim fullscreen on my primary screen (old 24"
      iMac) and have iTerm2 fullscreen on the secondary screen (widescreen 22"
      samsung) with many splits.

      After upgrading to 7.3-61 using Homebrew (brew install macvim --<many
      options>), I have no way to switch of Lion's full screen mode (something
      that iTerm2 has an option for).

      I would love an option to disable/enable as I'm sure this will improved in
      the long run from Apple as well.

      Best regards,
      Gabor

      --
      View this message in context: http://vim.1045645.n5.nabble.com/lion-fullscreen-bugs-and-thoughts-tp4621241p4654874.html
      Sent from the Vim - Mac mailing list archive at Nabble.com.

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • björn
      ... Please search through the archives before posting. I have mentioned this many times already. The gist is: $ defaults write org.vim.MacVim
      Message 2 of 7 , Aug 1 1:34 PM
      • 0 Attachment
        On 1 August 2011 14:12, rgabo wrote:
        > One issue that I think is absolutely crazy to the point that I might be
        > missing obvious is:
        >
        > 6. Fire up MacVim and enter fullscreen on a machine that has a secondary
        > screen attached. Oops, you just lost half of your screen estate as there is
        > no way to do anything on the secondary screen when Lion puts something full
        > screen on the primary screen. WTF?!
        >
        > My usual flow is to have MacVim fullscreen on my primary screen (old 24"
        > iMac) and have iTerm2 fullscreen on the secondary screen (widescreen 22"
        > samsung) with many splits.
        >
        > After upgrading to 7.3-61 using Homebrew (brew install macvim --<many
        > options>), I have no way to switch of Lion's full screen mode (something
        > that iTerm2 has an option for).
        >
        > I would love an option to disable/enable as I'm sure this will improved in
        > the long run from Apple as well.

        Please search through the archives before posting. I have mentioned
        this many times already. The gist is:

        $ defaults write org.vim.MacVim MMNativeFullScreen 0

        (The next window you open will use old full-screen behavior.)

        Björn

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.