Loading ...
Sorry, an error occurred while loading the content.

lion fullscreen bugs and thoughts

Expand Messages
  • dv1445@wayne.edu
    It s wonderful that MacVim works with Lion already. I ve built from the lion branch, and noticed a few bugs or less-than-fully-desirable aspects of Lion s
    Message 1 of 7 , Jul 21, 2011
    • 0 Attachment
      It's wonderful that MacVim works with Lion already. I've built from the
      lion branch, and noticed a few bugs or less-than-fully-desirable aspects
      of Lion's native fullscreen wrt MacVim.

      All of the following results even after doing mvim -u NONE -U NONE and
      having no ~/.vim folder, except where otherwise noted.

      1. Fire up MacVim, then enter fullscreen. No toolbar, which is correct
      behavior. Now move the mouse up to where the menubar would be. The
      menubar appears (which is correct), but also the MacVim toolbar appears,
      which is incorrect. Why is that incorrect? Because, it happens even if
      you have a minimal .gvimrc with "set go=" in it to remove all toolbars
      and scrollbars.

      2. Fire up MacVim, then enter fullscreen. Notice how the original size
      of the MacVim window stays there while a giant rectangle slowly grows
      behind it. To really make it noticeable, and to bring about just how
      ugly this is, go from non-fullscreen to fullscreen with a dark
      colorscheme in play (like a black background). Then you see a white
      rectangle slooowly growing behind your original black rectangle.

      3. This might be a problem with Lion, not MacVim, but here goes. With
      MacVim quit, set the Dock to show and hide automatically. Keep the
      mouse away from the dge of the screen so that the dock is hidden. Now
      fire up MacVim and enter fullscreen. The Dock is still hidden, which is
      correct behavior. Now move your mouse over to where the Dock hides to
      bring it out of hiding. Notice that the Dock refuses to appear. This
      is incorrect behavior, or at least, is a surprising difference from
      pre-Lion MacVim. I suspect, however, that this is Lion's fault.

      4. Fire up MacVim, and enter fullscreen not by mouse or key shortcut,
      but by doing ":set fu". You are now in fullscreen. Try to leave
      fullscreen by doing ":set nofu" and you will not leave fullscreen, even
      though you should. You can leave fullscreen with ":set invfu", which is
      as it should be.

      I've communicated privately with Björn about this, but it's worth saying
      to everyone to see if I'm alone on this. The aforementioned bugs aside,
      I think Lion's fullscreen mode is just absolutely awful, and would
      dearly, dearly appreciate some option to use the old way. It's awful
      for two reasons (neither of which have anything essentially to do with
      MacVim rather than some other app):

      (a) It *forces* you to swtich Spaces. WTF?! Every single day when
      using MacVim, I have one MacVim window in fullscreen, and also at least
      one other MacVim window open in addition (whether in fullscreen or not),
      and need to toggle quickly between them with Cmd-`, or look at them
      simultaneously (with the nonfull one in the foreground, small, and the
      full one in the background. This is just too useful to lose. Not to
      mention that *which* Space your fullscreen one goes to seems a bit
      unpredictable when you're using lots of spaces.

      (b) The animation for switching in and out of fullscreen is so
      unbelievably slow that it's very annoying. And I don't have a slow
      machine. My stopwatch records around 1.33-1.5 seconds to transition, on
      more than one machine. This is simply unacceptable. It's pointless
      "eye-candy" that slows down one's workflow. This is espeically annoying
      when one frequently flips between full and non-full.
      I found that with pre-Lion fullscreen, the animation can be disabled
      by replacing some numbers in mmfullscreenwindow.m before building so
      that the change is nearly instantaneous. *That's* how it should work,
      if at all possible.

      I'd love an option to use the old method of fullscreen. I personally
      don't care whether it's a compile-time option, or some checkbox in the
      preference pane, or if both ways are always available with two different
      key shortcuts in the menu. I don't care if Lion-mode is there as long
      as I don't have to use it.

      -gmn

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • dv1445@wayne.edu
      Let me add number 5 to the list: 5. Fire up MacVim and enter fullscreen. Then do :w. See the MacVim window disappear. See the plain gray background remain;
      Message 2 of 7 , Jul 21, 2011
      • 0 Attachment
        Let me add number 5 to the list:

        5. Fire up MacVim and enter fullscreen. Then do :w. See the MacVim window disappear. See the plain gray background remain; MacVim is not "releasing" the Space it claimed while in fullscreen mode. I can find no way to get rid of this extra, gray Space besides quitting MacVim.

        Let me also add another reason in favor of keeping "preLion fullscreen" around as an option at least. Fire up Macvim, and enter fullscreen. Now hit Cmd-N. What you get is a double abomination, namely, the new MacVim window is on a brand new Space (!!!), and --- this defies belief --- the new MacVim window is itself in fullscreen. (This is actually a triple abomination, since the sloooow transition animation happens too, but I've already covered that).

        This is NOT a bug in MacVim's Lion branch, since this is just how Lion works. Try it with Terminal, e.g. But it's a disgusting aspect of Lion, and we can hopefully steer around it with old-style fullscreen.

        -gmn

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • sos4nt
        ... This is Lion s default behavior in fullscreen mode. You have to move your mouse to the Dock s edge, wait a split second and move the mouse again into that
        Message 3 of 7 , Jul 22, 2011
        • 0 Attachment
          > 3. This might be a problem with Lion, not MacVim, but here goes.  With
          > MacVim quit, set the Dock to show and hide automatically.  Keep the
          > mouse away from the dge of the screen so that the dock is hidden.  Now
          > fire up MacVim and enter fullscreen.  The Dock is still hidden, which is
          > correct behavior.  Now move your mouse over to where the Dock hides to
          > bring it out of hiding.  Notice that the Dock refuses to appear.  This
          > is incorrect behavior, or at least, is a surprising difference from
          > pre-Lion MacVim.  I suspect, however, that this is Lion's fault.

          This is Lion's default behavior in fullscreen mode. You have to move
          your mouse to the Dock's edge, wait a split second and move the mouse
          again into that direction.

          -Stefan

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Seth Milliken
          Here is a roundabout way to address this fullscreen Dock problem, but one that might appeal especially well to vim users: 1. Open `System Preferences` 2. Go to
          Message 4 of 7 , Jul 24, 2011
          • 0 Attachment
            Here is a roundabout way to address this fullscreen Dock problem, but
            one that might appeal especially well to vim users:

            1. Open `System Preferences`
            2. Go to the `Keyboard` preference pane
            3. Select the `Keyboard Shortcuts` tab
            4. Select `Keyboard & Text Input` from the list on the lhs
            5. Set an easily accessible binding for `Move focus to the Dock`

            When you enter the Dock using this binding, you can use type-ahead
            find to select an application and <CR> to activate it.

            I use <C-S-'>, myself (with CapsLock mapped to Control).

            `Move focus to the menu bar` is another one worth binding to something
            easily accessible (type-ahead find works here, too).

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Jonathan Ragan-Kelley
            I d like to add to strong +1 to the desire for an option to use the classical full screen behavior. I like the push towards more full screen UIs in Lion, but
            Message 5 of 7 , Jul 29, 2011
            • 0 Attachment
              I'd like to add to strong +1 to the desire for an option to use the
              classical full screen behavior. I like the push towards more full
              screen UIs in Lion, but for editors I find this simply not usable. I
              was already a heavy MacVim full-screen user, and am sticking with
              snapshot 57 until it is possible to work around this behavior.

              Your heart is in the right place with making Vim more and more
              comfortably native, but for my usage, the result is a significant
              regression in usability.

              On Jul 21, 4:40 pm, dv1...@... wrote:
              > It's wonderful that MacVim works with Lion already.  I've built from the
              > lion branch, and noticed a few bugs or less-than-fully-desirable aspects
              > of Lion's native fullscreen wrt MacVim.
              >
              > All of the following results even after doing mvim -u NONE -U NONE and
              > having no ~/.vim folder, except where otherwise noted.
              >
              > 1. Fire up MacVim, then enter fullscreen.  No toolbar, which is correct
              > behavior.  Now move the mouse up to where the menubar would be.  The
              > menubar appears (which is correct), but also the MacVim toolbar appears,
              > which is incorrect.  Why is that incorrect?  Because, it happens even if
              > you have a minimal .gvimrc with "set go=" in it to remove all toolbars
              > and scrollbars.
              >
              > 2. Fire up MacVim, then enter fullscreen.  Notice how the original size
              > of the MacVim window stays there while a giant rectangle slowly grows
              > behind it.  To really make it noticeable, and to bring about just how
              > ugly this is, go from non-fullscreen to fullscreen with a dark
              > colorscheme in play (like a black background).  Then you see a white
              > rectangle slooowly growing behind your original black rectangle.
              >
              > 3. This might be a problem with Lion, not MacVim, but here goes.  With
              > MacVim quit, set the Dock to show and hide automatically.  Keep the
              > mouse away from the dge of the screen so that the dock is hidden.  Now
              > fire up MacVim and enter fullscreen.  The Dock is still hidden, which is
              > correct behavior.  Now move your mouse over to where the Dock hides to
              > bring it out of hiding.  Notice that the Dock refuses to appear.  This
              > is incorrect behavior, or at least, is a surprising difference from
              > pre-Lion MacVim.  I suspect, however, that this is Lion's fault.
              >
              > 4. Fire up MacVim, and enter fullscreen not by mouse or key shortcut,
              > but by doing ":set fu".  You are now in fullscreen.  Try to leave
              > fullscreen by doing ":set nofu" and you will not leave fullscreen, even
              > though you should.  You can leave fullscreen with ":set invfu", which is
              > as it should be.
              >
              > I've communicated privately with Bj rn about this, but it's worth saying
              > to everyone to see if I'm alone on this.  The aforementioned bugs aside,
              > I think Lion's fullscreen mode is just absolutely awful, and would
              > dearly, dearly appreciate some option to use the old way.  It's awful
              > for two reasons (neither of which have anything essentially to do with
              > MacVim rather than some other app):
              >
              > (a) It *forces* you to swtich Spaces.  WTF?!  Every single day when
              > using MacVim, I have one MacVim window in fullscreen, and also at least
              > one other MacVim window open in addition (whether in fullscreen or not),
              > and need to toggle quickly between them with Cmd-`, or look at them
              > simultaneously (with the nonfull one in the foreground, small, and the
              > full one in the background.  This is just too useful to lose.  Not to
              > mention that *which* Space your fullscreen one goes to seems a bit
              > unpredictable when you're using lots of spaces.
              >
              > (b) The animation for switching in and out of fullscreen is so
              > unbelievably slow that it's very annoying.  And I don't have a slow
              > machine.  My stopwatch records around 1.33-1.5 seconds to transition, on
              > more than one machine.  This is simply unacceptable.  It's pointless
              > "eye-candy" that slows down one's workflow.  This is espeically annoying
              > when one frequently flips between full and non-full.
              >    I found that with pre-Lion fullscreen, the animation can be disabled
              > by replacing some numbers in mmfullscreenwindow.m before building so
              > that the change is nearly instantaneous.  *That's* how it should work,
              > if at all possible.
              >
              > I'd love an option to use the old method of fullscreen.  I personally
              > don't care whether it's a compile-time option, or some checkbox in the
              > preference pane, or if both ways are always available with two different
              > key shortcuts in the menu.  I don't care if Lion-mode is there as long
              > as I don't have to use it.
              >
              > -gmn

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • rgabo
              One issue that I think is absolutely crazy to the point that I might be missing obvious is: 6. Fire up MacVim and enter fullscreen on a machine that has a
              Message 6 of 7 , Aug 1, 2011
              • 0 Attachment
                One issue that I think is absolutely crazy to the point that I might be
                missing obvious is:

                6. Fire up MacVim and enter fullscreen on a machine that has a secondary
                screen attached. Oops, you just lost half of your screen estate as there is
                no way to do anything on the secondary screen when Lion puts something full
                screen on the primary screen. WTF?!

                My usual flow is to have MacVim fullscreen on my primary screen (old 24"
                iMac) and have iTerm2 fullscreen on the secondary screen (widescreen 22"
                samsung) with many splits.

                After upgrading to 7.3-61 using Homebrew (brew install macvim --<many
                options>), I have no way to switch of Lion's full screen mode (something
                that iTerm2 has an option for).

                I would love an option to disable/enable as I'm sure this will improved in
                the long run from Apple as well.

                Best regards,
                Gabor

                --
                View this message in context: http://vim.1045645.n5.nabble.com/lion-fullscreen-bugs-and-thoughts-tp4621241p4654874.html
                Sent from the Vim - Mac mailing list archive at Nabble.com.

                --
                You received this message from the "vim_mac" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • björn
                ... Please search through the archives before posting. I have mentioned this many times already. The gist is: $ defaults write org.vim.MacVim
                Message 7 of 7 , Aug 1, 2011
                • 0 Attachment
                  On 1 August 2011 14:12, rgabo wrote:
                  > One issue that I think is absolutely crazy to the point that I might be
                  > missing obvious is:
                  >
                  > 6. Fire up MacVim and enter fullscreen on a machine that has a secondary
                  > screen attached. Oops, you just lost half of your screen estate as there is
                  > no way to do anything on the secondary screen when Lion puts something full
                  > screen on the primary screen. WTF?!
                  >
                  > My usual flow is to have MacVim fullscreen on my primary screen (old 24"
                  > iMac) and have iTerm2 fullscreen on the secondary screen (widescreen 22"
                  > samsung) with many splits.
                  >
                  > After upgrading to 7.3-61 using Homebrew (brew install macvim --<many
                  > options>), I have no way to switch of Lion's full screen mode (something
                  > that iTerm2 has an option for).
                  >
                  > I would love an option to disable/enable as I'm sure this will improved in
                  > the long run from Apple as well.

                  Please search through the archives before posting. I have mentioned
                  this many times already. The gist is:

                  $ defaults write org.vim.MacVim MMNativeFullScreen 0

                  (The next window you open will use old full-screen behavior.)

                  Björn

                  --
                  You received this message from the "vim_mac" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                Your message has been successfully submitted and would be delivered to recipients shortly.