Loading ...
Sorry, an error occurred while loading the content.

Re: Selection not disappearing if macvim_hig_shift_movement is on

Expand Messages
  • björn
    ... I think you should ask for help on vim_use. All I can say is that when macvim_hig_shift_movement is enabled MacVim will go into select mode (:h Select)
    Message 1 of 4 , Jun 16, 2011
    • 0 Attachment
      On 15 June 2011 15:18, IroNiQ wrote:
      > I would like to write a custom function to replace the string i select
      > with visual. Here is the code:
      >
      > vmap <silent> <C-T> :call PutTranslate()<CR>
      > function! PutTranslate()
      >        execute ":s/\\%V\\(.*\\)\\%V/\\<\\?php\\ __('\\1')\\ \\?\\>/"
      > endfunction
      >
      > In standard case the macvim_hig_shift_movement is not switched on, in
      > this case using GUI the selection disappears if i press ctrl-t. But if
      > i switch it on, the selection remains (the substitution is done). What
      > can i do to get it working the same way (disappearing the selection)?

      I think you should ask for help on vim_use. All I can say is that
      when macvim_hig_shift_movement is enabled MacVim will go into "select
      mode" (:h Select) instead of the "visual mode" when you select with
      the mouse.

      Björn

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • IroNiQ
      ... That is ok, but i d like to clear the selection automatically now i was able to clear the selection in insert mode, but in normal mode the selection still
      Message 2 of 4 , Jun 17, 2011
      • 0 Attachment
        On Jun 16, 6:58 pm, björn <bjorn.winck...@...> wrote:
        > On 15 June 2011 15:18, IroNiQ wrote:
        >
        > > I would like to write a custom function to replace the string i select
        > > with visual. Here is the code:
        >
        > > vmap <silent> <C-T> :call PutTranslate()<CR>
        > > function! PutTranslate()
        > >        execute ":s/\\%V\\(.*\\)\\%V/\\<\\?php\\ __('\\1')\\ \\?\\>/"
        > > endfunction
        >
        > > In standard case the macvim_hig_shift_movement is not switched on, in
        > > this case using GUI the selection disappears if i press ctrl-t. But if
        > > i switch it on, the selection remains (the substitution is done). What
        > > can i do to get it working the same way (disappearing the selection)?
        >
        > I think you should ask for help on vim_use.  All I can say is that
        > when macvim_hig_shift_movement is enabled MacVim will go into "select
        > mode" (:h Select) instead of the "visual mode" when you select with
        > the mouse.

        That is ok, but i'd like to clear the selection automatically now i
        was able to clear the selection in insert mode, but in normal mode the
        selection still remains and nothing happens for this:

        exec "normal \<Esc>"


        IroNiQ

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • IroNiQ
        ... Sorry, you were right... I should have read the help more carefully. the exec normal gV solved my problem :) IroNiQ -- You received this message from the
        Message 3 of 4 , Jun 17, 2011
        • 0 Attachment
          On Jun 16, 6:58 pm, björn <bjorn.winck...@...> wrote:
          > I think you should ask for help on vim_use.  All I can say is that
          > when macvim_hig_shift_movement is enabled MacVim will go into "select
          > mode" (:h Select) instead of the "visual mode" when you select with
          > the mouse.

          Sorry, you were right... I should have read the help more carefully.
          the exec "normal gV" solved my problem :)


          IroNiQ

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.