Loading ...
Sorry, an error occurred while loading the content.

Configuring MacVim

Expand Messages
  • Eric Weir
    I created a .gvimrc and put in my home directory. At present, I ve only got two commands in it: set guioptions-=T colorscheme murphy They re not working.
    Message 1 of 19 , Jun 5, 2011
    • 0 Attachment

      I created a .gvimrc and put in my home directory. At present, I've only got two commands in it:

      set guioptions-=T
      colorscheme murphy

      They're not working. MacVim starts up with the toolbar and without the murphy colorscheme.

      I'd also like to get rid of the right scrollbar.

      Help appreciated.

      Thanks,
      ------------------------------------------------------------------------------------------
      Eric Weir
      Decatur, GA  USA




      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Peter Palmreuther
      Hi, ... Use :version to inspect the value for user gvimrc file . ... set guioptions-=r -- Regards, Peter -- You received this message from the vim_mac
      Message 2 of 19 , Jun 5, 2011
      • 0 Attachment
        Hi,

        On 06/05/2011 at 4:32pm Eric Weir wrote:

        I created a .gvimrc and put in my home directory. At present, I've only got two commands in it:

        set guioptions-=T
        colorscheme murphy

        They're not working. MacVim starts up with the toolbar and without the murphy colorscheme.

        Use ':version' to inspect the value for "user gvimrc file".

        I'd also like to get rid of the right scrollbar.

        set guioptions-=r
        -- 
        Regards,

        Peter

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Eric Weir
        ... Thanks, Peter. It is $HOME/.gvimrc . Which I guess is the one I created, and has only these two commands. [While I m at it, should colorscheme murphy be
        Message 3 of 19 , Jun 5, 2011
        • 0 Attachment

          On Jun 5, 2011, at 3:29 PM, Peter Palmreuther wrote:

          On 06/05/2011 at 4:32pm Eric Weir wrote:

          I created a .gvimrc and put in my home directory. At present, I've only got two commands in it:

          set guioptions-=T
          colorscheme murphy

          They're not working. MacVim starts up with the toolbar and without the murphy colorscheme.

          Use ':version' to inspect the value for "user gvimrc file".

          Thanks, Peter. It is "$HOME/.gvimrc". Which I guess is the one I created, and has only these two commands. [While I'm at it, should "colorscheme murphy" be "set colorscheme murphy?]

          I'd also like to get rid of the right scrollbar.

          set guioptions-=r

          And thanks again.

          ------------------------------------------------------------------------------------------
          Eric Weir
          Decatur, GA  USA




          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Peter Palmreuther
          Hello, ... guess is quite vague for problem hunting . Please open MacVim and enter command :e $HOME/.gvimrc to check if the correct file opens, i.e. the
          Message 4 of 19 , Jun 5, 2011
          • 0 Attachment
            Hello,

            On 06/06/2011 at 00:06 Eric Weir wrote:

            On Jun 5, 2011, at 3:29 PM, Peter Palmreuther wrote:

            On 06/05/2011 at 4:32pm Eric Weir wrote:

            I created a .gvimrc and put in my home directory. At present, I've only got two commands in it:

            set guioptions-=T
            colorscheme murphy

            They're not working. MacVim starts up with the toolbar and without the murphy colorscheme.

            Use ':version' to inspect the value for "user gvimrc file".

            Thanks, Peter. It is "$HOME/.gvimrc". Which I guess is the one I created, and has only these two commands.

            "guess" is quite vague for "problem hunting".
            Please open MacVim and enter command ":e $HOME/.gvimrc" to check if the correct file opens, i.e. the one that in fact contains the two lines you entered.
            If possible use copy/paste to avoid typos.

            All I can say right now is, that MacVim evaluates my users gvimrc file correctly, and it's definitely more than two lines.
            And among these lines I do have colorscheme settings and toolbar button disabling settings as well. So yes, it works. We've just got to figure what's different on your system.

            Additionally: which version of MacVim are you using?

            [While I'm at it, should "colorscheme murphy" be "set colorscheme murphy?]

            No. It's correct without "set".
            -- 
            Regards,

            Peter

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Devric
            just .vimrc will do the guioptions-=T kind of useless on mac, you can just hit the button on the top right of the macvim window to show/hide the tools. ... --
            Message 5 of 19 , Jun 6, 2011
            • 0 Attachment
              just .vimrc will do

              the guioptions-=T kind of useless on mac, you can just hit the button
              on the top right of the macvim window to show/hide the tools.



              On Jun 6, 12:32 am, Eric Weir <eew...@...> wrote:
              > I created a .gvimrc and put in my home directory. At present, I've only got two commands in it:
              >
              > set guioptions-=T
              > colorscheme murphy
              >
              > They're not working. MacVim starts up with the toolbar and without the murphy colorscheme.
              >
              > I'd also like to get rid of the right scrollbar.
              >
              > Help appreciated.
              >
              > Thanks,
              > ------------------------------------------------------------------------------------------
              > Eric Weir
              > Decatur, GA  USA
              > eew...@...

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Eric Weir
              ... My apologies for the vagueness, Peter. And thanks. Problem solved. When I opened the file in MacVim I saw that it had ^Ms at the beginning and end of the
              Message 6 of 19 , Jun 6, 2011
              • 0 Attachment
                On Jun 6, 2011, at 2:43 AM, Peter Palmreuther wrote:

                >> Thanks, Peter. It is "$HOME/.gvimrc". Which I guess is the one I created, and has only these two commands.
                >
                > "guess" is quite vague for "problem hunting".
                > Please open MacVim and enter command ":e $HOME/.gvimrc" to check if the correct file opens, i.e. the one that in fact contains the two lines you entered.
                > If possible use copy/paste to avoid typos.

                My apologies for the vagueness, Peter.

                And thanks. Problem solved. When I opened the file in MacVim I saw that it had "^Ms" at the beginning and end of the lines. I had created the file in another editor and must have saved it with CRLF format.

                My MacVim version is 7.3.

                ------------------------------------------------------------------------------------------
                Eric Weir
                Decatur, GA USA
                eeweir@...




                --
                You received this message from the "vim_mac" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • Eric Weir
                ... Thanks for bringing that to my attention, Devric. ... Eric Weir Decatur, GA USA eeweir@bellsouth.net -- You received this message from the vim_mac
                Message 7 of 19 , Jun 6, 2011
                • 0 Attachment
                  On Jun 6, 2011, at 3:18 AM, Devric wrote:

                  > the guioptions-=T kind of useless on mac, you can just hit the button
                  > on the top right of the macvim window to show/hide the tools.

                  Thanks for bringing that to my attention, Devric.

                  ------------------------------------------------------------------------------------------
                  Eric Weir
                  Decatur, GA USA
                  eeweir@...




                  --
                  You received this message from the "vim_mac" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • Peter Palmreuther
                  ... No problem :-) It s just been my experience, that guess often turned out to be != reality ;-) ... Great news. Glad you got it worked out. ... *nah* How
                  Message 8 of 19 , Jun 6, 2011
                  • 0 Attachment
                    On 06/06/2011 at 11:20pm Eric Weir wrote:
                    >
                    > On Jun 6, 2011, at 2:43 AM, Peter Palmreuther wrote:
                    >
                    >>> Thanks, Peter. It is "$HOME/.gvimrc". Which I guess is the one I created, and has only these two commands.
                    >>
                    >> "guess" is quite vague for "problem hunting".
                    >> Please open MacVim and enter command ":e $HOME/.gvimrc" to check if the correct file opens, i.e. the one that in fact contains the two lines you entered.
                    >> If possible use copy/paste to avoid typos.
                    >
                    > My apologies for the vagueness, Peter.

                    No problem :-)
                    It's just been my experience, that "guess" often turned out to be != reality ;-)

                    > And thanks. Problem solved.

                    Great news. Glad you got it worked out.

                    > When I opened the file in MacVim I saw that it had "^Ms" at the beginning and end of the lines. I had created the file in another editor and must have saved it with CRLF format.

                    *nah* How can you edit a vim config file with any other editor but vim ... ;-)
                    --
                    Best regard,

                    Peter

                    --
                    You received this message from the "vim_mac" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  • Eric Weir
                    ... Well, I won t do that again. And while I m at it, while I m a writer, not a programmer, and while most of the topics on Vim_mac and Vim_Use are way over my
                    Message 9 of 19 , Jun 7, 2011
                    • 0 Attachment
                      On Jun 6, 2011, at 5:54 PM, Peter Palmreuther wrote:

                      > *nah* How can you edit a vim config file with any other editor but vim ... ;-)

                      Well, I won't do that again. And while I'm at it, while I'm a writer, not a programmer, and while most of the topics on Vim_mac and Vim_Use are way over my head, and highly unlikely ever to be useful to me, I am gradually become more and more committed to Vim. Just today I discovered the ":ex" command. I love it.

                      Next up is finding out about spellchecking and formatting of documents for printing.

                      ------------------------------------------------------------------------------------------
                      Eric Weir
                      Decatur, GA USA
                      eeweir@...




                      --
                      You received this message from the "vim_mac" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                    • Braden Douglass
                      Eric, For your formatting issue I would look into a simple markup language like markup or textile. This is what I recommend to everyone using Vim who are
                      Message 10 of 19 , Jun 8, 2011
                      • 0 Attachment
                        Eric,

                        For your formatting "issue" I would look into a simple markup language like markup or textile. This is what I recommend to everyone using Vim who are predominately using it as a writing tool. All of the formatting stays in one document and is run through a converter when you want to pass the information to another human being, be it an editor or whatever.
                        _____________________
                        Braden Sawyer Douglass
                         whyhello.im/braden
                        “To avoid criticism, do nothing, say nothing, and be nothing.”
                                  – Elbert Hubbard via Tim Ferriss



                        On Tue, Jun 7, 2011 at 12:24 PM, Eric Weir <eeweir@...> wrote:

                        On Jun 6, 2011, at 5:54 PM, Peter Palmreuther wrote:

                        > *nah* How can you edit a vim config file with any other editor but vim ... ;-)

                        Well, I won't do that again. And while I'm at it, while I'm a writer, not a programmer, and while most of the topics on Vim_mac and Vim_Use are way over my head, and highly unlikely ever to be useful to me, I am gradually become more and more committed to Vim. Just today I discovered the ":ex" command. I love it.

                        Next up is finding out about spellchecking and formatting of documents for printing.

                        ------------------------------------------------------------------------------------------
                        Eric Weir
                        Decatur, GA  USA
                        eeweir@...




                        --
                        You received this message from the "vim_mac" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        --
                        You received this message from the "vim_mac" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php
                      • Tim Gray
                        ... Assuming you want the spell checker on all the time, add this in your .vimrc: set spell spelllang=en If you want it on for only certain document types, you
                        Message 11 of 19 , Jun 8, 2011
                        • 0 Attachment
                          On Jun 07, 2011 at 12:24 PM -0400, Eric Weir wrote:
                          >Next up is finding out about spellchecking and formatting of documents
                          >for printing.

                          Assuming you want the spell checker on all the time, add this in your
                          .vimrc:

                          set spell spelllang=en

                          If you want it on for only certain document types, you could instead add
                          a line like the following:

                          au FileType mail,markdown,tex setlocal spell spelllang=en

                          Obviously, add in the appropriate file types. A short list of commands
                          that you'll probably want follow.

                          - ]s - next misspelled word
                          - [s - previous misspelled word
                          - zg - add word to dictionary
                          - z= - suggest correction

                          For more information on the spell checker included with vim 7.3, try
                          `:help spell`.

                          --
                          You received this message from the "vim_mac" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php
                        • Eric Weir
                          ... Thanks, Braden. Yeah, I ve become familiar with MultiMarkDown, which is really simple, leaves the file very readable, and can be compiled for LaTeX
                          Message 12 of 19 , Jun 8, 2011
                          • 0 Attachment
                            On Jun 8, 2011, at 9:42 AM, Braden Douglass wrote:

                            > For your formatting "issue" I would look into a simple markup language like markup or textile. This is what I recommend to everyone using Vim who are predominately using it as a writing tool. All of the formatting stays in one document and is run through a converter when you want to pass the information to another human being, be it an editor or whatever.

                            Thanks, Braden. Yeah, I've become familiar with MultiMarkDown, which is really simple, leaves the file very readable, and can be compiled for LaTeX processing. And I think I've come across something for it -- a plugin? -- for Vim.

                            I am also looking for something that would handle simple setup of printing of Vim text documents, e.g., wrapping words, selecting fonts, and setting margins -- the bare minimum. Haven't come across anything for that yet.

                            ------------------------------------------------------------------------------------------
                            Eric Weir
                            Decatur, GA USA
                            eeweir@...




                            --
                            You received this message from the "vim_mac" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php
                          • Eric Weir
                            ... Thanks, Tim. Especially for the first two items. I used the second to turn spell on for txt files only, but it s checking my .vimrc. I especially don t
                            Message 13 of 19 , Jun 8, 2011
                            • 0 Attachment
                              On Jun 8, 2011, at 9:53 AM, Tim Gray wrote:

                              > Assuming you want the spell checker on all the time, add this in your .vimrc:
                              >
                              > set spell spelllang=en
                              >
                              > If you want it on for only certain document types, you could instead add a line like the following:
                              >
                              > au FileType mail,markdown,tex setlocal spell spelllang=en
                              >
                              > Obviously, add in the appropriate file types. A short list of commands that you'll probably want follow.
                              >
                              > - ]s - next misspelled word
                              > - [s - previous misspelled word
                              > - zg - add word to dictionary
                              > - z= - suggest correction
                              >
                              > For more information on the spell checker included with vim 7.3, try `:help spell`.

                              Thanks, Tim. Especially for the first two items.

                              I used the second to turn spell on for txt files only, but it's checking my .vimrc. I especially don't want that.

                              Checking the help on spell, one of the comments was that it loads the entire dictionary, apparently a large file, into memory, and that it can slow things down. I don't work with very big files. Max would be 15 to 20 pages of plain text. I assume having spell on all the time is not going to be a problem for me. [I have two Gb of RAM.]

                              ------------------------------------------------------------------------------------------
                              Eric Weir
                              Decatur, GA USA
                              eeweir@...




                              --
                              You received this message from the "vim_mac" maillist.
                              Do not top-post! Type your reply below the text you are replying to.
                              For more information, visit http://www.vim.org/maillist.php
                            • David Patrick Henderson
                              ... Probably better to make the spelling checker local to the current buffer using ‘setlocal’ David P Henderson c: 757.286.3212 -- Criticizing
                              Message 14 of 19 , Jun 8, 2011
                              • 0 Attachment
                                On 08 Jun 2011, at 14:48, Eric Weir wrote:

                                > Checking the help on spell, one of the comments was that it loads the entire dictionary, apparently a large file, into memory, and that it can slow things down. I don't work with very big files. Max would be 15 to 20 pages of plain text. I assume having spell on all the time is not going to be a problem for me. [I have two Gb of RAM.]

                                If you find it to be problematic, you turn it on and off in the vim command line:
                                :set(local) (no)spell

                                Probably better to make the spelling checker local to the current buffer using ‘setlocal’

                                David P Henderson
                                c: 757.286.3212
                                --
                                "Criticizing evolutionary theory because Darwin was limited is like claiming computers don't work because Chuck Babbage didn't foresee Duke Nukem 3."
                                -- Patrick Coskren

                                --
                                You received this message from the "vim_mac" maillist.
                                Do not top-post! Type your reply below the text you are replying to.
                                For more information, visit http://www.vim.org/maillist.php
                              • Eric Weir
                                ... Thanks, David -- on both counts. At Tim s suggestion, I have the following in my .vimrc. au FileType txt setlocal spell spelllang=en_us Will the setlocal
                                Message 15 of 19 , Jun 9, 2011
                                • 0 Attachment
                                  On Jun 8, 2011, at 8:09 PM, David Patrick Henderson wrote:

                                  > On 08 Jun 2011, at 14:48, Eric Weir wrote:
                                  >
                                  >> Checking the help on spell, one of the comments was that it loads the entire dictionary, apparently a large file, into memory, and that it can slow things down. I don't work with very big files. Max would be 15 to 20 pages of plain text. I assume having spell on all the time is not going to be a problem for me. [I have two Gb of RAM.]
                                  >
                                  > If you find it to be problematic, you turn it on and off in the vim command line:
                                  > :set(local) (no)spell
                                  >
                                  > Probably better to make the spelling checker local to the current buffer using ‘setlocal’

                                  Thanks, David -- on both counts. At Tim's suggestion, I have the following in my .vimrc.

                                  au FileType txt setlocal spell spelllang=en_us

                                  Will the setlocal in that take care of it?

                                  ------------------------------------------------------------------------------------------
                                  Eric Weir
                                  Decatur, GA USA
                                  eeweir@...




                                  --
                                  You received this message from the "vim_mac" maillist.
                                  Do not top-post! Type your reply below the text you are replying to.
                                  For more information, visit http://www.vim.org/maillist.php
                                • Tim Gray
                                  ... Yes that should take care of it. -- You received this message from the vim_mac maillist. Do not top-post! Type your reply below the text you are replying
                                  Message 16 of 19 , Jun 9, 2011
                                  • 0 Attachment
                                    On Jun 09, 2011 at 05:33 AM -0400, Eric Weir wrote:
                                    >Thanks, David -- on both counts. At Tim's suggestion, I have the
                                    >following in my .vimrc.
                                    >
                                    > au FileType txt setlocal spell spelllang=en_us
                                    >
                                    >Will the setlocal in that take care of it?

                                    Yes that should take care of it.

                                    --
                                    You received this message from the "vim_mac" maillist.
                                    Do not top-post! Type your reply below the text you are replying to.
                                    For more information, visit http://www.vim.org/maillist.php
                                  • Eric Weir
                                    ... Thanks, Tim. ... Eric Weir Decatur, GA USA eeweir@bellsouth.net -- You received this message from the vim_mac maillist. Do not top-post! Type your reply
                                    Message 17 of 19 , Jun 9, 2011
                                    • 0 Attachment
                                      On Jun 9, 2011, at 10:11 AM, Tim Gray wrote:

                                      > On Jun 09, 2011 at 05:33 AM -0400, Eric Weir wrote:
                                      >> Thanks, David -- on both counts. At Tim's suggestion, I have the following in my .vimrc.
                                      >>
                                      >> au FileType txt setlocal spell spelllang=en_us
                                      >>
                                      >> Will the setlocal in that take care of it?
                                      >
                                      > Yes that should take care of it.

                                      Thanks, Tim.

                                      ------------------------------------------------------------------------------------------
                                      Eric Weir
                                      Decatur, GA USA
                                      eeweir@...




                                      --
                                      You received this message from the "vim_mac" maillist.
                                      Do not top-post! Type your reply below the text you are replying to.
                                      For more information, visit http://www.vim.org/maillist.php
                                    • Levi Figueira
                                      With Lion, there is no more collapse toolbar button anymore… :) -- You received this message from the vim_mac maillist. Do not top-post! Type your reply
                                      Message 18 of 19 , Jul 6 12:07 PM
                                      • 0 Attachment
                                        With Lion, there is no more "collapse toolbar" button anymore… :)

                                        --
                                        You received this message from the "vim_mac" maillist.
                                        Do not top-post! Type your reply below the text you are replying to.
                                        For more information, visit http://www.vim.org/maillist.php
                                      • David Patrick Henderson
                                        ... Try the following in your .gvimrc as it works regardless of toolbar lozenge’s existence: set guioptions-=T David P Henderson c: xxx.xxx.xxxx -- You
                                        Message 19 of 19 , Jul 6 2:20 PM
                                        • 0 Attachment

                                          On 06 Jul 2011, at 12:07, Levi Figueira wrote:

                                          With Lion, there is no more "collapse toolbar" button anymore… :)

                                          Try the following in your .gvimrc as it works regardless of toolbar lozenge’s existence:

                                          set guioptions-=T


                                          David P Henderson
                                          c: xxx.xxx.xxxx
                                          --
                                          "You can't have capitalism on the way up and socialism on the way down."
                                             -- Newt Gingrich

                                          --
                                          You received this message from the "vim_mac" maillist.
                                          Do not top-post! Type your reply below the text you are replying to.
                                          For more information, visit http://www.vim.org/maillist.php
                                        Your message has been successfully submitted and would be delivered to recipients shortly.