Loading ...
Sorry, an error occurred while loading the content.
 

Re: vim python2.7 brew build

Expand Messages
  • locojay
    thanks that helped ... -- You received this message from the vim_mac maillist. Do not top-post! Type your reply below the text you are replying to. For more
    Message 1 of 8 , Jun 1, 2011
      thanks that helped

      On Wednesday, June 1, 2011 at 10:11 PM, Nathan Ramella wrote:

      You might be getting a false-negative by mvim if you've got Vim installed in 
      /Applications/ and you're testing the in your source tree (having not
      installed it). 

      Try running $TOPDIR/src/Vim directly after building?

      I've got python2.6 as my 'default' and tried the following:

      ./configure \
        --enable-pythoninterp=dynamic \
        vi_cv_path_python=/System/Library/Frameworks/Python.framework/Versions/2.5/bin/python

      And it worked for me.

      -n

      On Jun 1, 2011, at 5:29 PM, locojay wrote:

      ./configure --with-features=huge --enable-rubyinterp --enable-pythoninterp=dynamic --enable-perlinterp --with-python-config-dir=/usr/local/Cellar/python/2.7.1/Frameworks/Python.framework/Versions/2.7/lib/python2.7/config

      did not help. 

      configure outputs :
      checking --enable-pythoninterp argument... dynamic
      checking for python... /usr/local/bin/python
      checking Python version... 2.7
      checking Python is 1.4 or better... yep
      checking Python's install prefix... /usr/local/Cellar/python/2.7.1/Frameworks/Python.framework/Versions/2.7
      checking Python's execution prefix... /usr/local/Cellar/python/2.7.1/Frameworks/Python.framework/Versions/2.7
      checking Python's configuration directory... (cached) /usr/local/Cellar/python/2.7.1/Frameworks/Python.framework/Versions/2.7/lib/python2.7/config

      this all looks ok to me 

      but 

      :python import sys; print sys.path

      I also resmlink 

      Current in /System/Library/Frameworks/Python.framework/Versions to

      /usr/local/Cellar/python/2.7.1/Frameworks/Python.framework/Versions/2.7

      no clue 

      on ./src/MacVim/mvim outputs 2.6 

      On Wednesday, June 1, 2011 at 7:40 PM, Nathan Ramella wrote:

      --enable-pythoninterp=dynamic might help you out


      On Jun 1, 2011, at 4:34 PM, LocoJay Dev wrote:

      hi,

      i would like to have python2.7 once running


      :python import sys; print sys.path

      at the moment it shows

      /Library/Python2.6/site-packages

      but may main python is brew 2.7

      which python /usr/local/bin/python --> ../Cellar/python/2.7.1/bin/python ( + all the other pip ipython, ....)

      i m a bit confused.
      why does vim not use brews python?

      i tried the following from git source

      ./configure --with-features=huge --enable-rubyinterp --enable-pythoninterp --enable-perlinterp --with-python-config-dir=/usr/local/Cellar/python/2.7.1/Frameworks/Python.framework/Versions/2.7/lib/python2.7/config

      but still

      :python import sys; print sys.path

      outputs 2.6

      any idea?

      is there maybe a way to set the "main" python in vimrc ( would prefer to use brew macvim instead of master)

      many thanks

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php


      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php


      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • William Quirk
      Same problem but my main python is 3.2 Any constructive idea is welcome. Thanks in advance Bill Quirk ________________________________ From: LocoJay Dev
      Message 2 of 8 , Jun 2, 2011
        Same problem but my main python is 3.2

        Any constructive idea is welcome.
        Thanks in advance
        Bill Quirk


        From: LocoJay Dev <locojaydev@...>
        To: vim_mac@...
        Sent: Wednesday, June 1, 2011 6:34 PM
        Subject: vim python2.7 brew build

        hi,

        i would like to have python2.7 once running


        :python import sys;  print sys.path

        at the moment it shows

        /Library/Python2.6/site-packages

        but may main python is brew 2.7

        which python /usr/local/bin/python --> ../Cellar/python/2.7.1/bin/python  ( + all the other pip ipython, ....)

        i m a bit confused.
        why does vim not use brews python?

        i tried the following from git source

        ./configure --with-features=huge --enable-rubyinterp --enable-pythoninterp --enable-perlinterp --with-python-config-dir=/usr/local/Cellar/python/2.7.1/Frameworks/Python.framework/Versions/2.7/lib/python2.7/config

        but still

        :python import sys;  print sys.path

        outputs 2.6

        any idea?

        is there maybe a way to set the "main" python in vimrc ( would prefer to use brew macvim instead of master)

        many thanks

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php


        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • björn
        ... Guys, what s with the weird fonts and bad posting manners? Please turn off the rich text and bottom post on this list. Thanks! :-) Having said that, you
        Message 3 of 8 , Jun 2, 2011
          On 2 June 2011 16:30, William Quirk wrote:
          > Same problem but my main python is 3.2
          > Any constructive idea is welcome.
          > Thanks in advance
          > Bill Quirk
          > ________________________________
          > From: LocoJay Dev <locojaydev@...>
          > To: vim_mac@...
          > Sent: Wednesday, June 1, 2011 6:34 PM
          > Subject: vim python2.7 brew build
          >
          > hi,
          >
          > i would like to have python2.7 once running
          >
          >
          > :python import sys;  print sys.path
          >
          > at the moment it shows
          >
          > /Library/Python2.6/site-packages
          >
          > but may main python is brew 2.7
          >
          > which python /usr/local/bin/python --> ../Cellar/python/2.7.1/bin/python  (
          > + all the other pip ipython, ....)
          >
          > i m a bit confused.
          > why does vim not use brews python?
          >
          > i tried the following from git source
          >
          > ./configure --with-features=huge --enable-rubyinterp --enable-pythoninterp
          > --enable-perlinterp
          > --with-python-config-dir=/usr/local/Cellar/python/2.7.1/Frameworks/Python.framework/Versions/2.7/lib/python2.7/config
          >
          > but still
          >
          > :python import sys;  print sys.path
          >
          > outputs 2.6
          >
          > any idea?
          >
          > is there maybe a way to set the "main" python in vimrc ( would prefer to use
          > brew macvim instead of master)
          >
          > many thanks

          Guys, what's with the weird fonts and bad posting manners? Please
          turn off the rich text and bottom post on this list. Thanks! :-)

          Having said that, you should probably ask on vim_use if you need help
          with building with a specific version of Python. I have no experience
          of this so can not be of much help (I do recall seeing this type of
          discussions several times before, did you try searching old posts?).

          Two tips: dynamic Python is not supported on Mac OS X (as far as I
          know), and Python 3 needs a separate flag from Python 2.x
          (--enable-python3interp, as opposed to --enable-pythoninterp). Type

          ./configure --help

          to see all flags to configure (there are quite a few related to Python).

          Björn

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • LocoJay Dev
          at the end it worked for me it just picked up my old vim . so if you uninstall fist of reset VIM_APP_DIR ( or so) it works ... -- You received this message
          Message 4 of 8 , Jun 2, 2011
            at the end it worked for me it just picked up my old vim .
            so if you uninstall fist of reset VIM_APP_DIR ( or so) it works


            On Jun 2, 2011, at 12:35 PM, björn wrote:

            > On 2 June 2011 16:30, William Quirk wrote:
            >> Same problem but my main python is 3.2
            >> Any constructive idea is welcome.
            >> Thanks in advance
            >> Bill Quirk
            >> ________________________________
            >> From: LocoJay Dev <locojaydev@...>
            >> To: vim_mac@...
            >> Sent: Wednesday, June 1, 2011 6:34 PM
            >> Subject: vim python2.7 brew build
            >>
            >> hi,
            >>
            >> i would like to have python2.7 once running
            >>
            >>
            >> :python import sys; print sys.path
            >>
            >> at the moment it shows
            >>
            >> /Library/Python2.6/site-packages
            >>
            >> but may main python is brew 2.7
            >>
            >> which python /usr/local/bin/python --> ../Cellar/python/2.7.1/bin/python (
            >> + all the other pip ipython, ....)
            >>
            >> i m a bit confused.
            >> why does vim not use brews python?
            >>
            >> i tried the following from git source
            >>
            >> ./configure --with-features=huge --enable-rubyinterp --enable-pythoninterp
            >> --enable-perlinterp
            >> --with-python-config-dir=/usr/local/Cellar/python/2.7.1/Frameworks/Python.framework/Versions/2.7/lib/python2.7/config
            >>
            >> but still
            >>
            >> :python import sys; print sys.path
            >>
            >> outputs 2.6
            >>
            >> any idea?
            >>
            >> is there maybe a way to set the "main" python in vimrc ( would prefer to use
            >> brew macvim instead of master)
            >>
            >> many thanks
            >
            > Guys, what's with the weird fonts and bad posting manners? Please
            > turn off the rich text and bottom post on this list. Thanks! :-)
            >
            > Having said that, you should probably ask on vim_use if you need help
            > with building with a specific version of Python. I have no experience
            > of this so can not be of much help (I do recall seeing this type of
            > discussions several times before, did you try searching old posts?).
            >
            > Two tips: dynamic Python is not supported on Mac OS X (as far as I
            > know), and Python 3 needs a separate flag from Python 2.x
            > (--enable-python3interp, as opposed to --enable-pythoninterp). Type
            >
            > ./configure --help
            >
            > to see all flags to configure (there are quite a few related to Python).
            >
            > Björn
            >
            > --
            > You received this message from the "vim_mac" maillist.
            > Do not top-post! Type your reply below the text you are replying to.
            > For more information, visit http://www.vim.org/maillist.php

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          Your message has been successfully submitted and would be delivered to recipients shortly.