Loading ...
Sorry, an error occurred while loading the content.

Re: MacVim remembers my old settings

Expand Messages
  • Anton Egorov
    I have found the problem. I always start my vim with `/usr/local/bin/mvim -S .vimses`. I have removed .vim direcrory but session stores somethind that causes
    Message 1 of 3 , May 18, 2011
    View Source
    • 0 Attachment
      I have found the problem. I always start my vim with `/usr/local/bin/mvim -S .vimses`. I have removed .vim direcrory but session stores somethind that causes such problems. Remove the session file and all be ok.

      On 18 May 2011 04:34, Ben Schmidt <mail_ben_schmidt@...> wrote:
      On 18/05/11 1:26 AM, Anton Egorov wrote:
      I have removes my old settings by deleting .vim directory, but MacVim
      still remember old settings e.g. autoload plugins. I have tried to
      install and remove new plugin (XP Template), but I start getting
      errors on startup

      E117: Unknown function: XPMautoUpdate
      E15: Invalid expression: XPMautoUpdate("statusline")

      It seems that MacVim caches this stuff. I have posted the same
      queation on StackOverflow http://stackoverflow.com/questions/5952977/macvim-remember-my-old-settings
      but there is no good answers yet.

      Did you remember to delete your ~/.vimrc or remove the lines from it
      that reference your autoload scripts that are now deleted?

      Ben.




      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.