Loading ...
Sorry, an error occurred while loading the content.

Re: Macvim doesn't work properly with chinese input method

Expand Messages
  • Ben Schmidt
    ... It works for me, too, though I m using the experimental renderer and have the inline marked text turned on. I use the pinyin Chinese input method, as
    Message 1 of 8 , Apr 30, 2011
    • 0 Attachment
      On 30/04/11 7:02 PM, björn wrote:
      > On 30 April 2011 10:07, Jamie Xie wrote:
      >> I disabled the "Draw marked text inline" option in Advanced Preferences,and
      >> added "set noimdisable" to vimrc,it can automatically switch to english when
      >> I return to normal mode.But there is still a problem: it doesn't remember
      >> the state of input method in insert mode,so when I change to insert mode the
      >> IME state is still English.But it's a lot better than before.
      >
      > This should work. I use it myself.

      It works for me, too, though I'm using the experimental renderer and
      have the inline marked text turned on. I use the pinyin Chinese input
      method, as that's the only thing that I have a hope of even doing a
      handful of characters with (I only learnt Chinese at primary school...).
      But it does work, and MacVim changes layouts just fine. Maybe the
      problem is with some other Chinese input method that I don't understand.

      Ben.



      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Jerry
      Ben,sorry for my delayed reply.It s strange that I didn t receive your last two message in my Email. I have followed your instructions to reproduce the problem
      Message 2 of 8 , Jun 18, 2011
      • 0 Attachment
        Ben,sorry for my delayed reply.It's strange that I didn't receive your
        last two message in my Email.

        I have followed your instructions to reproduce the problem and the
        input method I am using is FIT,you can download it here(http://
        dl.fit4.cn/FIT_2.2.1.dmg),my os x version is 10.6.7,Macvim version is
        7.3

        1.I open both the "use experimental renderer" and "draw marked text
        inline" options in macvim's preference setting

        2.restart macvim without any plugins and ":set noimd"

        3.switch to insert mode and switch to Chinese IME,type "shenme" and
        space bar,then I get "什么'me" on the screen,the expected result is "什
        么",the "'me" is unwanted

        4.uncheck "draw marked text inline" option,restart vim without plugins
        and ":set noimd",switch to chinese IME,then type "shenme",the
        candidate window pops up,but the characters "shenme" don't get printed
        to the screen,so I get no clue what I've just typed.

        5.uncheck "use experiemental renderer" option,restart and do the steps
        above,everything works fine.

        In either case I didn't encounter any IME switch problem anymore,I
        think it is one of my plugins make the switch function broken.

        hope I have described it clearly enough.



        On Apr 30, 5:36 pm, Ben Schmidt <mail_ben_schm...@...> wrote:
        > On 30/04/11 7:02 PM, bj rn wrote:
        >
        > > On 30 April 2011 10:07, Jamie Xie wrote:
        > >> I disabled the "Draw marked text inline" option in Advanced Preferences,and
        > >> added "set noimdisable" to vimrc,it can automatically switch to english when
        > >> I return to normal mode.But there is still a problem: it doesn't remember
        > >> the state ofinputmethodin insert mode,so when I change to insert mode the
        > >> IME state is still English.But it's a lot better than before.
        >
        > > This should work. I use it myself.
        >
        > It works for me, too, though I'm using the experimental renderer and
        > have the inline marked text turned on. I use the pinyinChineseinputmethod, as that's the only thing that I have a hope of even doing a
        > handful of characters with (I only learntChineseat primary school...).
        > But it does work, and MacVim changes layouts just fine. Maybe the
        > problem is with some otherChineseinputmethodthat I don't understand.
        >
        > Ben.

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.