Loading ...
Sorry, an error occurred while loading the content.

ssop="tabpages" doesn't preserve tabs

Expand Messages
  • philipx
    I was hoping that by settings sessionoptions to = tabpages I would get a very minimal file upon executing :mksession. But when loading the session, only one
    Message 1 of 2 , Mar 14, 2011
    • 0 Attachment
      I was hoping that by settings sessionoptions to ="tabpages" I would
      get a very minimal file upon executing :mksession.
      But when loading the session, only one of the tabs gets restored,
      although all the buffers are loaded. A diff between the files shows
      that they both load all the files that were loaded in the window:
      badd +1 file1
      badd +0 file2
      args file1 file2
      edit file1

      But with the default ssop the file also contains this command:
      tabedit file2

      which is missing from the session file saved with ssop="tabpages".

      Is this expected? If yes, how do I get the session file to save only
      the tab layout?

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • björn
      ... This is a general Vim question so you may want to try asking on vim_use instead. I don t have an answer myself. Björn -- You received this message from
      Message 2 of 2 , Mar 21, 2011
      • 0 Attachment
        On 15 March 2011 03:27, philipx wrote:
        > I was hoping that by settings sessionoptions to ="tabpages" I would
        > get a very minimal file upon executing :mksession.
        > But when loading the session, only one of the tabs gets restored,
        > although all the buffers are loaded. A diff between the files shows
        > that they both load all the files that were loaded in the window:
        > badd +1 file1
        > badd +0 file2
        > args file1 file2
        > edit file1
        >
        > But with the default ssop the file also contains this command:
        > tabedit file2
        >
        > which is missing from the session file saved with ssop="tabpages".
        >
        > Is this expected? If yes, how do I get the session file to save only
        > the tab layout?

        This is a general Vim question so you may want to try asking on
        vim_use instead. I don't have an answer myself.

        Björn

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.