Loading ...
Sorry, an error occurred while loading the content.
 

Option/meta/alt key not working

Expand Messages
  • Johannes Harestad
    Hey. I am not sure what to call it, meta, option, or alt key. I have a nordic keyboard layout, and to write a (backslash) I need to press - - ,
    Message 1 of 3 , Mar 11, 2011
      Hey.
      I am not sure what to call it, meta, option, or alt key.

      I have a nordic keyboard layout, and to write a \ (backslash) I need
      to press <shift>-<alt>-<7>, but doing that does nothing in MacVim.

      Please help, thanks.

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • philipx
      I had somewhat the same problem, but with shortcuts. Try :set macmeta and then see if that works. On Mar 11, 5:45 pm, Johannes Harestad
      Message 2 of 3 , Mar 12, 2011
        I had somewhat the same problem, but with shortcuts.

        Try ":set macmeta" and then see if that works.



        On Mar 11, 5:45 pm, Johannes Harestad <johanneshares...@...>
        wrote:
        > Hey.
        > I am not sure what to call it, meta, option, or alt key.
        >
        > I have a nordic keyboard layout, and to write a \ (backslash) I need
        > to press <shift>-<alt>-<7>, but doing that does nothing in MacVim.
        >
        > Please help, thanks.

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • björn
        ... Exactly which keyboard layout are you using (Norwegian, Danish, Swedish, ...)? Please go through the troubleshooting guide as well:
        Message 3 of 3 , Mar 14, 2011
          On 12 March 2011 00:45, Johannes Harestad wrote:
          > Hey.
          > I am not sure what to call it, meta, option, or alt key.
          >
          > I have a nordic keyboard layout, and to write a \ (backslash) I need
          > to press <shift>-<alt>-<7>, but doing that does nothing in MacVim.
          >
          > Please help, thanks.

          Exactly which keyboard layout are you using (Norwegian, Danish, Swedish, ...)?

          Please go through the troubleshooting guide as well:

          https://github.com/b4winckler/macvim/wiki/Troubleshooting

          Björn

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.