Loading ...
Sorry, an error occurred while loading the content.

MacVim and Ruby (RVM)

Expand Messages
  • Anders Janmyr
    Hi, I am having trouble getting macvim to work with ruby 1.9.2 under RVM. I read the previous discussions, and I checked out this gist.
    Message 1 of 15 , Jan 3, 2011
    • 0 Attachment
      Hi,

      I am having trouble getting macvim to work with ruby 1.9.2 under RVM.

      I read the previous discussions, and I checked out this gist. https://gist.github.com/398996, but I cannot get it to work 
      properly. With the brew installed version I get a segfault when starting from the command line under a different version
      than the system version. The system version works fine.

      If I configure and build with the command below I get strange results. Is this issue resolved, if so how?

      I would be very grateful for any help
      Regards 
      Anders

      ./configure --with-features=huge --enable-rubyinterp --with-macsdk=10.6 --with-macarchs=x86_64 --with-ruby-command=/Users/andersjanmyr/.rvm/wrappers/ruby-1.9.2-p136/ruby |grep ruby

      checking --enable-rubyinterp argument... yes
      checking --with-ruby-command argument... /Users/andersjanmyr/.rvm/wrappers/ruby-1.9.2-p136/ruby

      checking for /Users/andersjanmyr/.rvm/wrappers/ruby-1.9.2-p136/ruby... no # << Why is this no?

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • björn
      ... You have to patch the configure script in order for Ruby 1.9 to build. I have had two contributors work on a patch which I thought would be re-submitted to
      Message 2 of 15 , Jan 3, 2011
      • 0 Attachment
        On 3 January 2011 10:36, Anders Janmyr <anders.janmyr@...> wrote:
        > Hi,
        > I am having trouble getting macvim to work with ruby 1.9.2 under RVM.
        > I read the previous discussions, and I checked out this
        > gist. https://gist.github.com/398996, but I cannot get it to work
        > properly. With the brew installed version I get a segfault when starting
        > from the command line under a different version
        > than the system version. The system version works fine.
        > If I configure and build with the command below I get strange results. Is
        > this issue resolved, if so how?

        You have to patch the configure script in order for Ruby 1.9 to build.
        I have had two contributors work on a patch which I thought would be
        re-submitted to vim_dev, but I have not seen it there yet. I may have
        to see if I can submit it myself.

        The necessary changes can be found in this pull request:

        https://github.com/b4winckler/vim/pull/1

        ...and there is a long discussion about it here:

        https://github.com/b4winckler/macvim/pull/2

        Björn

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Anders Janmyr
        Ok, thanks, I ll try to work it out from this. Anders ... -- http://anders.janmyr.com/ -- You received this message from the vim_mac maillist. Do not
        Message 3 of 15 , Jan 3, 2011
        • 0 Attachment
          Ok, thanks, I'll try to work it out from this.

          Anders

          2011/1/3 björn <bjorn.winckler@...>:
          > On 3 January 2011 10:36, Anders Janmyr <anders.janmyr@...> wrote:
          >> Hi,
          >> I am having trouble getting macvim to work with ruby 1.9.2 under RVM.
          >> I read the previous discussions, and I checked out this
          >> gist. https://gist.github.com/398996, but I cannot get it to work
          >> properly. With the brew installed version I get a segfault when starting
          >> from the command line under a different version
          >> than the system version. The system version works fine.
          >> If I configure and build with the command below I get strange results. Is
          >> this issue resolved, if so how?
          >
          > You have to patch the configure script in order for Ruby 1.9 to build.
          >  I have had two contributors work on a patch which I thought would be
          > re-submitted to vim_dev, but I have not seen it there yet.  I may have
          > to see if I can submit it myself.
          >
          > The necessary changes can be found in this pull request:
          >
          > https://github.com/b4winckler/vim/pull/1
          >
          > ...and there is a long discussion about it here:
          >
          > https://github.com/b4winckler/macvim/pull/2
          >
          > Björn
          >
          > --
          > You received this message from the "vim_mac" maillist.
          > Do not top-post! Type your reply below the text you are replying to.
          > For more information, visit http://www.vim.org/maillist.php
          >



          --
          http://anders.janmyr.com/

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Anders Janmyr
          Hi again, I still cannot get it to work, I m no good with config files. I tried to take the simple road and change config.mk directly but I cannot get this to
          Message 4 of 15 , Jan 5, 2011
          • 0 Attachment
            Hi again,

            I still cannot get it to work, I'm no good with config files.
            I tried to take the simple road and change config.mk directly but I cannot get this to work either.

            I tried these setting, but it results in the following error, 

            I'm very grateful for you taking the time to help me out.
            Anders

            RUBY            = /Users/andersjanmyr/.rvm/bin/ruby-1.9.2-p136
            RUBY_SRC        = if_ruby.c
            RUBY_OBJ        = objects/if_ruby.o
            RUBY_PRO        = if_ruby.pro
            RUBY_CFLAGS     = -I/Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/include/ruby-1.9.1 -I/Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/include/ruby-1.9.1/i386-darwin10.5.0 -DRUBY_VERSION=19
            RUBY_LIBS       = -lruby-static -lpthread -ldl -lobjc -lruby-1.9.1 -L/Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/lib 


            include/ruby-1.9.1/i386-darwin10.5.0 -DRUBY_VERSION=19 -o objects/if_ruby.o if_ruby.c
            In file included from /Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/include/ruby-1.9.1/Ruby/ruby.h:1326,
                             from if_ruby.c:89:
            /Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/include/ruby-1.9.1/ruby/missing.h:35: error: redefinition of ‘struct timespec’
            /Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/include/ruby-1.9.1/ruby/missing.h:42: error: redefinition of ‘struct timezone’
            if_ruby.c: In function ‘ruby_buffer_free’:
            if_ruby.c:633: error: ‘buf_T’ has no member named ‘b_ruby_ref’
            if_ruby.c:635: error: ‘buf_T’ has no member named ‘b_ruby_ref’
            if_ruby.c:636: error: ‘buf_T’ has no member named ‘b_ruby_ref’
            if_ruby.c: In function ‘ruby_window_free’:
            if_ruby.c:642: error: ‘win_T’ has no member named ‘w_ruby_ref’
            if_ruby.c:644: error: ‘win_T’ has no member named ‘w_ruby_ref’
            if_ruby.c:645: error: ‘win_T’ has no member named ‘w_ruby_ref’
            if_ruby.c: In function ‘buffer_new’:
            if_ruby.c:878: error: ‘buf_T’ has no member named ‘b_ruby_ref’
            if_ruby.c:880: error: ‘buf_T’ has no member named ‘b_ruby_ref’
            if_ruby.c:885: error: ‘buf_T’ has no member named ‘b_ruby_ref’
            if_ruby.c: In function ‘window_new’:
            if_ruby.c:1094: error: ‘win_T’ has no member named ‘w_ruby_ref’
            if_ruby.c:1096: error: ‘win_T’ has no member named ‘w_ruby_ref’
            if_ruby.c:1101: error: ‘win_T’ has no member named ‘w_ruby_ref’
            make: *** [objects/if_ruby.o] Error 1

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Bharat
            Anders, I installed Macvim using Macports and it installed fine. RVM and Macvim are indepependent of each other so you may want to install MacVim first and
            Message 5 of 15 , Jan 5, 2011
            • 0 Attachment
              Anders,
              I installed Macvim using Macports and it installed fine. RVM and
              Macvim are indepependent of each other so you may want to install
              MacVim first and then RVM. Now, you can set RVM default to point to
              Ruby 1.9.2 and MacVim will not complain. I have been using this
              combination for awhile without any problems.
              Bharat


              On Jan 5, 3:52 am, Anders Janmyr <anders.jan...@...> wrote:
              > Hi again,
              >
              > I still cannot get it to work, I'm no good with config files.
              > I tried to take the simple road and change config.mk directly but I cannot
              > get this to work either.
              >
              > I tried these setting, but it results in the following error,
              >
              > I'm very grateful for you taking the time to help me out.
              > Anders
              >
              > RUBY            = /Users/andersjanmyr/.rvm/bin/ruby-1.9.2-p136
              > RUBY_SRC        = if_ruby.c
              > RUBY_OBJ        = objects/if_ruby.o
              > RUBY_PRO        = if_ruby.pro
              > RUBY_CFLAGS     =
              > -I/Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/include/ruby-1.9.1
              > -I/Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/include/ruby-1.9.1/i386-darwin10.5.0
              > -DRUBY_VERSION=19
              > RUBY_LIBS       = -lruby-static -lpthread -ldl -lobjc -lruby-1.9.1
              > -L/Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/lib
              >
              > include/ruby-1.9.1/i386-darwin10.5.0 -DRUBY_VERSION=19 -o objects/if_ruby.o
              > if_ruby.c
              > In file included from
              > /Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/include/ruby-1.9.1/Ruby/ruby.h:1326,
              >                  from if_ruby.c:89:
              > /Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/include/ruby-1.9.1/ruby/missing.h:35:
              > error: redefinition of ‘struct timespec’
              > /Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/include/ruby-1.9.1/ruby/missing.h:42:
              > error: redefinition of ‘struct timezone’
              > if_ruby.c: In function ‘ruby_buffer_free’:
              > if_ruby.c:633: error: ‘buf_T’ has no member named ‘b_ruby_ref’
              > if_ruby.c:635: error: ‘buf_T’ has no member named ‘b_ruby_ref’
              > if_ruby.c:636: error: ‘buf_T’ has no member named ‘b_ruby_ref’
              > if_ruby.c: In function ‘ruby_window_free’:
              > if_ruby.c:642: error: ‘win_T’ has no member named ‘w_ruby_ref’
              > if_ruby.c:644: error: ‘win_T’ has no member named ‘w_ruby_ref’
              > if_ruby.c:645: error: ‘win_T’ has no member named ‘w_ruby_ref’
              > if_ruby.c: In function ‘buffer_new’:
              > if_ruby.c:878: error: ‘buf_T’ has no member named ‘b_ruby_ref’
              > if_ruby.c:880: error: ‘buf_T’ has no member named ‘b_ruby_ref’
              > if_ruby.c:885: error: ‘buf_T’ has no member named ‘b_ruby_ref’
              > if_ruby.c: In function ‘window_new’:
              > if_ruby.c:1094: error: ‘win_T’ has no member named ‘w_ruby_ref’
              > if_ruby.c:1096: error: ‘win_T’ has no member named ‘w_ruby_ref’
              > if_ruby.c:1101: error: ‘win_T’ has no member named ‘w_ruby_ref’
              > make: *** [objects/if_ruby.o] Error 1

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Anders Janmyr
              Hi Bharat, thanks for your reply. I should have been better at describing my problem. It comes up when I start vim from the terminal. $ rvm use 1.9.2 $ mvim
              Message 6 of 15 , Jan 5, 2011
              • 0 Attachment
                Hi Bharat, thanks for your reply.

                I should have been better at describing my problem.

                It comes up when I start vim from the terminal.

                $ rvm use 1.9.2
                $ mvim Gemfile #for example

                Then when I use omnicompletion in insert mode and try to do a <TAB> or
                a CTRL-n it crashes.

                Vim: Caught deadly signal SEGV
                Vim: preserving files...
                Vim: Finished.

                If I start vim as an App it works out fine.

                $ rvm use system
                $ mvim Gemfile # also works out fine


                But I want to start it from the command line with the correct version
                of ruby set...
                But it is not killing me, it is just annoying :(

                Anders

                On Wed, Jan 5, 2011 at 3:49 PM, Bharat <bcruparel@...> wrote:
                > Anders,
                > I installed Macvim using Macports and it installed fine.  RVM and
                > Macvim are indepependent of each other so you may want to install
                > MacVim first and then RVM.  Now, you can set RVM default to point to
                > Ruby 1.9.2 and MacVim will not complain.  I have been using this
                > combination for awhile without any problems.
                > Bharat
                >
                >
                > On Jan 5, 3:52 am, Anders Janmyr <anders.jan...@...> wrote:
                >> Hi again,
                >>
                >> I still cannot get it to work, I'm no good with config files.
                >> I tried to take the simple road and change config.mk directly but I cannot
                >> get this to work either.
                >>
                >> I tried these setting, but it results in the following error,
                >>
                >> I'm very grateful for you taking the time to help me out.
                >> Anders
                >>
                >> RUBY            = /Users/andersjanmyr/.rvm/bin/ruby-1.9.2-p136
                >> RUBY_SRC        = if_ruby.c
                >> RUBY_OBJ        = objects/if_ruby.o
                >> RUBY_PRO        = if_ruby.pro
                >> RUBY_CFLAGS     =
                >> -I/Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/include/ruby-1.9.1
                >> -I/Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/include/ruby-1.9.1/i386-darwin10.5.0
                >> -DRUBY_VERSION=19
                >> RUBY_LIBS       = -lruby-static -lpthread -ldl -lobjc -lruby-1.9.1
                >> -L/Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/lib
                >>
                >> include/ruby-1.9.1/i386-darwin10.5.0 -DRUBY_VERSION=19 -o objects/if_ruby.o
                >> if_ruby.c
                >> In file included from
                >> /Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/include/ruby-1.9.1/Ruby/ruby.h:1326,
                >>                  from if_ruby.c:89:
                >> /Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/include/ruby-1.9.1/ruby/missing.h:35:
                >> error: redefinition of ‘struct timespec’
                >> /Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/include/ruby-1.9.1/ruby/missing.h:42:
                >> error: redefinition of ‘struct timezone’
                >> if_ruby.c: In function ‘ruby_buffer_free’:
                >> if_ruby.c:633: error: ‘buf_T’ has no member named ‘b_ruby_ref’
                >> if_ruby.c:635: error: ‘buf_T’ has no member named ‘b_ruby_ref’
                >> if_ruby.c:636: error: ‘buf_T’ has no member named ‘b_ruby_ref’
                >> if_ruby.c: In function ‘ruby_window_free’:
                >> if_ruby.c:642: error: ‘win_T’ has no member named ‘w_ruby_ref’
                >> if_ruby.c:644: error: ‘win_T’ has no member named ‘w_ruby_ref’
                >> if_ruby.c:645: error: ‘win_T’ has no member named ‘w_ruby_ref’
                >> if_ruby.c: In function ‘buffer_new’:
                >> if_ruby.c:878: error: ‘buf_T’ has no member named ‘b_ruby_ref’
                >> if_ruby.c:880: error: ‘buf_T’ has no member named ‘b_ruby_ref’
                >> if_ruby.c:885: error: ‘buf_T’ has no member named ‘b_ruby_ref’
                >> if_ruby.c: In function ‘window_new’:
                >> if_ruby.c:1094: error: ‘win_T’ has no member named ‘w_ruby_ref’
                >> if_ruby.c:1096: error: ‘win_T’ has no member named ‘w_ruby_ref’
                >> if_ruby.c:1101: error: ‘win_T’ has no member named ‘w_ruby_ref’
                >> make: *** [objects/if_ruby.o] Error 1
                >
                > --
                > You received this message from the "vim_mac" maillist.
                > Do not top-post! Type your reply below the text you are replying to.
                > For more information, visit http://www.vim.org/maillist.php
                >



                --
                http://anders.janmyr.com/

                --
                You received this message from the "vim_mac" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • björn
                ... I m not sure exactly how rvm works, but I am pretty sure that when you start vim as an App it is still using the system Ruby version (which may or may
                Message 7 of 15 , Jan 8, 2011
                • 0 Attachment
                  On 5 January 2011 16:58, Anders Janmyr <anders.janmyr@...> wrote:
                  > Hi Bharat, thanks for your reply.
                  >
                  > I should have been better at describing my problem.
                  >
                  > It comes up when I start vim from the terminal.
                  >
                  > $ rvm use 1.9.2
                  > $ mvim Gemfile  #for example
                  >
                  > Then when I use omnicompletion in insert mode and try to do a <TAB> or
                  > a CTRL-n it crashes.
                  >
                  > Vim: Caught deadly signal SEGV
                  > Vim: preserving files...
                  > Vim: Finished.
                  >
                  > If I start vim as an App it works out fine.
                  >
                  > $ rvm use system
                  > $ mvim Gemfile  # also works out fine
                  >
                  >
                  > But I want to start it from the command line with the correct version
                  > of ruby set...
                  > But it is not killing me, it is just annoying :(

                  I'm not sure exactly how rvm works, but I am pretty sure that when you
                  start vim "as an App" it is still using the system Ruby version (which
                  may or may not be what you want). Using "mvim" may work as long as
                  you don't call it from the same Terminal window/tab that you called
                  "rvm" from (I am guessing here).

                  It is not possible to have one MacVim binary that works with several
                  different versions of Ruby at once since it links to a specific
                  version at build time. Patching MacVim to dynamically load a specific
                  version of Ruby will require some effort (there was a similar
                  discussion about loading Python in the past on vim_dev if I remember
                  correctly).

                  Björn

                  --
                  You received this message from the "vim_mac" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • Anders Janmyr
                  I am currently not trying to use it with many different versions of Ruby. I just want to compile it with ruby 1.9.2, which is what I use most of the time. That
                  Message 8 of 15 , Jan 9, 2011
                  • 0 Attachment
                    I am currently not trying to use it with many different versions of Ruby.
                    I just want to compile it with ruby 1.9.2, which is what I use most of the time.

                    That was what I was trying to do, but it failed somehow, and I cannot tell why.
                    I thought that maybe someone on the list had done it already, but I guess not.

                    I will take another look at it and report back when I figure it out.

                    Thanks anyway.
                    Anders


                    >
                    > I'm not sure exactly how rvm works, but I am pretty sure that when you
                    > start vim "as an App" it is still using the system Ruby version (which
                    > may or may not be what you want).  Using "mvim" may work as long as
                    > you don't call it from the same Terminal window/tab that you called
                    > "rvm" from (I am guessing here).
                    >
                    > It is not possible to have one MacVim binary that works with several
                    > different versions of Ruby at once since it links to a specific
                    > version at build time.  Patching MacVim to dynamically load a specific
                    > version of Ruby will require some effort (there was a similar
                    > discussion about loading Python in the past on vim_dev if I remember
                    > correctly).
                    >
                    > Björn
                    >
                    > --
                    > You received this message from the "vim_mac" maillist.
                    > Do not top-post! Type your reply below the text you are replying to.
                    > For more information, visit http://www.vim.org/maillist.php
                    >



                    --
                    http://anders.janmyr.com/

                    --
                    You received this message from the "vim_mac" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  • björn
                    ... I have tried to bring over the patch to the MacVim source tree (attached to this post) to help you get started (but I don t know if I can be of much more
                    Message 9 of 15 , Jan 9, 2011
                    • 0 Attachment
                      On 9 January 2011 20:48, Anders Janmyr <anders.janmyr@...> wrote:
                      > I am currently not trying to use it with many different versions of Ruby.
                      > I just want to compile it with ruby 1.9.2, which is what I use most of the time.
                      >
                      > That was what I was trying to do, but it failed somehow, and I cannot tell why.
                      > I thought that maybe someone on the list had done it already, but I guess not.
                      >
                      > I will take another look at it and report back when I figure it out.

                      I have tried to bring over the patch to the MacVim source tree
                      (attached to this post) to help you get started (but I don't know if I
                      can be of much more help). I have no idea if it works -- please let
                      me know how it goes.

                      With this patch you are supposed to be able to call configure like this:

                      ./configure --enable-ruby-interp --with-ruby-command=/usr/local/bin/ruby

                      Substitute the last path with wherever your 1.9 binary is.

                      Björn

                      --
                      You received this message from the "vim_mac" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                    • björn
                      ... There s an obvious typo here, but just to be sure it should be: ./configure --enable-rubyinterp --with-ruby-command=/usr/local/bin/ruby Björn -- You
                      Message 10 of 15 , Jan 9, 2011
                      • 0 Attachment
                        On 9 January 2011 21:34, björn <bjorn.winckler@...> wrote:
                        > On 9 January 2011 20:48, Anders Janmyr <anders.janmyr@...> wrote:
                        >> I am currently not trying to use it with many different versions of Ruby.
                        >> I just want to compile it with ruby 1.9.2, which is what I use most of the time.
                        >>
                        >> That was what I was trying to do, but it failed somehow, and I cannot tell why.
                        >> I thought that maybe someone on the list had done it already, but I guess not.
                        >>
                        >> I will take another look at it and report back when I figure it out.
                        >
                        > I have tried to bring over the patch to the MacVim source tree
                        > (attached to this post) to help you get started (but I don't know if I
                        > can be of much more help).  I have no idea if it works -- please let
                        > me know how it goes.
                        >
                        > With this patch you are supposed to be able to call configure like this:
                        >
                        > ./configure --enable-ruby-interp --with-ruby-command=/usr/local/bin/ruby

                        There's an obvious typo here, but just to be sure it should be:

                        ./configure --enable-rubyinterp --with-ruby-command=/usr/local/bin/ruby

                        Björn

                        --
                        You received this message from the "vim_mac" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php
                      • Anders Janmyr
                        Thanks Björn, The patch works like a charm. No problems so far. Regards Anders ... -- http://anders.janmyr.com/ -- You received this message from the
                        Message 11 of 15 , Jan 10, 2011
                        • 0 Attachment
                          Thanks Björn,

                          The patch works like a charm.

                          No problems so far.

                          Regards
                          Anders

                          2011/1/9 björn <bjorn.winckler@...>:
                          > On 9 January 2011 21:34, björn <bjorn.winckler@...> wrote:
                          >> On 9 January 2011 20:48, Anders Janmyr <anders.janmyr@...> wrote:
                          >>> I am currently not trying to use it with many different versions of Ruby.
                          >>> I just want to compile it with ruby 1.9.2, which is what I use most of the time.
                          >>>
                          >>> That was what I was trying to do, but it failed somehow, and I cannot tell why.
                          >>> I thought that maybe someone on the list had done it already, but I guess not.
                          >>>
                          >>> I will take another look at it and report back when I figure it out.
                          >>
                          >> I have tried to bring over the patch to the MacVim source tree
                          >> (attached to this post) to help you get started (but I don't know if I
                          >> can be of much more help).  I have no idea if it works -- please let
                          >> me know how it goes.
                          >>
                          >> With this patch you are supposed to be able to call configure like this:
                          >>
                          >> ./configure --enable-ruby-interp --with-ruby-command=/usr/local/bin/ruby
                          >
                          > There's an obvious typo here, but just to be sure it should be:
                          >
                          > ./configure --enable-rubyinterp --with-ruby-command=/usr/local/bin/ruby
                          >
                          > Björn
                          >
                          > --
                          > You received this message from the "vim_mac" maillist.
                          > Do not top-post! Type your reply below the text you are replying to.
                          > For more information, visit http://www.vim.org/maillist.php
                          >



                          --
                          http://anders.janmyr.com/

                          --
                          You received this message from the "vim_mac" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php
                        • Nikola Knežević
                          Hey, I had the same problems (I wanted to use homebrew s version of ruby). This patch helped. Thanks. ... -- You received this message from the vim_mac
                          Message 12 of 15 , Feb 16 6:22 AM
                          • 0 Attachment
                            Hey, I had the same problems (I wanted to use homebrew's version of ruby). This patch helped. Thanks.

                            On 09.01.2011, at 21:34 , björn wrote:

                            > On 9 January 2011 20:48, Anders Janmyr <anders.janmyr@...> wrote:
                            >> I am currently not trying to use it with many different versions of Ruby.
                            >> I just want to compile it with ruby 1.9.2, which is what I use most of the time.
                            >>
                            >> That was what I was trying to do, but it failed somehow, and I cannot tell why.
                            >> I thought that maybe someone on the list had done it already, but I guess not.
                            >>
                            >> I will take another look at it and report back when I figure it out.
                            >
                            > I have tried to bring over the patch to the MacVim source tree
                            > (attached to this post) to help you get started (but I don't know if I
                            > can be of much more help). I have no idea if it works -- please let
                            > me know how it goes.
                            >
                            > With this patch you are supposed to be able to call configure like this:
                            >
                            > ./configure --enable-ruby-interp --with-ruby-command=/usr/local/bin/ruby
                            >
                            > Substitute the last path with wherever your 1.9 binary is.
                            >
                            > Björn
                            >
                            > --
                            > You received this message from the "vim_mac" maillist.
                            > Do not top-post! Type your reply below the text you are replying to.
                            > For more information, visit http://www.vim.org/maillist.php
                            > <0001-Apply-patch-to-fix-with-ruby-command.patch>

                            --
                            You received this message from the "vim_mac" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php
                          • Björn Winckler
                            ... I have merged this patch with mainline now. Can I please get some confirmation that the master branch compiles Ruby 1.9 properly now? (It should be the
                            Message 13 of 15 , Feb 16 10:16 AM
                            • 0 Attachment
                              On Feb 16, 2011, at 3:22 PM, Nikola Knežević wrote:
                              >
                              > On 09.01.2011, at 21:34 , björn wrote:
                              >
                              >> On 9 January 2011 20:48, Anders Janmyr <anders.janmyr@...> wrote:
                              >>> I am currently not trying to use it with many different versions of Ruby.
                              >>> I just want to compile it with ruby 1.9.2, which is what I use most of the time.
                              >>>
                              >>> That was what I was trying to do, but it failed somehow, and I cannot tell why.
                              >>> I thought that maybe someone on the list had done it already, but I guess not.
                              >>>
                              >>> I will take another look at it and report back when I figure it out.
                              >>
                              >> I have tried to bring over the patch to the MacVim source tree
                              >> (attached to this post) to help you get started (but I don't know if I
                              >> can be of much more help). I have no idea if it works -- please let
                              >> me know how it goes.
                              >>
                              >> With this patch you are supposed to be able to call configure like this:
                              >>
                              >> ./configure --enable-ruby-interp --with-ruby-command=/usr/local/bin/ruby
                              >>
                              >> Substitute the last path with wherever your 1.9 binary is.
                              >>
                              >> Björn

                              >
                              > Hey, I had the same problems (I wanted to use homebrew's version of ruby). This patch helped. Thanks.

                              I have merged this patch with mainline now. Can I please get some confirmation that the master branch compiles Ruby 1.9 properly now? (It should be the same as with this patch, but ...)

                              Björn

                              --
                              You received this message from the "vim_mac" maillist.
                              Do not top-post! Type your reply below the text you are replying to.
                              For more information, visit http://www.vim.org/maillist.php
                            • Anders Janmyr
                              Hi Björn, I tried to compile the current master, but it failed. I believe it is unrelated to the ruby settings though. I configured with the following.
                              Message 14 of 15 , Feb 25 12:25 AM
                              • 0 Attachment
                                Hi Björn,

                                I tried to compile the current master, but it failed. I believe it is
                                unrelated to the ruby settings though.

                                I configured with the following.

                                ./configure --with-features=huge \
                                > --enable-rubyinterp \
                                > --enable-pythoninterp \
                                > --enable-perlinterp \
                                > --enable-cscope \
                                > --with-ruby-command=/Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/ruby

                                And below are the failures, the short version.

                                Anders



                                cc1obj: error: /var/folders/xQ/xQLJaYfpE-OC5JHXGYXw8k+++TI/-Caches-/com.apple.Xcode.501/SharedPrecompiledHeaders/AppKit-hlhifydmgfqmdralehblkqeidwva/AppKit.h:
                                No such file or directory
                                cc1obj: error: one or more PCH files were found, but they were invalid
                                cc1obj: error: use -Winvalid-pch for more information

                                === BUILD NATIVE TARGET MacVim OF PROJECT MacVim WITH THE DEFAULT
                                CONFIGURATION (Release) ===
                                Check dependencies
                                PhaseScriptExecution "Make Document Icons"
                                build/MacVim.build/Release/MacVim.build/Script-1D1C31F00EFFBFD6003FE9A5.sh
                                cd /Users/andersjanmyr/External_Projects/macvim/src/MacVim
                                /bin/sh -c /Users/andersjanmyr/External_Projects/macvim/src/MacVim/build/MacVim.build/Release/MacVim.build/Script-1D1C31F00EFFBFD6003FE9A5.sh

                                make[2]: `/Users/andersjanmyr/External_Projects/macvim/src/MacVim/build/Release/MacVim.app/Contents/Resources/MacVim-generic.icns'
                                is up to date.
                                ** BUILD FAILED **


                                The following build commands failed:
                                PSMTabBarControlFramework:
                                CompileC ../build/PSMTabBarControl.build/Release/PSMTabBarControlFramework.build/Objects-normal/x86_64/PSMOverflowPopUpButton.o
                                /Users/andersjanmyr/External_Projects/macvim/src/MacVim/PSMTabBarControl/source/PSMOverflowPopUpButton.m
                                normal x86_64 objective-c com.apple.compilers.gcc.4_2
                                CompileC ../build/PSMTabBarControl.build/Release/PSMTabBarControlFramework.build/Objects-normal/x86_64/PSMTabBarControl.o
                                /Users/andersjanmyr/External_Projects/macvim/src/MacVim/PSMTabBarControl/source/PSMTabBarControl.m
                                normal x86_64 objective-c com.apple.compilers.gcc.4_2
                                CompileC ../build/PSMTabBarControl.build/Release/PSMTabBarControlFramework.build/Objects-normal/x86_64/PSMTabBarCell.o
                                /Users/andersjanmyr/External_Projects/macvim/src/MacVim/PSMTabBarControl/source/PSMTabBarCell.m
                                normal x86_64 objective-c com.apple.compilers.gcc.4_2
                                CompileC ../build/PSMTabBarControl.build/Release/PSMTabBarControlFramework.build/Objects-normal/x86_64/PSMAquaTabStyle.o
                                /Users/andersjanmyr/External_Projects/macvim/src/MacVim/PSMTabBarControl/source/PSMAquaTabStyle.m
                                normal x86_64 objective-c com.apple.compilers.gcc.4_2
                                CompileC ../build/PSMTabBarControl.build/Release/PSMTabBarControlFramework.build/Objects-normal/x86_64/PSMMetalTabStyle.o
                                /Users/andersjanmyr/External_Projects/macvim/src/MacVim/PSMTabBarControl/source/PSMMetalTabStyle.m
                                normal x86_64 objective-c com.apple.compilers.gcc.4_2
                                CompileC ../build/PSMTabBarControl.build/Release/PSMTabBarControlFramework.build/Objects-normal/x86_64/PSMRolloverButton.o
                                /Users/andersjanmyr/External_Projects/macvim/src/MacVim/PSMTabBarControl/source/PSMRolloverButton.m
                                normal x86_64 objective-c com.apple.compilers.gcc.4_2
                                CompileC ../build/PSMTabBarControl.build/Release/PSMTabBarControlFramework.build/Objects-normal/x86_64/PSMProgressIndicator.o
                                /Users/andersjanmyr/External_Projects/macvim/src/MacVim/PSMTabBarControl/source/PSMProgressIndicator.m
                                normal x86_64 objective-c com.apple.compilers.gcc.4_2
                                CompileC ../build/PSMTabBarControl.build/Release/PSMTabBarControlFramework.build/Objects-normal/x86_64/PSMTabDragAssistant.o
                                /Users/andersjanmyr/External_Projects/macvim/src/MacVim/PSMTabBarControl/source/PSMTabDragAssistant.m
                                normal x86_64 objective-c com.apple.compilers.gcc.4_2
                                CompileC ../build/PSMTabBarControl.build/Release/PSMTabBarControlFramework.build/Objects-normal/x86_64/PSMUnifiedTabStyle.o
                                /Users/andersjanmyr/External_Projects/macvim/src/MacVim/PSMTabBarControl/source/PSMUnifiedTabStyle.m
                                normal x86_64 objective-c com.apple.compilers.gcc.4_2
                                CompileC ../build/PSMTabBarControl.build/Release/PSMTabBarControlFramework.build/Objects-normal/x86_64/NSBezierPath_AMShading.o
                                /Users/andersjanmyr/External_Projects/macvim/src/MacVim/PSMTabBarControl/source/NSBezierPath_AMShading.m
                                normal x86_64 objective-c com.apple.compilers.gcc.4_2
                                (10 failures)


                                2011/2/16 Björn Winckler <bjorn.winckler@...>:
                                > On Feb 16, 2011, at 3:22 PM, Nikola Knežević wrote:
                                >>
                                >> On 09.01.2011, at 21:34 , björn wrote:
                                >>
                                >>> On 9 January 2011 20:48, Anders Janmyr <anders.janmyr@...> wrote:
                                >>>> I am currently not trying to use it with many different versions of Ruby.
                                >>>> I just want to compile it with ruby 1.9.2, which is what I use most of the time.
                                >>>>
                                >>>> That was what I was trying to do, but it failed somehow, and I cannot tell why.
                                >>>> I thought that maybe someone on the list had done it already, but I guess not.
                                >>>>
                                >>>> I will take another look at it and report back when I figure it out.
                                >>>
                                >>> I have tried to bring over the patch to the MacVim source tree
                                >>> (attached to this post) to help you get started (but I don't know if I
                                >>> can be of much more help).  I have no idea if it works -- please let
                                >>> me know how it goes.
                                >>>
                                >>> With this patch you are supposed to be able to call configure like this:
                                >>>
                                >>> ./configure --enable-ruby-interp --with-ruby-command=/usr/local/bin/ruby
                                >>>
                                >>> Substitute the last path with wherever your 1.9 binary is.
                                >>>
                                >>> Björn
                                >
                                >>
                                >> Hey, I had the same problems (I wanted to use homebrew's version of ruby). This patch helped. Thanks.
                                >
                                > I have merged this patch with mainline now.  Can I please get some confirmation that the master branch compiles Ruby 1.9 properly now?  (It should be the same as with this patch, but ...)
                                >
                                > Björn
                                >
                                > --
                                > You received this message from the "vim_mac" maillist.
                                > Do not top-post! Type your reply below the text you are replying to.
                                > For more information, visit http://www.vim.org/maillist.php
                                >



                                --
                                http://anders.janmyr.com/

                                --
                                You received this message from the "vim_mac" maillist.
                                Do not top-post! Type your reply below the text you are replying to.
                                For more information, visit http://www.vim.org/maillist.php
                              • björn
                                ... This is a problem with precompiled headers. The only way I know how to work around this issue is to delete the SharedPrecompiledHeaders temporary
                                Message 15 of 15 , Feb 25 1:06 AM
                                • 0 Attachment
                                  On 25 February 2011 09:25, Anders Janmyr <anders.janmyr@...> wrote:
                                  >
                                  > I tried to compile the current master, but it failed. I believe it is
                                  > unrelated to the ruby settings though.
                                  >
                                  > I configured with the following.
                                  >
                                  > ./configure --with-features=huge \
                                  >>                   --enable-rubyinterp \
                                  >>                   --enable-pythoninterp \
                                  >>                   --enable-perlinterp \
                                  >>                   --enable-cscope \
                                  >> --with-ruby-command=/Users/andersjanmyr/.rvm/rubies/ruby-1.9.2-p136/ruby
                                  >
                                  > And below are the failures, the short version.
                                  >
                                  > Anders
                                  >
                                  >
                                  >
                                  > cc1obj: error: /var/folders/xQ/xQLJaYfpE-OC5JHXGYXw8k+++TI/-Caches-/com.apple.Xcode.501/SharedPrecompiledHeaders/AppKit-hlhifydmgfqmdralehblkqeidwva/AppKit.h:
                                  > No such file or directory
                                  > cc1obj: error: one or more PCH files were found, but they were invalid
                                  > cc1obj: error: use -Winvalid-pch for more information

                                  This is a problem with precompiled headers. The only way I know how
                                  to work around this issue is to delete the SharedPrecompiledHeaders
                                  temporary directory mentioned in the above error message. Don't know
                                  why Xcode does this but it happens to me all the time.

                                  Björn

                                  --
                                  You received this message from the "vim_mac" maillist.
                                  Do not top-post! Type your reply below the text you are replying to.
                                  For more information, visit http://www.vim.org/maillist.php
                                Your message has been successfully submitted and would be delivered to recipients shortly.