Loading ...
Sorry, an error occurred while loading the content.
 

Problem with the 'r' replace command and the US-Extended keyboard

Expand Messages
  • Andrew Gollan
    I had a quick look here to see if this was already discussed, but couldn t see anything. I am using MacVim 7.3-53 (the stable release as best I can tell). I
    Message 1 of 2 , Nov 27, 2010
      I had a quick look here to see if this was already discussed, but
      couldn't see anything.

      I am using MacVim 7.3-53 (the stable release as best I can tell). I
      also use the US-Extended keyboard to enter a lot of vowels with
      macrons (opt-a + vowel). I also convert a lot of texts without the
      macrons to have them. (I am a Latin teacher).

      When I use replace mode (the 'r' command) and then type the 'opt-a'
      all looks good, I get the free-floating macron, but then vim ignores
      the next letter completely: e.g. opt-a+i gives me just the macron not
      the 'i' with a macron. If I hit another 'i' then it goes into insert
      as you would expect.

      This works properly in the vim 7.2 shipped by apple in /usr/bin, and I
      would have sworn that it worked in previous MacVim versions, but I
      can't be sure.

      Can anyone point me at either what I doing wrong, or where I should
      report this as a bug?

      Andrew Gollan
      quī loquitur Latīnē et linguam quoque docet.

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Bjorn Winckler
      Go into the advanced prefs and untick the inline marked text option. The only downside is that with the experimental renderer you won t see the combining
      Message 2 of 2 , Nov 27, 2010
        Go into the advanced prefs and untick the "inline marked text" option. The only downside is that with the experimental renderer you won't see the combining character until the following character is typed (the default renderer doesn't exhibit this problem).

        Björn

        On Nov 27, 2010, at 6:48 AM, Andrew Gollan <tharoth@...> wrote:

        > I had a quick look here to see if this was already discussed, but
        > couldn't see anything.
        >
        > I am using MacVim 7.3-53 (the stable release as best I can tell). I
        > also use the US-Extended keyboard to enter a lot of vowels with
        > macrons (opt-a + vowel). I also convert a lot of texts without the
        > macrons to have them. (I am a Latin teacher).
        >
        > When I use replace mode (the 'r' command) and then type the 'opt-a'
        > all looks good, I get the free-floating macron, but then vim ignores
        > the next letter completely: e.g. opt-a+i gives me just the macron not
        > the 'i' with a macron. If I hit another 'i' then it goes into insert
        > as you would expect.
        >
        > This works properly in the vim 7.2 shipped by apple in /usr/bin, and I
        > would have sworn that it worked in previous MacVim versions, but I
        > can't be sure.
        >
        > Can anyone point me at either what I doing wrong, or where I should
        > report this as a bug?
        >
        > Andrew Gollan
        > quī loquitur Latīnē et linguam quoque docet.
        >
        > --
        > You received this message from the "vim_mac" maillist.
        > Do not top-post! Type your reply below the text you are replying to.
        > For more information, visit http://www.vim.org/maillist.php

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.