Loading ...
Sorry, an error occurred while loading the content.

Re: Echo problem in MacVim

Expand Messages
  • björn
    ... I haven t had a look at this but I m pretty sure it is the same problem as described in this thread from a few days ago:
    Message 1 of 3 , Nov 13, 2010
    • 0 Attachment
      On 13 November 2010 09:33, Yongwei Wu <wuyongwei@...> wrote:
      > Hi Bjorn,
      >
      > I found a weird problem in MacVim (it does not occur in console Vim).
      > I have a script to echo the function prototype when "(" is pressed:
      >
      > http://www.vim.org/scripts/script.php?script_id=1735
      >
      > In MacVim, I find that in certain cases nothing is echoed. This always
      > occurs when the script increases cmdheight to display content that is
      > more than one line. I reproduced this behaviour with the following
      > steps:
      >
      > 1) Rename my ~/.vim/plugin so that my scripts do not interfere.
      >
      > 2) Open a new MacVim window.
      >
      > 3) Enter ":so test.vim", while test.vim contains the following lines:
      > ----------------------------------------------
      > function! TestFunc()
      >  let &cmdheight=2
      >  echo "Ha ha"
      >  return ''
      > endfunction
      >
      > inoremap ( (<c-r>=TestFunc()<cr>
      > ----------------------------------------------
      >
      > 4) The first time I press "(", cmdheight increases, but nothing is
      > displayed. After that, "Ha ha" can be seen.
      >
      > I looks to me a bug in MacVim. Can you have a look?

      I haven't had a look at this but I'm pretty sure it is the same
      problem as described in this thread from a few days ago:

      http://groups.google.com/group/vim_mac/browse_thread/thread/a6c2e541a1382a8d?tvc=2

      So far I have not come up with a solution but I am thinking about it.

      Björn

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • dacresni
      ... Hey, what about the rest of us? ... So when you run it in MacVim/Contents/MacOS/Vim it works? I cant get it to work in vim 7.3 nor 7.2 -- You received this
      Message 2 of 3 , Nov 13, 2010
      • 0 Attachment
        > Hi Bjorn,
        >
        Hey, what about the rest of us?

        > I found a weird problem in MacVim (it does not occur in console Vim).
        > I have a script to echo the function prototype when "(" is pressed:

        So when you run it in MacVim/Contents/MacOS/Vim it works? I cant get
        it to work in vim 7.3 nor 7.2

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.