Loading ...
Sorry, an error occurred while loading the content.

eacute input on a mac in latex-suite

Expand Messages
  • Sébastien Barthélemy
    Hello, I m using vim and macvim (both from macports) on a mac os computer with an english keyboard. In order to input an eacute (é) character, I use the
    Message 1 of 2 , Nov 6, 2010
    • 0 Attachment
      Hello,

      I'm using vim and macvim (both from macports) on a mac os computer
      with an english keyboard. In order to input an eacute (é) character, I
      use the standard mac sequence : option+e e

      In vim, it works as expected. When I press option+e, it inserts a ´
      character with a yellow background, then when I press e, it is
      replaced with é.

      In MacVim, it works in insert mode, but it does not if I want to
      replace a character. Say I want to replace the character under the
      cursor with é, the option+e e sequence will do it in vim, but in
      MacVim the character will be replaced by ´ instead of é. I have the
      same problem if I want to replace the character with ú (option+e u).

      This is happening while editing plain text file. For latex files, with
      vim-latex-mode active, there is additional problem: I cannot insert
      (in insert mode) the é character. When I press option+e, ´ is
      inserted, then when I press e it is removed. This happens in both vim
      and macvim. But it works for ú !

      This last problem is the most annoying.

      Does anybody here have a suggestion?

      Thanks in advance,
      Sebastian

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • björn
      ... Go into the MacVim Advanced Preferences, deselect Draw marked text inline and restart MacVim. The downside to this is that when you e.g. type alt+e, e,
      Message 2 of 2 , Nov 7, 2010
      • 0 Attachment
        2010/11/6 Sébastien Barthélemy <barthelemy@...>:
        > Hello,
        >
        > I'm using vim and macvim (both from macports) on a mac os computer
        > with an english keyboard. In order to input an eacute (é) character, I
        > use the standard mac sequence : option+e e
        >
        > In vim, it works as expected. When I press option+e, it inserts a ´
        > character with a yellow background, then when I press e, it is
        > replaced with é.
        >
        > In MacVim, it works in insert mode, but it does not if I want to
        > replace a character. Say I want to replace the character under the
        > cursor with é, the option+e e sequence will do it in vim, but in
        > MacVim the character will be replaced by ´ instead of é. I have the
        > same problem if I want to replace the character with ú (option+e u).
        >
        > This is happening while editing plain text file. For latex files, with
        > vim-latex-mode active, there is additional problem: I cannot insert
        > (in insert mode) the é character. When I press option+e, ´ is
        > inserted, then when I press e it is removed. This happens in both vim
        > and macvim. But it works for ú !
        >
        > This last problem is the most annoying.
        >
        > Does anybody here have a suggestion?

        Go into the MacVim Advanced Preferences, deselect "Draw marked text
        inline" and restart MacVim.

        The downside to this is that when you e.g. type alt+e, e, you won't
        see any text until you hit that final e _if_ you are using the
        experimental renderer (the default renderer does not have this
        problem).

        Björn

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.