Loading ...
Sorry, an error occurred while loading the content.

Fullscreen, multiple monitors

Expand Messages
  • Chuck Harmston
    Hey all, I ve successfully gotten MacVim to go fullscreen on launch with the following bit in my vimrc: if has( gui_macvim ) set fuoptions=maxvert,maxhorz au
    Message 1 of 4 , Oct 5, 2010
    • 0 Attachment
      Hey all,

      I've successfully gotten MacVim to go fullscreen on launch with the following bit in my vimrc:

      if has("gui_macvim")

          set fuoptions=maxvert,maxhorz

          au GUIEnter * set fullscreen

      endif


      However, it always goes fullscreen on my primary monitor, and I would prefer for it to do so on my second monitor. I've unsuccessfully searched for a command or setting to control this. Have I missed anything?

      Thanks!

      Chuck

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • björn
      ... Hi Chuck, I can see the problem and I already have a patch in mind. I also notice that upon entering full screen, both screens fade to black and then the
      Message 2 of 4 , Oct 7, 2010
      • 0 Attachment
        On 5 October 2010 22:45, Chuck Harmston <chuck@...> wrote:
        > Hey all,
        > I've successfully gotten MacVim to go fullscreen on launch with the
        > following bit in my vimrc:
        >
        > if has("gui_macvim")
        >
        >     set fuoptions=maxvert,maxhorz
        >
        >     au GUIEnter * set fullscreen
        >
        > endif
        >
        > However, it always goes fullscreen on my primary monitor, and I would prefer
        > for it to do so on my second monitor. I've unsuccessfully searched for a
        > command or setting to control this. Have I missed anything?

        Hi Chuck,

        I can see the problem and I already have a patch in mind.

        I also notice that upon entering full screen, both screens fade to
        black and then the one without the window "pops back" which is rather
        unpleasant. Maybe I'll try to change it so that only the screen which
        will hold the window fade to black.

        Thanks for the report,
        Björn

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Nico Weber
        ... Do you know how to do that? I looked for a way to do this back then and didn t find anything iirc. Nico -- You received this message from the vim_mac
        Message 3 of 4 , Oct 7, 2010
        • 0 Attachment
          On 07.10.2010, at 13:05, björn wrote:

          > On 5 October 2010 22:45, Chuck Harmston <chuck@...> wrote:
          >> Hey all,
          >> I've successfully gotten MacVim to go fullscreen on launch with the
          >> following bit in my vimrc:
          >>
          >> if has("gui_macvim")
          >>
          >> set fuoptions=maxvert,maxhorz
          >>
          >> au GUIEnter * set fullscreen
          >>
          >> endif
          >>
          >> However, it always goes fullscreen on my primary monitor, and I would prefer
          >> for it to do so on my second monitor. I've unsuccessfully searched for a
          >> command or setting to control this. Have I missed anything?
          >
          > Hi Chuck,
          >
          > I can see the problem and I already have a patch in mind.
          >
          > I also notice that upon entering full screen, both screens fade to
          > black and then the one without the window "pops back" which is rather
          > unpleasant. Maybe I'll try to change it so that only the screen which
          > will hold the window fade to black.

          Do you know how to do that? I looked for a way to do this back then and didn't find anything iirc.

          Nico

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • björn
          ... I don t, no. If you didn t find it I guess I won t waste too much time looking -- thanks for letting me know. (I thought perhaps you didn t try with
          Message 4 of 4 , Oct 8, 2010
          • 0 Attachment
            On 8 October 2010 08:10, Nico Weber <nicolasweber@...> wrote:
            > On 07.10.2010, at 13:05, björn wrote:
            >
            >> On 5 October 2010 22:45, Chuck Harmston <chuck@...> wrote:
            >>> Hey all,
            >>> I've successfully gotten MacVim to go fullscreen on launch with the
            >>> following bit in my vimrc:
            >>>
            >>> if has("gui_macvim")
            >>>
            >>>     set fuoptions=maxvert,maxhorz
            >>>
            >>>     au GUIEnter * set fullscreen
            >>>
            >>> endif
            >>>
            >>> However, it always goes fullscreen on my primary monitor, and I would prefer
            >>> for it to do so on my second monitor. I've unsuccessfully searched for a
            >>> command or setting to control this. Have I missed anything?
            >>
            >> Hi Chuck,
            >>
            >> I can see the problem and I already have a patch in mind.
            >>
            >> I also notice that upon entering full screen, both screens fade to
            >> black and then the one without the window "pops back" which is rather
            >> unpleasant.  Maybe I'll try to change it so that only the screen which
            >> will hold the window fade to black.
            >
            > Do you know how to do that? I looked for a way to do this back then and didn't find anything iirc.

            I don't, no. If you didn't find it I guess I won't waste too much
            time looking -- thanks for letting me know. (I thought perhaps you
            didn't try with multiple monitors when you implemented this.)

            One thought that comes to mind however is to try the new APIs for full
            screen (introduced with 10.5?) but I'm not sure I want to fix
            something that isn't really broken.

            Björn

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          Your message has been successfully submitted and would be delivered to recipients shortly.