Loading ...
Sorry, an error occurred while loading the content.

Problems with accented characters in snapshot 54

Expand Messages
  • Cássio Marques
    Hello, After upgrading the snapshot 54 I can no longer type accented characters. When trying, I get only the accent, without the character. I double checked
    Message 1 of 5 , Oct 2, 2010
    • 0 Attachment
      Hello,

      After upgrading the snapshot 54 I can no longer type accented characters. When trying, I get only the accent, without the character. I double checked and it does work using other editors.

      I'm using OSX 10.6.4 and the U.S. International - PC keyboard layout.

      Any ideas?

      Thank you very much!

      --
      Cássio Marques

      Blog: http://cassiomarques.wordpress.com

      If you're writing code and you're not testing it, the code is wrong. I don't care if it does the right thing, and people need to understand this. If it works by accident, you're still wrong.
      Bryan Liles - Ruby Hoedown 2008

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • björn
      ... I see the problem -- it is indeed a regression introduced in snap 54. You can work around it by going into the Advanced Preferences and unticking Draw
      Message 2 of 5 , Oct 2, 2010
      • 0 Attachment
        2010/10/2 Cássio Marques <cassiommc@...>:
        > Hello,
        > After upgrading the snapshot 54 I can no longer type accented characters.
        > When trying, I get only the accent, without the character. I double checked
        > and it does work using other editors.
        > I'm using OSX 10.6.4 and the U.S. International - PC keyboard layout.
        > Any ideas?

        I see the problem -- it is indeed a regression introduced in snap 54.
        You can work around it by going into the "Advanced" Preferences and
        unticking "Draw marked text inline".

        I'll see what I can do to fix it.

        Björn

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • björn
        ... Fixed: http://github.com/b4winckler/macvim/commit/cc43c3f65c7e085eeb0532801532b7112ca00a93 Thanks for reporting this issue. Björn -- You received this
        Message 3 of 5 , Oct 2, 2010
        • 0 Attachment
          On 2 October 2010 18:55, björn <bjorn.winckler@...> wrote:
          > 2010/10/2 Cássio Marques <cassiommc@...>:
          >> Hello,
          >> After upgrading the snapshot 54 I can no longer type accented characters.
          >> When trying, I get only the accent, without the character. I double checked
          >> and it does work using other editors.
          >> I'm using OSX 10.6.4 and the U.S. International - PC keyboard layout.
          >> Any ideas?
          >
          > I see the problem -- it is indeed a regression introduced in snap 54.
          > You can work around it by going into the "Advanced" Preferences and
          > unticking "Draw marked text inline".
          >
          > I'll see what I can do to fix it.

          Fixed:

          http://github.com/b4winckler/macvim/commit/cc43c3f65c7e085eeb0532801532b7112ca00a93

          Thanks for reporting this issue.

          Björn

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Cássio Marques
          Thank you very much for the quick fix! ... -- Cássio Marques Blog: http://cassiomarques.wordpress.com If you re writing code and you re not testing it, the
          Message 4 of 5 , Oct 2, 2010
          • 0 Attachment
            Thank you very much for the quick fix!

            On Sat, Oct 2, 2010 at 2:23 PM, björn <bjorn.winckler@...> wrote:
            On 2 October 2010 18:55, björn <bjorn.winckler@...> wrote:
            > 2010/10/2 Cássio Marques <cassiommc@...>:
            >> Hello,
            >> After upgrading the snapshot 54 I can no longer type accented characters.
            >> When trying, I get only the accent, without the character. I double checked
            >> and it does work using other editors.
            >> I'm using OSX 10.6.4 and the U.S. International - PC keyboard layout.
            >> Any ideas?
            >
            > I see the problem -- it is indeed a regression introduced in snap 54.
            > You can work around it by going into the "Advanced" Preferences and
            > unticking "Draw marked text inline".
            >
            > I'll see what I can do to fix it.

            Fixed:

            http://github.com/b4winckler/macvim/commit/cc43c3f65c7e085eeb0532801532b7112ca00a93

            Thanks for reporting this issue.

            Björn

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php



            --
            Cássio Marques

            Blog: http://cassiomarques.wordpress.com

            If you're writing code and you're not testing it, the code is wrong. I don't care if it does the right thing, and people need to understand this. If it works by accident, you're still wrong.
            Bryan Liles - Ruby Hoedown 2008

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Cássio Marques
            Just built it from source and reinstalled and it s working now, thank you Björn! 2010/10/2 Cássio Marques ... -- Cássio Marques Blog:
            Message 5 of 5 , Oct 2, 2010
            • 0 Attachment
              Just built it from source and reinstalled and it's working now, thank you  Björn!

              2010/10/2 Cássio Marques <cassiommc@...>
              Thank you very much for the quick fix!


              On Sat, Oct 2, 2010 at 2:23 PM, björn <bjorn.winckler@...> wrote:
              On 2 October 2010 18:55, björn <bjorn.winckler@...> wrote:
              > 2010/10/2 Cássio Marques <cassiommc@...>:
              >> Hello,
              >> After upgrading the snapshot 54 I can no longer type accented characters.
              >> When trying, I get only the accent, without the character. I double checked
              >> and it does work using other editors.
              >> I'm using OSX 10.6.4 and the U.S. International - PC keyboard layout.
              >> Any ideas?
              >
              > I see the problem -- it is indeed a regression introduced in snap 54.
              > You can work around it by going into the "Advanced" Preferences and
              > unticking "Draw marked text inline".
              >
              > I'll see what I can do to fix it.

              Fixed:

              http://github.com/b4winckler/macvim/commit/cc43c3f65c7e085eeb0532801532b7112ca00a93

              Thanks for reporting this issue.

              Björn

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php



              --
              Cássio Marques

              Blog: http://cassiomarques.wordpress.com

              If you're writing code and you're not testing it, the code is wrong. I don't care if it does the right thing, and people need to understand this. If it works by accident, you're still wrong.
              Bryan Liles - Ruby Hoedown 2008



              --
              Cássio Marques

              Blog: http://cassiomarques.wordpress.com

              If you're writing code and you're not testing it, the code is wrong. I don't care if it does the right thing, and people need to understand this. If it works by accident, you're still wrong.
              Bryan Liles - Ruby Hoedown 2008

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            Your message has been successfully submitted and would be delivered to recipients shortly.