Loading ...
Sorry, an error occurred while loading the content.
 

Re: Building with GTK

Expand Messages
  • björn
    ... I recognize this one: the netbeans.pro header assumes that the GUI headers have been pulled in but due to the NO_X11_INCLUDES in the top of gui_mac_conv.c
    Message 1 of 5 , Aug 2, 2010
      On 2 August 2010 22:10, Hisashi T Fujinaka wrote:
      >
      > Now I'm stuck at:
      >
      > gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK  -I/sw64/include/pango-1.0
      > -I/sw64/lib/fontconfig2/include -I/sw64/include/freetype2 -I/sw64/include
      > -I/sw64/include/gtk-2.0 -I/sw64/lib/gtk-2.0/include -I/sw64/include/atk-1.0
      > -I/sw64/include/cairo -I/sw64/include/glib-2.0 -I/sw64/lib/glib-2.0/include
      > -I/usr/X11R6/include -I/usr/X11/include -I/sw64/include -DMACOS_X_UNIX
      > -no-cpp-precomp  -O2 -fno-strength-reduce -Wall -D_FORTIFY_SOURCE=1
      >  -I/usr/X11/include      -o objects/os_mac_conv.o os_mac_conv.c
      > In file included from proto.h:208,
      >                 from vim.h:1919,
      >                 from os_mac_conv.c:17:
      > proto/netbeans.pro:10: error: expected ')' before '*' token
      > make: *** [objects/os_mac_conv.o] Error 1

      I recognize this one: the netbeans.pro header assumes that the GUI
      headers have been pulled in but due to the NO_X11_INCLUDES in the top
      of gui_mac_conv.c this does not happen (FEAT_GUI never gets defined in
      vim.h). Somehow you have to make sure FEAT_GUI gets defined in vim.h.
      Not sure what the best solution to this is...

      If you manage to solve this riddle, please post a patch. Maybe the
      best solution is simply to not compile os_mac_conv.c when GTK is
      enabled.

      > I'm unfamiliar with ".pro" files.

      It's just a header file containing function prototypes.


      Björn

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Hisashi T Fujinaka
      ... I cheated and edited the Makefile to use --disable-darwin and everything works again. I m guessing that s the right answer. -- Hisashi T Fujinaka -
      Message 2 of 5 , Aug 3, 2010
        On Mon, 2 Aug 2010, bj?rn wrote:

        > On 2 August 2010 22:10, Hisashi T Fujinaka wrote:
        >>
        >> Now I'm stuck at:
        >>
        >> gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -I/sw64/include/pango-1.0
        >> -I/sw64/lib/fontconfig2/include -I/sw64/include/freetype2 -I/sw64/include
        >> -I/sw64/include/gtk-2.0 -I/sw64/lib/gtk-2.0/include -I/sw64/include/atk-1.0
        >> -I/sw64/include/cairo -I/sw64/include/glib-2.0 -I/sw64/lib/glib-2.0/include
        >> -I/usr/X11R6/include -I/usr/X11/include -I/sw64/include -DMACOS_X_UNIX
        >> -no-cpp-precomp -O2 -fno-strength-reduce -Wall -D_FORTIFY_SOURCE=1
        >> -I/usr/X11/include -o objects/os_mac_conv.o os_mac_conv.c
        >> In file included from proto.h:208,
        >> from vim.h:1919,
        >> from os_mac_conv.c:17:
        >> proto/netbeans.pro:10: error: expected ')' before '*' token
        >> make: *** [objects/os_mac_conv.o] Error 1
        >
        > I recognize this one: the netbeans.pro header assumes that the GUI
        > headers have been pulled in but due to the NO_X11_INCLUDES in the top
        > of gui_mac_conv.c this does not happen (FEAT_GUI never gets defined in
        > vim.h). Somehow you have to make sure FEAT_GUI gets defined in vim.h.
        > Not sure what the best solution to this is...
        >
        > If you manage to solve this riddle, please post a patch. Maybe the
        > best solution is simply to not compile os_mac_conv.c when GTK is
        > enabled.
        >
        >> I'm unfamiliar with ".pro" files.
        >
        > It's just a header file containing function prototypes.

        I cheated and edited the Makefile to use --disable-darwin and everything
        works again. I'm guessing that's the right answer.

        --
        Hisashi T Fujinaka - htodd@...
        BSEE(6/86) + BSChem(3/95) + BAEnglish(8/95) + MSCS(8/03) + $2.50 = latte

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • björn
        ... Can you patch configure.in so that darwin is automatically disabled when GTK is enabled? Björn -- You received this message from the vim_mac maillist.
        Message 3 of 5 , Aug 3, 2010
          >
          > I cheated and edited the Makefile to use --disable-darwin and everything
          > works again. I'm guessing that's the right answer.

          Can you patch configure.in so that darwin is automatically disabled
          when GTK is enabled?

          Björn

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.