Loading ...
Sorry, an error occurred while loading the content.
 

Re: [OT] FuzzyFinder and having it search any level deep?

Expand Messages
  • Rick R
    ... Found a post on another site. Solution append **/ after FuFile so my mapping is now: map f :FufFile **/ things are fine now. -- You received
    Message 1 of 7 , Jul 6, 2010
      On Tue, Jul 6, 2010 at 11:52 AM, Rick R <rickcr@...> wrote:
       What I want is the behavior that I get in all the IDEs where I have a project opened and I can just hit a shortcut key and start typing the name of a file and it prompts me with choices of files that match the name, regardless of what directory they are in.
       


      Found a post on another site. Solution append **/ after FuFile

      so my mapping is now:

      map <leader>f :FufFile **/<CR>

      things are fine now.

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Lyle
      ... I m trying to do some mappings to match Eclipse (while yearning for the day I can embed Vim in it) and am having a little trouble with the Apple command
      Message 2 of 7 , Jul 7, 2010
          Rick R <rickcr@...> Jul 06 08:02PM -0400 ^
           
          > project opened and I can just hit a shortcut key and start typing the name
          > of a file and it prompts me with choices of files that match the name,
          > regardless of what directory they are in.
           
          Found a post on another site. Solution append **/ after FuFile
           
          so my mapping is now:
           
          map <leader>f :FufFile **/<CR>
           
          things are fine now.
        Also sort of OT, but semi-related so I'll ask here in case anyone knows. I'm trying to do some mappings to match Eclipse (while yearning for the day I can embed Vim in it) and am having a little trouble with the Apple command key.

        Specifically, I'm trying to map Shift-Command-R (Eclipse's "open resource") to something similar to the FuzzyFinder command above. I can do "map <S-r> :e **/" or "map <D-r> :e **/" for shift-r and command-r, respectively, but when I try "map <S-D-r> :e **/", the command just puts me in replace mode.

        Any ideas?

        Thanks,
        Lyle

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Rick R
        ... By the way, this plugin seemed to work pretty nicely in Eclipse back when I used Eclipse http://www.viplugin.com/viplugin/. (I use IDEA now, has vim mode
        Message 3 of 7 , Jul 7, 2010
          On Wed, Jul 7, 2010 at 10:11 AM, Lyle <lyle2.0@...> wrote:
             
          (while yearning for the day I can embed Vim in it)

          By the way, this plugin seemed to work pretty nicely in Eclipse back when I used Eclipse http://www.viplugin.com/viplugin/. (I use IDEA now, has vim mode through a plugin as well.) 

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • björn
          ... Try map :e **/ That is, capitalize the R instead of adding the S- flag when using mappings. (Yes, it is a bit odd...) Björn -- You
          Message 4 of 7 , Jul 8, 2010
            On 7 July 2010 16:11, Lyle wrote:
            > Specifically, I'm trying to map Shift-Command-R (Eclipse's "open resource")
            > to something similar to the FuzzyFinder command above. I can do "map <S-r>
            > :e **/" or "map <D-r> :e **/" for shift-r and command-r, respectively, but
            > when I try "map <S-D-r> :e **/", the command just puts me in replace mode.
            > Any ideas?

            Try

            map <D-R> :e **/"

            That is, capitalize the "R" instead of adding the "S-" flag when using
            <D-..> mappings. (Yes, it is a bit odd...)

            Björn

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Lyle
            ... Thanks. I ve tried several plugins for Eclipse, with eclim being the best option for me so far, but unfortunately it doesn t support embedding gvim as an
            Message 5 of 7 , Jul 8, 2010
              > Rick R <rickcr@...> Jul 08 01:03AM -0400
              >
              > >> (while yearning for the day I can embed Vim in it)
              >
              > By the way, this plugin seemed to work pretty nicely in Eclipse back when I
              > used Eclipse http://www.viplugin.com/viplugin/. (I use IDEA now, has vim
              > mode through a plugin as well.)

              Thanks. I've tried several plugins for Eclipse, with eclim being the
              best option for me so far, but unfortunately it doesn't support
              embedding gvim as an Eclipse editor on OS X. I think my next move is
              to see what's available for IDEA and Netbeans (I've heard good things
              about jVi there).

              -Lyle

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Lyle
              ... Fantastic, that works. Thanks! -Lyle -- You received this message from the vim_mac maillist. Do not top-post! Type your reply below the text you are
              Message 6 of 7 , Jul 9, 2010
                > björn <bjorn.winckler@...> Jul 08 01:37PM +0200 ^
                >
                > On 7 July 2010 16:11, Lyle wrote:
                >> :e **/" or "map <D-r> :e **/" for shift-r and command-r, respectively, but
                >> when I try "map <S-D-r> :e **/", the command just puts me in replace mode.
                >> Any ideas?
                >
                > Try
                >
                > map <D-R> :e **/"
                >
                > That is, capitalize the "R" instead of adding the "S-" flag when using
                > <D-..> mappings. (Yes, it is a bit odd...)
                >
                > Björn

                Fantastic, that works. Thanks!

                -Lyle

                --
                You received this message from the "vim_mac" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              Your message has been successfully submitted and would be delivered to recipients shortly.