Loading ...
Sorry, an error occurred while loading the content.
 

Re: MacVim 7.3a BETA - Intel/10.6+

Expand Messages
  • Keyan
    just checked. worked fine for me. i first checked the option and restartet. that did not work. but when i chose the check for updated … menu, everything
    Message 1 of 28 , Jun 10, 2010
      just checked. worked fine for me. i first checked the option and restartet. that did not work. but when i chose the "check for updated …" menu, everything worked perfectly. may be should have waited a bit longer for the pop-up to appear by itself, but i was to impatient :)

      regards,
      keyan

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Craig
      ... Am I the only one who finds they can regularly out-type MacGVim? It feels noticeably sluggish and slow and often draws the text long after I ve typed it.
      Message 2 of 28 , Jun 11, 2010
        On Jun 9, 6:43 pm, björn <bjorn.winck...@...> wrote:
        > On 6 June 2010 19:17, björn wrote:
        >
        >
        >
        > > In preparation for the release of Vim 7.3 I have uploaded a version of
        > > MacVim based on Vim 7.3a BETA (this includes all commits to the vim73
        > > branch up to and including 5b8ff51).  Get it here:
        >
        > >http://github.com/b4winckler/macvim/downloads
        >
        > > This build requires an Intel Mac running 10.6 or later.  When 7.3 is
        > > released I will build another version that runs on earlier versions of
        > > OS X and which supports PPC.  (Note: This build includes support for
        > > automatic updating so you'll be notified of new builds, including when
        > > 7.3 is released.)
        >
        > I've just updated this build so the automatic updating should tell
        > anybody who downloaded it that there's a new version now.  Please
        > check if the automatic updating works (it did for me).
        >
        > Björn
        >
        > P.S. The first build (52.1) had a crash bug in :grep (or :vimgrep),
        > this build (52.2) contains a fix (among other things).

        Am I the only one who finds they can regularly out-type MacGVim?
        It feels noticeably sluggish and slow and often draws the text long
        after I've typed it.
        I'm using the 52.2 build with experimental rendering turned, using
        Andale Mono:h13.00 as my font.
        I just tried 7.2 and it's not that much faster.
        Longer lines seem to exacerbate the problem.
        I've for the insert mode line highlight enabled.

        -C

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Wy Mitbbs
        You are not alone. The big file (300 lines) will slow down McVim like hell for me. vim in Terminal is fine for the same file. It was working good back to the
        Message 3 of 28 , Jun 11, 2010
          You are not alone. The big file (300 lines) will slow down McVim like hell for me. vim in Terminal is fine for the same file.

          It was working good back to the Mar 05 snapshot. I have no idea why....
          On Jun 11, 2010, at 8:41 AM, Craig wrote:

          > On Jun 9, 6:43 pm, björn <bjorn.winck...@...> wrote:
          >> On 6 June 2010 19:17, björn wrote:
          >>
          >>
          >>
          >>> In preparation for the release of Vim 7.3 I have uploaded a version of
          >>> MacVim based on Vim 7.3a BETA (this includes all commits to the vim73
          >>> branch up to and including 5b8ff51). Get it here:
          >>
          >>> http://github.com/b4winckler/macvim/downloads
          >>
          >>> This build requires an Intel Mac running 10.6 or later. When 7.3 is
          >>> released I will build another version that runs on earlier versions of
          >>> OS X and which supports PPC. (Note: This build includes support for
          >>> automatic updating so you'll be notified of new builds, including when
          >>> 7.3 is released.)
          >>
          >> I've just updated this build so the automatic updating should tell
          >> anybody who downloaded it that there's a new version now. Please
          >> check if the automatic updating works (it did for me).
          >>
          >> Björn
          >>
          >> P.S. The first build (52.1) had a crash bug in :grep (or :vimgrep),
          >> this build (52.2) contains a fix (among other things).
          >
          > Am I the only one who finds they can regularly out-type MacGVim?
          > It feels noticeably sluggish and slow and often draws the text long
          > after I've typed it.
          > I'm using the 52.2 build with experimental rendering turned, using
          > Andale Mono:h13.00 as my font.
          > I just tried 7.2 and it's not that much faster.
          > Longer lines seem to exacerbate the problem.
          > I've for the insert mode line highlight enabled.
          >
          > -C
          >
          > --
          > You received this message from the "vim_mac" maillist.
          > Do not top-post! Type your reply below the text you are replying to.
          > For more information, visit http://www.vim.org/maillist.php

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Daniel Corrêa
          In my MacVim, i m right now working in a 2500+ line document, performing macros and substitutes and all sorts, and no slowing whatsoever. Weird... Cheers, ...
          Message 4 of 28 , Jun 11, 2010
            In my MacVim, i'm right now working in a 2500+ line document, performing
            macros and substitutes and all sorts, and no slowing whatsoever. Weird...

            Cheers,

            On 11/06/10 11:38, Wy Mitbbs wrote:
            > You are not alone. The big file (300 lines) will slow down McVim like hell for me. vim in Terminal is fine for the same file.
            >
            > It was working good back to the Mar 05 snapshot. I have no idea why....
            > On Jun 11, 2010, at 8:41 AM, Craig wrote:
            >
            >
            >> On Jun 9, 6:43 pm, björn<bjorn.winck...@...> wrote:
            >>
            >>> On 6 June 2010 19:17, björn wrote:
            >>>
            >>>
            >>>
            >>>
            >>>> In preparation for the release of Vim 7.3 I have uploaded a version of
            >>>> MacVim based on Vim 7.3a BETA (this includes all commits to the vim73
            >>>> branch up to and including 5b8ff51). Get it here:
            >>>>
            >>>
            >>>> http://github.com/b4winckler/macvim/downloads
            >>>>
            >>>
            >>>> This build requires an Intel Mac running 10.6 or later. When 7.3 is
            >>>> released I will build another version that runs on earlier versions of
            >>>> OS X and which supports PPC. (Note: This build includes support for
            >>>> automatic updating so you'll be notified of new builds, including when
            >>>> 7.3 is released.)
            >>>>
            >>> I've just updated this build so the automatic updating should tell
            >>> anybody who downloaded it that there's a new version now. Please
            >>> check if the automatic updating works (it did for me).
            >>>
            >>> Björn
            >>>
            >>> P.S. The first build (52.1) had a crash bug in :grep (or :vimgrep),
            >>> this build (52.2) contains a fix (among other things).
            >>>
            >> Am I the only one who finds they can regularly out-type MacGVim?
            >> It feels noticeably sluggish and slow and often draws the text long
            >> after I've typed it.
            >> I'm using the 52.2 build with experimental rendering turned, using
            >> Andale Mono:h13.00 as my font.
            >> I just tried 7.2 and it's not that much faster.
            >> Longer lines seem to exacerbate the problem.
            >> I've for the insert mode line highlight enabled.
            >>
            >> -C
            >>
            >> --
            >> You received this message from the "vim_mac" maillist.
            >> Do not top-post! Type your reply below the text you are replying to.
            >> For more information, visit http://www.vim.org/maillist.php
            >>
            >

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Wy Mitbbs
            Do you think I should somehow remove all MacVim.app related file and retry? Which files need to be deleted? Thanks Yi ... -- You received this message from the
            Message 5 of 28 , Jun 11, 2010
              Do you think I should somehow remove all MacVim.app related file and retry? Which files need to be deleted?

              Thanks

              Yi

              On Jun 11, 2010, at 9:49 AM, Daniel Corrêa wrote:

              > In my MacVim, i'm right now working in a 2500+ line document, performing macros and substitutes and all sorts, and no slowing whatsoever. Weird...
              >
              > Cheers,
              >
              > On 11/06/10 11:38, Wy Mitbbs wrote:
              >> You are not alone. The big file (300 lines) will slow down McVim like hell for me. vim in Terminal is fine for the same file.
              >>
              >> It was working good back to the Mar 05 snapshot. I have no idea why....
              >> On Jun 11, 2010, at 8:41 AM, Craig wrote:
              >>
              >>
              >>> On Jun 9, 6:43 pm, björn<bjorn.winck...@...> wrote:
              >>>
              >>>> On 6 June 2010 19:17, björn wrote:
              >>>>
              >>>>
              >>>>
              >>>>
              >>>>> In preparation for the release of Vim 7.3 I have uploaded a version of
              >>>>> MacVim based on Vim 7.3a BETA (this includes all commits to the vim73
              >>>>> branch up to and including 5b8ff51). Get it here:
              >>>>>
              >>>>
              >>>>> http://github.com/b4winckler/macvim/downloads
              >>>>>
              >>>>
              >>>>> This build requires an Intel Mac running 10.6 or later. When 7.3 is
              >>>>> released I will build another version that runs on earlier versions of
              >>>>> OS X and which supports PPC. (Note: This build includes support for
              >>>>> automatic updating so you'll be notified of new builds, including when
              >>>>> 7.3 is released.)
              >>>>>
              >>>> I've just updated this build so the automatic updating should tell
              >>>> anybody who downloaded it that there's a new version now. Please
              >>>> check if the automatic updating works (it did for me).
              >>>>
              >>>> Björn
              >>>>
              >>>> P.S. The first build (52.1) had a crash bug in :grep (or :vimgrep),
              >>>> this build (52.2) contains a fix (among other things).
              >>>>
              >>> Am I the only one who finds they can regularly out-type MacGVim?
              >>> It feels noticeably sluggish and slow and often draws the text long
              >>> after I've typed it.
              >>> I'm using the 52.2 build with experimental rendering turned, using
              >>> Andale Mono:h13.00 as my font.
              >>> I just tried 7.2 and it's not that much faster.
              >>> Longer lines seem to exacerbate the problem.
              >>> I've for the insert mode line highlight enabled.
              >>>
              >>> -C
              >>>
              >>> --
              >>> You received this message from the "vim_mac" maillist.
              >>> Do not top-post! Type your reply below the text you are replying to.
              >>> For more information, visit http://www.vim.org/maillist.php
              >>>
              >>
              >
              > --
              > You received this message from the "vim_mac" maillist.
              > Do not top-post! Type your reply below the text you are replying to.
              > For more information, visit http://www.vim.org/maillist.php
              > <dnlcorrea.vcf>

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Daniel Corrêa
              Hey, Transparency fades letters and numbers that just disappeared instead of making my window transparent. Did I change some variable or is this a 52.2 bug?
              Message 6 of 28 , Jun 11, 2010
                Hey,

                "Transparency" fades letters and numbers that just disappeared instead
                of making my window transparent. Did I change some variable or is this a
                52.2 bug?

                Cheers,

                On 11/06/10 11:58, Wy Mitbbs wrote:
                > Do you think I should somehow remove all MacVim.app related file and retry? Which files need to be deleted?
                >
                > Thanks
                >
                > Yi
                >
                > On Jun 11, 2010, at 9:49 AM, Daniel Corrêa wrote:
                >
                >
                >> In my MacVim, i'm right now working in a 2500+ line document, performing macros and substitutes and all sorts, and no slowing whatsoever. Weird...
                >>
                >> Cheers,
                >>
                >> On 11/06/10 11:38, Wy Mitbbs wrote:
                >>
                >>> You are not alone. The big file (300 lines) will slow down McVim like hell for me. vim in Terminal is fine for the same file.
                >>>
                >>> It was working good back to the Mar 05 snapshot. I have no idea why....
                >>> On Jun 11, 2010, at 8:41 AM, Craig wrote:
                >>>
                >>>
                >>>
                >>>> On Jun 9, 6:43 pm, björn<bjorn.winck...@...> wrote:
                >>>>
                >>>>
                >>>>> On 6 June 2010 19:17, björn wrote:
                >>>>>
                >>>>>
                >>>>>
                >>>>>
                >>>>>
                >>>>>> In preparation for the release of Vim 7.3 I have uploaded a version of
                >>>>>> MacVim based on Vim 7.3a BETA (this includes all commits to the vim73
                >>>>>> branch up to and including 5b8ff51). Get it here:
                >>>>>>
                >>>>>>
                >>>>>
                >>>>>
                >>>>>> http://github.com/b4winckler/macvim/downloads
                >>>>>>
                >>>>>>
                >>>>>
                >>>>>
                >>>>>> This build requires an Intel Mac running 10.6 or later. When 7.3 is
                >>>>>> released I will build another version that runs on earlier versions of
                >>>>>> OS X and which supports PPC. (Note: This build includes support for
                >>>>>> automatic updating so you'll be notified of new builds, including when
                >>>>>> 7.3 is released.)
                >>>>>>
                >>>>>>
                >>>>> I've just updated this build so the automatic updating should tell
                >>>>> anybody who downloaded it that there's a new version now. Please
                >>>>> check if the automatic updating works (it did for me).
                >>>>>
                >>>>> Björn
                >>>>>
                >>>>> P.S. The first build (52.1) had a crash bug in :grep (or :vimgrep),
                >>>>> this build (52.2) contains a fix (among other things).
                >>>>>
                >>>>>
                >>>> Am I the only one who finds they can regularly out-type MacGVim?
                >>>> It feels noticeably sluggish and slow and often draws the text long
                >>>> after I've typed it.
                >>>> I'm using the 52.2 build with experimental rendering turned, using
                >>>> Andale Mono:h13.00 as my font.
                >>>> I just tried 7.2 and it's not that much faster.
                >>>> Longer lines seem to exacerbate the problem.
                >>>> I've for the insert mode line highlight enabled.
                >>>>
                >>>> -C
                >>>>
                >>>> --
                >>>> You received this message from the "vim_mac" maillist.
                >>>> Do not top-post! Type your reply below the text you are replying to.
                >>>> For more information, visit http://www.vim.org/maillist.php
                >>>>
                >>>>
                >>>
                >>>
                >> --
                >> You received this message from the "vim_mac" maillist.
                >> Do not top-post! Type your reply below the text you are replying to.
                >> For more information, visit http://www.vim.org/maillist.php
                >> <dnlcorrea.vcf>
                >>
                >

                --
                You received this message from the "vim_mac" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • björn
                ... Try going through the first step at http://code.google.com/p/macvim/wiki/ReportingBugs My guess is that you have some option/autocommand enabled that slows
                Message 7 of 28 , Jun 11, 2010
                  On 11 June 2010 16:38, Wy Mitbbs wrote:
                  > On Jun 11, 2010, at 8:41 AM, Craig wrote:
                  >>
                  >> Am I the only one who finds they can regularly out-type MacGVim?
                  >> It feels noticeably sluggish and slow and often draws the text long
                  >> after I've typed it.
                  >> I'm using the 52.2 build with experimental rendering turned, using
                  >> Andale Mono:h13.00 as my font.
                  >> I just tried 7.2 and it's not that much faster.
                  >> Longer lines seem to exacerbate the problem.
                  >> I've for the insert mode line highlight enabled.
                  > You are not alone. The big file (300 lines) will slow down McVim like hell for me. vim in Terminal is fine for the same file.
                  >
                  > It was working good back to the Mar 05 snapshot. I have no idea why....

                  Try going through the first step at

                  http://code.google.com/p/macvim/wiki/ReportingBugs

                  My guess is that you have some option/autocommand enabled that slows
                  things down...it would be good to know which one. (I know that
                  'cursorline' as well as folding can slow things down so that's a good
                  place to start.)

                  Björn

                  --
                  You received this message from the "vim_mac" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • björn
                  ... Try enabling the Experimental Renderer in the Advanced preferences. Does that help? (I know that the default renderer has some problems with transparency
                  Message 8 of 28 , Jun 11, 2010
                    2010/6/11 Daniel Corrêa:
                    >
                    > "Transparency" fades letters and numbers that just disappeared instead of
                    > making my window transparent. Did I change some variable or is this a 52.2
                    > bug?

                    Try enabling the "Experimental Renderer" in the Advanced preferences.
                    Does that help?

                    (I know that the default renderer has some problems with transparency
                    unless I link against the 10.5 SDK, but in this release I linked
                    against 10.6.)

                    Björn

                    --
                    You received this message from the "vim_mac" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  • Wy Mitbbs
                    yes! it s the folding. Thank you very much! But is this because it is just slow, or something we(or you) can do about it? Thanks yi ... -- You received this
                    Message 9 of 28 , Jun 11, 2010
                      yes! it's the folding. Thank you very much! But is this because it is just slow, or something we(or you) can do about it?
                      Thanks

                      yi
                      On Jun 11, 2010, at 1:01 PM, björn wrote:

                      > On 11 June 2010 16:38, Wy Mitbbs wrote:
                      >> On Jun 11, 2010, at 8:41 AM, Craig wrote:
                      >>>
                      >>> Am I the only one who finds they can regularly out-type MacGVim?
                      >>> It feels noticeably sluggish and slow and often draws the text long
                      >>> after I've typed it.
                      >>> I'm using the 52.2 build with experimental rendering turned, using
                      >>> Andale Mono:h13.00 as my font.
                      >>> I just tried 7.2 and it's not that much faster.
                      >>> Longer lines seem to exacerbate the problem.
                      >>> I've for the insert mode line highlight enabled.
                      >> You are not alone. The big file (300 lines) will slow down McVim like hell for me. vim in Terminal is fine for the same file.
                      >>
                      >> It was working good back to the Mar 05 snapshot. I have no idea why....
                      >
                      > Try going through the first step at
                      >
                      > http://code.google.com/p/macvim/wiki/ReportingBugs
                      >
                      > My guess is that you have some option/autocommand enabled that slows
                      > things down...it would be good to know which one. (I know that
                      > 'cursorline' as well as folding can slow things down so that's a good
                      > place to start.)
                      >
                      > Björn
                      >
                      > --
                      > You received this message from the "vim_mac" maillist.
                      > Do not top-post! Type your reply below the text you are replying to.
                      > For more information, visit http://www.vim.org/maillist.php

                      --
                      You received this message from the "vim_mac" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                    • Daniel Corrêa
                      Yeah, that did the trick! Thanks, Björn. ... -- You received this message from the vim_mac maillist. Do not top-post! Type your reply below the text you are
                      Message 10 of 28 , Jun 11, 2010
                        Yeah, that did the trick!

                        Thanks, Björn.

                        On 11/06/10 15:02, björn wrote:
                        > 2010/6/11 Daniel Corrêa:
                        >
                        >> "Transparency" fades letters and numbers that just disappeared instead of
                        >> making my window transparent. Did I change some variable or is this a 52.2
                        >> bug?
                        >>
                        > Try enabling the "Experimental Renderer" in the Advanced preferences.
                        > Does that help?
                        >
                        > (I know that the default renderer has some problems with transparency
                        > unless I link against the 10.5 SDK, but in this release I linked
                        > against 10.6.)
                        >
                        > Björn
                        >
                        >

                        --
                        You received this message from the "vim_mac" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php
                      • John Beckett
                        NEW USERS ON THIS MAILING LIST: Please bottom post on this list. Quote a small (relevant) part of the message you are replying to, and put your text
                        Message 11 of 28 , Jun 11, 2010
                          NEW USERS ON THIS MAILING LIST:

                          Please bottom post on this list. Quote a small (relevant) part
                          of the message you are replying to, and put your text underneath.
                          Delete text that is not needed to understand your reply

                          See
                          http://groups.google.com/group/vim_use/web/vim-information
                          The footer below each message ("Do not top-post!").

                          John

                          --
                          You received this message from the "vim_mac" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php
                        • Tony Mechelynck
                          ... For those who would like to know _before_ installing it, here s a summary: * Changed - Extra and language sources are planned to be merged into the main
                          Message 12 of 28 , Jul 5, 2010
                            On Jun 8, 10:11 pm, Wy Mitbbs <wy.mit...@...> wrote:
                            > Where can I find a Change log of vim 7.3? Thank you

                            For those who would like to know _before_ installing it, here's a
                            summary:

                            * Changed
                            - Extra and language sources are planned to be merged into the main
                            Unix source archive. At the moment there is no source archive yet but
                            a Mercurial repository is already in place.
                            - After recovery, if the buffer differs from the file on disk it is
                            now set as 'modified'
                            - When exiting because of a deadly signal and v:dying is >=2,
                            autocommands are skipped

                            * Added
                            - Persistent undo (partly by J. Lewis)
                            - 'relativenumber' option (M. Heidelberg)
                            - Blowfish encryption (stronger) (mostly by M. Ahmed).
                            ("Traditional" Vim encryption is still supported by the same
                            executable)
                            - Netbeans in a terminal (X. de Gaye)
                            - Ten more floating-point functions (W. McCarthy)
                            - gettabvar() and settabvar() (Y. Lakshmanan)
                            - new syntax and filetype plugins (TODO)
                            - new spelling dictionaries (Breton by D. Pellé, others TODO)
                            - Support GDK_SUPER_MASK for GTK on Mac. (S. Schulz)

                            * Removed
                            - (old) GTK1 GUI support

                            * Fixed
                            - Several bugs

                            --
                            You received this message from the "vim_mac" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php
                          • Tony Mechelynck
                            I forgot: * Added - conceal / ownsyntax options (V. Negri) -- You received this message from the vim_mac maillist. Do not top-post! Type your reply below
                            Message 13 of 28 , Jul 5, 2010
                              I forgot:
                              * Added
                              - 'conceal' / 'ownsyntax' options (V. Negri)

                              --
                              You received this message from the "vim_mac" maillist.
                              Do not top-post! Type your reply below the text you are replying to.
                              For more information, visit http://www.vim.org/maillist.php
                            Your message has been successfully submitted and would be delivered to recipients shortly.