Loading ...
Sorry, an error occurred while loading the content.

File creation/access timestamp

Expand Messages
  • mav
    Hello there fellow VIMmers! I have a small problem with MacVim + Extendmac s Flow app (great FTP client) combo. When I open some file remotely in Flow, it
    Message 1 of 2 , Jun 9, 2010
    • 0 Attachment
      Hello there fellow VIMmers!

      I have a small problem with MacVim + Extendmac's Flow app (great FTP
      client) combo. When I open some file remotely in Flow, it opens fine
      in MacVim as I've set it in the preferences. But when I save the file,
      it doesn't always get updated in the client and sent to server.

      I noticed that MacVim changes not only "last modified" timestamp of
      saved file, but also creation and access timestamp. I figure that this
      could confuse Flow app and prevent it from updating the file on the
      server. Is there any way to disable this behaviour (eg. to only update
      the last modified timestamp)?

      Best Regards,
      Maciej "mav" Trębacz.

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • björn
      ... This is due to the way Vim saves files (it renames the original file for backup, then saves a new file, then finally deletes the backup). ... See, :h
      Message 2 of 2 , Jun 10, 2010
      • 0 Attachment
        On 9 June 2010 13:38, mav wrote:
        >
        > I have a small problem with MacVim + Extendmac's Flow app (great FTP
        > client) combo. When I open some file remotely in Flow, it opens fine
        > in MacVim as I've set it in the preferences. But when I save the file,
        > it doesn't always get updated in the client and sent to server.
        >
        > I noticed that MacVim changes not only "last modified" timestamp of
        > saved file, but also creation and access timestamp. I figure that this
        > could confuse Flow app and prevent it from updating the file on the
        > server. Is there any way to disable this behaviour (eg. to only update
        > the last modified timestamp)?

        This is due to the way Vim saves files (it renames the original file
        for backup, then saves a new file, then finally deletes the backup).
        You can work around this by setting 'backupcopy' to 'yes':

        :set backupcopy=yes

        See, ":h 'bkc" for more information (also take a look at ":h
        backup-table", ":h 'backup" and ":h 'writebackup").

        Björn

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.