Loading ...
Sorry, an error occurred while loading the content.

set foreground=green

Expand Messages
  • sixtyfootersdude
    I have been using vim on solaris for about 4 months but but just switched back to Mac OS X so I thought I would start using MacVim. Normally I use a black
    Message 1 of 3 , May 15, 2010
    • 0 Attachment
      I have been using vim on solaris for about 4 months but but just
      switched back to Mac OS X so I thought I would start using MacVim.

      Normally I use a black background and green font (as the default). I
      cannot seem to figure out how to do this. My understanding is that I
      should put this:

      set foreground=green

      into my ~/.gvimrc. Using:

      set background=dark

      Works to change the background color (almost) black.

      This the error that I get:

      % gvim .bashrc
      Error detected while processing /Users/me/.gvimrc:
      line 5:
      E518: Unknown option: foreground=green% Error detected while
      processing /Users/me/.gvimrc:
      line 5:
      E518: Unknown option: foreground=green

      Thanks,
      Jake

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Yi Wen
      should be guifg On May 15, 1:38 pm, sixtyfootersdude ... -- You received this message from the vim_mac maillist. Do not
      Message 2 of 3 , May 16, 2010
      • 0 Attachment
        should be guifg

        On May 15, 1:38 pm, sixtyfootersdude <sixtyfootersd...@...>
        wrote:
        > I have been using vim on solaris for about 4 months but but just
        > switched back to Mac OS X so I thought I would start using MacVim.
        >
        > Normally I use a black background and green font (as the default).  I
        > cannot seem to figure out how to do this.  My understanding is that I
        > should put this:
        >
        > set foreground=green
        >
        > into my ~/.gvimrc.  Using:
        >
        > set background=dark
        >
        > Works to change the background color (almost) black.
        >
        > This the error that I get:
        >
        > % gvim .bashrc
        > Error detected while processing /Users/me/.gvimrc:
        > line    5:
        > E518: Unknown option: foreground=green% Error detected while
        > processing /Users/me/.gvimrc:
        > line    5:
        > E518: Unknown option: foreground=green
        >
        > Thanks,
        > Jake
        >
        > --
        > You received this message from the "vim_mac" maillist.
        > Do not top-post! Type your reply below the text you are replying to.
        > For more information, visithttp://www.vim.org/maillist.php

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Kyle Lippincott
        Not for set . Jake: You can accomplish this with putting this in your gvimrc: highlight Normal guifg=green guibg=black You can get information on what color
        Message 3 of 3 , May 16, 2010
        • 0 Attachment
          Not for 'set'.

          Jake: You can accomplish this with putting this in your gvimrc:
          highlight Normal guifg=green guibg=black

          You can get information on what color names are available by going to :help macvim-colors

          But this is probably not what you really want.  I recommend going to http://code.google.com/p/vimcolorschemetest/, click on the language of your choice at the bottom, wait for the page to load, find a colorscheme close to what you want, download it and put it in the right place (I believe ~/.vim/colors/<schemename>.vim).  You can then tweak it to your liking.  This file is just a collection of various 'highlight' commands like above with the labels needed to work with all of the default syntax files.

          On Sun, May 16, 2010 at 11:37 AM, Yi Wen <hayafirst@...> wrote:
          should be guifg

          On May 15, 1:38 pm, sixtyfootersdude <sixtyfootersd...@...>
          wrote:
          > I have been using vim on solaris for about 4 months but but just
          > switched back to Mac OS X so I thought I would start using MacVim.
          >
          > Normally I use a black background and green font (as the default).  I
          > cannot seem to figure out how to do this.  My understanding is that I
          > should put this:
          >
          > set foreground=green
          >
          > into my ~/.gvimrc.  Using:
          >
          > set background=dark
          >
          > Works to change the background color (almost) black.
          >
          > This the error that I get:
          >
          > % gvim .bashrc
          > Error detected while processing /Users/me/.gvimrc:
          > line    5:
          > E518: Unknown option: foreground=green% Error detected while
          > processing /Users/me/.gvimrc:
          > line    5:
          > E518: Unknown option: foreground=green
          >
          > Thanks,
          > Jake
          >
          > --
          > You received this message from the "vim_mac" maillist.
          > Do not top-post! Type your reply below the text you are replying to.
          > For more information, visithttp://www.vim.org/maillist.php

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.