Loading ...
Sorry, an error occurred while loading the content.
 

Re: Using MacVim terminal app with arrow keys?

Expand Messages
  • Wincent Colaiuta
    On 31 mar, 15:47, Patrick O Doherty ... Perhaps you have a mapping for or one that begins with ? Seeing as some (or
    Message 1 of 2 , Apr 1, 2010
      On 31 mar, 15:47, "Patrick O'Doherty" <patr...@...>
      wrote:
      > Hey guys,
      >
      > I use MacVim when I'm at my Mac but there are times when I have to
      > edit files from remote locations over ssh with vim. While I have
      > another version of vim installed I'm trying to achieve consistency so
      > I've started using the CLI version of vim compiled in the MacVim
      > build. Everything works but the arrow keys when used for any sort of
      > navigation. If anyone has any suggestions on how I could solve this
      > I'd really appreciate it.

      Perhaps you have a mapping for <Esc> or one that begins with <Esc>?

      Seeing as some (or many) terminals actually send the cursor keys as
      "<Esc><a>", "<Esc><b>", "<Esc><c>", "<Esc><d>", VIM sees the cursor
      key presses as two separate keystrokes, and is probably performing the
      wrong mapping.

      At least in my limited experimentation I've found that you have remove
      any mapping for <Esc>, or at least make sure that it only gets set up
      when running the GUI. I've played around with the 'timeout',
      'ttimeout', 'timeout' and 'ttimeoutlen' settings but to no avail; it
      seems you just have to stay away from <Esc> in your mappings.

      Cheers,
      Wincent

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      To unsubscribe, reply using "remove me" as the subject.
    Your message has been successfully submitted and would be delivered to recipients shortly.