Loading ...
Sorry, an error occurred while loading the content.

can't launch snapshot 52

Expand Messages
  • john mckenzie
    can t launch snapshot 52 on my 10.5 intel mac. I did do the preferences/dotfile cleansing as recommended. Console messages are as follows: 3/30/10 8:37:07 AM
    Message 1 of 4 , Mar 30, 2010
    • 0 Attachment
      can't launch snapshot 52 on my 10.5 intel mac. I did do the
      preferences/dotfile cleansing as recommended. Console messages are as
      follows:

      3/30/10 8:37:07 AM [0x0-0x5d05d].org.vim.MacVim[943] Warning: no
      access to tty (Bad file descriptor).
      3/30/10 8:37:07 AM [0x0-0x5d05d].org.vim.MacVim[943] Thus no job
      control in this shell.
      3/30/10 8:37:10 AM com.apple.launchd[533]
      ([0x0-0x5d05d].org.vim.MacVim[943]) Exited abnormally: Segmentation
      fault


      Many thanks for any help.

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      To unsubscribe, reply using "remove me" as the subject.
    • björn
      ... Not sure what this means -- have you had any success running any of the older snapshots? One thing you could try is to quit MacVim (Cmd+Q), then open
      Message 2 of 4 , Apr 1, 2010
      • 0 Attachment
        On 30 March 2010 16:43, john mckenzie wrote:
        > can't launch snapshot 52 on my 10.5 intel mac. I did do the
        > preferences/dotfile cleansing as recommended. Console messages are as
        > follows:
        >
        > 3/30/10 8:37:07 AM [0x0-0x5d05d].org.vim.MacVim[943] Warning: no
        > access to tty (Bad file descriptor).
        > 3/30/10 8:37:07 AM [0x0-0x5d05d].org.vim.MacVim[943] Thus no job
        > control in this shell.
        > 3/30/10 8:37:10 AM com.apple.launchd[533]
        > ([0x0-0x5d05d].org.vim.MacVim[943]) Exited abnormally: Segmentation
        > fault

        Not sure what this means -- have you had any success running any of
        the older snapshots?

        One thing you could try is to quit MacVim (Cmd+Q), then open
        Terminal.app and type

        defaults write org.vim.MacVim MMLoginShell 0

        Then open up MacVim again and see if it works.

        Björn

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        To unsubscribe, reply using "remove me" as the subject.
      • john mckenzie
        ... 1. Yes, all previous snapshots had worked. 2. Your solution fixed the issue for me, thanks! -- You received this message from the vim_mac maillist. Do
        Message 3 of 4 , Apr 5, 2010
        • 0 Attachment
          On Thu, Apr 1, 2010 at 12:42 PM, björn <bjorn.winckler@...> wrote:

          Not sure what this means -- have you had any success running any of
          the older snapshots?

          One thing you could try is to quit MacVim (Cmd+Q), then open
          Terminal.app and type

          defaults write org.vim.MacVim MMLoginShell 0

          Then open up MacVim again and see if it works.


          1. Yes, all previous snapshots had worked.
          2. Your solution fixed the issue for me, thanks!

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • björn
          ... This is weird -- have you changed which shell (other than bash) to use or something? Please read up on :h macvim-login-shell and see if that gives you
          Message 4 of 4 , Apr 6, 2010
          • 0 Attachment
            On 5 April 2010 15:16, john mckenzie wrote:
            > On Thu, Apr 1, 2010 at 12:42 PM, björn wrote:
            >>
            >> One thing you could try is to quit MacVim (Cmd+Q), then open
            >> Terminal.app and type
            >>
            >> defaults write org.vim.MacVim MMLoginShell 0
            >>
            >> Then open up MacVim again and see if it works.
            >>
            >
            > 1. Yes, all previous snapshots had worked.
            > 2. Your solution fixed the issue for me, thanks!

            This is weird -- have you changed which shell (other than bash) to use
            or something?

            Please read up on ":h macvim-login-shell" and see if that gives you
            any clues as to what is going wrong (and let me know if you do...this
            is the first time I've seen this option causing problems).

            Björn

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            To unsubscribe, reply using "remove me" as the subject.
          Your message has been successfully submitted and would be delivered to recipients shortly.