Loading ...
Sorry, an error occurred while loading the content.
 

Problem setting bold fonts via .gvimrc

Expand Messages
  • Frank R.
    Hello, I m triying to change the default font to Consolas:h15:b but when I issue the command: set guifont=Consolas:h15:b I get an Unvalid font error . It
    Message 1 of 3 , Mar 26, 2010
      Hello,

      I'm triying to change the default font to "Consolas:h15:b" but when I
      issue the command: set guifont=Consolas:h15:b I get an "Unvalid font
      error".
      It works fine if i use "Consolas:h15"
      If I try this same font via Edit->Font->Show fonts menu, bold font
      works without problem. I'm getting the same behaviour with other fonts
      such as Menlo.

      Does anybody know what I am doing wrong? Why I can set the bold
      version via menu but not via .gvimrc or set command?

      Thanks in advance,
      Frank

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      To unsubscribe from this group, send email to vim_mac+unsubscribegooglegroups.com or reply to this email with the words "REMOVE ME" as the subject.
    • Kyle Lippincott
      What do you see if you do :set guifont? (with the question mark, without the quotes) after setting it from the menu? The guifont line is interpreted
      Message 2 of 3 , Mar 26, 2010
        What do you see if you do ":set guifont?"  (with the question mark, without the quotes) after setting it from the menu?  The guifont line is interpreted differently on pretty much every platform, unfortunately.  It's possible :b isn't the proper way to set it (I haven't tested this).

        On Fri, Mar 26, 2010 at 9:41 AM, Frank R. <trek1s@...> wrote:
        Hello,

        I'm triying to change the default font to "Consolas:h15:b" but when I
        issue the command: set guifont=Consolas:h15:b I get an "Unvalid font
        error".
        It works fine if i use "Consolas:h15"
        If I try this same font via Edit->Font->Show fonts menu, bold font
        works without problem. I'm getting the same behaviour with other fonts
        such as Menlo.

        Does anybody know what I am doing wrong? Why I can set the bold
        version via menu but not via .gvimrc or set command?

        Thanks in advance,
        Frank

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        To unsubscribe from this group, send email to vim_mac+unsubscribegooglegroups.com or reply to this email with the words "REMOVE ME" as the subject.

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        To unsubscribe from this group, send email to vim_mac+unsubscribegooglegroups.com or reply to this email with the words "REMOVE ME" as the subject.
      • Frank R.
        Hi again, As Kyle pointed out, after setting the font via MacVim menu set guifont? command returned Menlo bold:h15 (same for Consolas font). It seems
        Message 3 of 3 , Mar 27, 2010
          Hi again,
          As Kyle pointed out, after setting the font via MacVim menu "set
          guifont?" command returned "Menlo bold:h15" (same for Consolas font).
          It seems that, for these two fonts at least, correct way to set bold
          fonts is by using "<font_name> bold:h<size>" instead of using the
          ":b" at the end.

          Thanks a lot for your help Kyle.

          Regards,
          Frank

          P.S. BTW, when updating .gvimrc file remember to scape that blank
          space, that is "set guifont=Menlo\ bold:h15"

          On Mar 26, 11:04 pm, Kyle Lippincott <spect...@...> wrote:
          > What do you see if you do ":set guifont?"  (with the question mark, without
          > the quotes) after setting it from the menu?  The guifont line is interpreted
          > differently on pretty much every platform, unfortunately.  It's possible :b
          > isn't the proper way to set it (I haven't tested this).
          >
          > On Fri, Mar 26, 2010 at 9:41 AM, Frank R. <tre...@...> wrote:
          > > Hello,
          >
          > > I'm triying to change the default font to "Consolas:h15:b" but when I
          > > issue the command: set guifont=Consolas:h15:b I get an "Unvalid font
          > > error".
          > > It works fine if i use "Consolas:h15"
          > > If I try this same font via Edit->Font->Show fonts menu, bold font
          > > works without problem. I'm getting the same behaviour with other fonts
          > > such as Menlo.
          >
          > > Does anybody know what I am doing wrong? Why I can set the bold
          > > version via menu but not via .gvimrc or set command?
          >
          > > Thanks in advance,
          > > Frank
          >
          > > --
          > > You received this message from the "vim_mac" maillist.
          > > Do not top-post! Type your reply below the text you are replying to.
          > > For more information, visithttp://www.vim.org/maillist.php
          >
          > > To unsubscribe from this group, send email to vim_mac+
          > > unsubscribegooglegroups.com or reply to this email with the words "REMOVE
          > > ME" as the subject.

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          To unsubscribe from this group, send email to vim_mac+unsubscribegooglegroups.com or reply to this email with the words "REMOVE ME" as the subject.
        Your message has been successfully submitted and would be delivered to recipients shortly.