Loading ...
Sorry, an error occurred while loading the content.

Colors only in gvim

Expand Messages
  • LuKreme
    I asked this in vim-use, but only got a reply asking what was in .vimrc and .,gvimrc, neither of which I have, so I thought maybe this might be a Mac question
    Message 1 of 2 , Mar 10, 2010
    • 0 Attachment
      I asked this in vim-use, but only got a reply asking what was in .vimrc and .,gvimrc, neither of which I have, so I thought maybe this might be a Mac question after all.

      When I run gvim, I get syntax coloring all over the place, even in USENET posting all the headers and quotes and signatures are color coded.

      But when I run vim, there's no syntax coloring at all.

      I went ahead and looked at these:
      system vimrc file: "$VIM/vimrc"
      system gvimrc file: "$VIM/gvimrc"

      but I don't know if I can merely copy the gvimrc to $HOME/.vimrc without that causing problems. I mean, it SEEMS to work, but what do I know.

      Since I am hear, I'd like to ask a couple of other questions.

      1) why does MacVim look different from vim even with identical rc files? (MacVim uses a white background, vim a black one as is right and proper).

      2) how do I integrate spell-checking into vim (both gvim and vim)?

      3) I have "Open files from applications in the current window with a tab for each file" selected in the preferences, but when I issue the following:

      % vim file1 file2

      I do not get tabs, and have to use :n to go to the next file.

      --
      I WILL NOT FAKE RABIES Bart chalkboard Ep. 8F07

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • björn
      ... I m not sure what the question is but the reason you get syntax highlighting by default in MacVim is because it is enabled in the system gvimrc file (which
      Message 2 of 2 , Mar 10, 2010
      • 0 Attachment
        On 10 March 2010 09:30, LuKreme wrote:
        > I asked this in vim-use, but only got a reply asking what was in .vimrc and .,gvimrc, neither of which I have, so I thought maybe this might be a Mac question after all.
        >
        > When I run  gvim, I get syntax coloring all over the place, even in USENET posting all the headers and quotes and signatures are color coded.
        >
        > But when I run vim, there's no syntax coloring at all.
        >
        > I went ahead and looked at these:
        >  system vimrc file: "$VIM/vimrc"
        >  system gvimrc file: "$VIM/gvimrc"
        >
        > but I don't know if I can merely copy the gvimrc to $HOME/.vimrc without that causing problems. I mean, it SEEMS to work, but what do I know.

        I'm not sure what the question is but the reason you get syntax
        highlighting by default in MacVim is because it is enabled in the
        system gvimrc file (which maybe you had figured out already?). I did
        change a few options in the MacVim system rc files to non-default
        values for various reasons.

        The changes in the system rc-files can all be reverted if you wish,
        e.g. add "syntax off" to your ~/.gvimrc file to disable syntax
        highlighting. (Or did you want to enable it in other versions of Vim?
        If so add "syntax on" in either ~/.vimrc or ~/.gvimrc.)

        > Since I am hear, I'd like to ask a couple of other questions.
        >
        > 1) why does MacVim look different from vim even with identical rc files? (MacVim uses a white background, vim a black one as is right and proper).

        All GUI versions of Vim use a white color background by default.
        MacVim's GUI uses a slightly different color scheme than other GUIs to
        make it more "Mac-like". If you want the same color scheme as other
        Vim GUIs, add the following line to your ~/.vimrc:

        let colors_name = "default"

        If you want a dark background, add the following to ~/.vimrc

        set background=dark

        ... or use the ":colorscheme" command to change the color scheme (see
        ":h colorscheme") to some dark variant.

        > 2) how do I integrate spell-checking into vim (both gvim and vim)?

        See ":h spell:". Typing ":set spell" will enable spell checking.


        > 3) I have "Open files from applications in the current window with a tab for each file" selected in the preferences, but when I issue the following:
        >
        > % vim file1 file2
        >
        > I do not get tabs, and have to use :n to go to the next file.

        You have to use the "-p" flag on the command line -- the preference
        setting only applies to files opened from Finder (it also says so in
        the preferences dialog). See ":h starting" for more info on "-p" and
        other flags.

        Note that these types of questions (1 - 3) are best asked on vim_use
        even though I do my best to answer any question (if I am able). I
        strongly recommend that you check out the help files in Vim -- they
        contain _a lot_ of information (see ":help") although I can understand
        that it is not always easy to find what you are looking for. You may
        also want to take a look at ":h macvim".

        Björn

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.