Loading ...
Sorry, an error occurred while loading the content.

Calling macvim from .slrnrc

Expand Messages
  • LuKreme
    In my slrnrc I have set editor_command vim +set tw=72 +%d %s which works fine when I am sshed into the server and I get the CLI/Term version of vim.
    Message 1 of 2 , Mar 8, 2010
    • 0 Attachment
      In my slrnrc I have

      set editor_command "vim '+set tw=72' +%d '%s'"

      which works fine when I am sshed into the server and I get the CLI/Term version of vim. However, when I am on the local machine, as soon as MacVim opens the file, slrn reaqctivates saying the file was not changed. I am calling vim from the alias


      function vim() { /usr/local/bin/mvim "${@}"; }

      When logged in to the local console and

      function vim() { /usr/local/bin/vim "${@}"; }

      when logged in remotely.

      I am hoping there is some flag I can add to the vim call in the slrnrc file that will let the graphic vim wait for the file to close (like the BBEdit --wait command) or that ther is a way I can tell slrn to use vim when I am on a ssh session and BBEdit when I am logged in to the local console. I looked through the man page, but I must have missed it.


      --
      Rick: And remember, this gun is pointed right at your heart.
      Captain Renault: That is my *least* vulnerable spo

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • LuKreme
      ... OK, as so often happens, I found the -f flag mere seconds after finally hitting send on that last message. For the archives: set editor_command vim -f
      Message 2 of 2 , Mar 8, 2010
      • 0 Attachment
        On 8-Mar-2010, at 17:28, LuKreme wrote:
        >
        > I looked through the man page, but I must have missed it.

        OK, as so often happens, I found the -f flag mere seconds after finally hitting send on
        that last message.

        For the archives:

        set editor_command "vim -f '+set tw=72' +%d '%s'"

        Seems to work.

        Now, how do I get the nifty coloring that I get in the GUI to work in the regular vim as well?

        --
        Love seeketh not itself to please Nor for itself hath any care But
        for another gives its ease And builds a heaven in Hell's
        despair

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.