Loading ...
Sorry, an error occurred while loading the content.
 

Re: MacVim.app snapshot 52

Expand Messages
  • J Irving
    ... I m also seeing this issue, and have isolated the problem to my guioptions. With the following testrc file: set guioptions=gmLtT set bg=dark hi normal
    Message 1 of 12 , Mar 6, 2010
      On Mar 6, 10:00 am, björn <bjorn.winck...@...> wrote:
      > On 6 March 2010 15:56, Skammer wrote:
      >
      > >> Have you got Quickstart enabled by any chance?
      >
      > > I have. I turned it off and it had no effect.
      >
      > Ok, it may be that something in your rc-files cause this.  Can you try
      > renaming them temporarily to see if that makes any difference?  If so,
      > can you figure out what lines cause it?

      I'm also seeing this issue, and have isolated the problem to my
      guioptions.

      With the following testrc file:

      set guioptions=gmLtT
      set bg=dark
      hi normal guibg=black guifg=white

      and the following invocation:

      mvim --noplugin -U /dev/null -u ./testrc

      I get a white flash when MacVim starts. If I switch off the
      experimental renderer, or comment out the guioptions line, this goes
      away. I tried removing the guioptions one by one, but couldn't find a
      single option which caused it. Perhaps it's an interaction between
      multiple options. I will do a little research to see if I can make
      sense of it.

      > > Apparently, it's a bug with new renderer. Turning it off eliminated
      > > this weird blinking, but scrolling big files became painfully slow :(
      >
      > Ok, I suspected as much.  It shouldn't be too hard to fix, only I need
      > some way to reproduce it (I don't see any flashes).

      Hopefully the above rc file will do the trick.

      cheers, J

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • björn
      ... Ah good, now I can reproduce the flashing as well (set go-=r in .gvimrc did the trick). I ll have this fixed for the next snapshot. Thanks for telling me
      Message 2 of 12 , Mar 7, 2010
        On 7 March 2010 06:04, J Irving wrote:
        >
        > I switched guioptions back to their default (egmrt) and found that the
        > flashing stopped.  Simply removing "r" caused it to come back.  I've
        > confirmed that adding "r" to my original set of options causes the
        > flashing to go away (and of course the scrollbar to appear).

        Ah good, now I can reproduce the flashing as well (set go-=r in
        .gvimrc did the trick). I'll have this fixed for the next snapshot.
        Thanks for telling me how to reproduce the problem.

        Björn

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.