Loading ...
Sorry, an error occurred while loading the content.

Re: MacVim.app snapshot 52

Expand Messages
  • Cássio Marques
    Yes, before building from sources I downloaded the pre-build MacVim and I ran into the same problem. I ll take a look at the the instructions in this link you
    Message 1 of 12 , Mar 5, 2010
    • 0 Attachment
      Yes, before building from sources I downloaded the pre-build MacVim and I ran into the same problem. I'll take a look at the the instructions in this link you gave me.

      If i find out what's happening, I'll come back here and tell, maybe it will be useful to others.

      Thank you!

      On Fri, Mar 5, 2010 at 3:00 PM, björn <bjorn.winckler@...> wrote:
      2010/3/5 Cássio Marques:
      > I've built it from source here and the process went ok, but when trying to
      > run it, I am not able to type anything, I can't even get into insert mode.
      > I'm running OSX 10.5.8.
      > I've been using MacVim stable since I started to use a Mac, but now I want
      > all the new features from the snapshots :)
      > Do you have any idea of what may be causing it? In the meanwhile, I've
      > checkout tag snapshot-51 from git and will try and see if it runs ok after
      > building.

      Have you tried downloading snapshot 52 and trying it instead of
      building from sources?  Also, be sure to check this page:

      http://code.google.com/p/macvim/wiki/ReportingBugs

      to rule out any problems with your rc-files etc.

      > Anyway, when will we see a new stable version?

      I was thinking I'd release a new stable version when Vim 7.3 is
      released.  Note that there is not much difference between "stable" and
      "snapshot": the former is just a snapshot that has been used for a
      long time.

      > Thanks for such a nice project!

      I'm glad you like it. :-)

      Björn

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php



      --
      Cássio Marques

      Blog: http://cassiomarques.wordpress.com

      If you're writing code and you're not testing it, the code is wrong. I don't care if it does the right thing, and people need to understand this. If it works by accident, you're still wrong.
      Bryan Liles - Ruby Hoedown 2008

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Cássio Marques
      Hey Bjorn, I ve renamed my .vim folder and .vimrc file (I don t have a .gvimrc file) and after that I still can t type anything in MacVim. When using the old,
      Message 2 of 12 , Mar 5, 2010
      • 0 Attachment
        Hey Bjorn,

        I've renamed my .vim folder and .vimrc file (I don't have a .gvimrc file) and after that I still can't type anything in MacVim. When using the old, stable release, I can.

        This is very frustrating, since I built snapshot 51 (which I think is aroud for a while now) and I can't use it either, even without any configuration file. Any clue of what may be happening or something else I can't try?

        Thank you very much!

        2010/3/5 Cássio Marques <cassiommc@...>
        Yes, before building from sources I downloaded the pre-build MacVim and I ran into the same problem. I'll take a look at the the instructions in this link you gave me.

        If i find out what's happening, I'll come back here and tell, maybe it will be useful to others.

        Thank you!


        On Fri, Mar 5, 2010 at 3:00 PM, björn <bjorn.winckler@...> wrote:
        2010/3/5 Cássio Marques:
        > I've built it from source here and the process went ok, but when trying to
        > run it, I am not able to type anything, I can't even get into insert mode.
        > I'm running OSX 10.5.8.
        > I've been using MacVim stable since I started to use a Mac, but now I want
        > all the new features from the snapshots :)
        > Do you have any idea of what may be causing it? In the meanwhile, I've
        > checkout tag snapshot-51 from git and will try and see if it runs ok after
        > building.

        Have you tried downloading snapshot 52 and trying it instead of
        building from sources?  Also, be sure to check this page:

        http://code.google.com/p/macvim/wiki/ReportingBugs

        to rule out any problems with your rc-files etc.

        > Anyway, when will we see a new stable version?

        I was thinking I'd release a new stable version when Vim 7.3 is
        released.  Note that there is not much difference between "stable" and
        "snapshot": the former is just a snapshot that has been used for a
        long time.

        > Thanks for such a nice project!

        I'm glad you like it. :-)

        Björn

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php



        --
        Cássio Marques

        Blog: http://cassiomarques.wordpress.com

        If you're writing code and you're not testing it, the code is wrong. I don't care if it does the right thing, and people need to understand this. If it works by accident, you're still wrong.
        Bryan Liles - Ruby Hoedown 2008



        --
        Cássio Marques

        Blog: http://cassiomarques.wordpress.com

        If you're writing code and you're not testing it, the code is wrong. I don't care if it does the right thing, and people need to understand this. If it works by accident, you're still wrong.
        Bryan Liles - Ruby Hoedown 2008

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • björn
        ... (Replying to vim_mac.) Have you got Quickstart enabled by any chance? Björn -- You received this message from the vim_mac maillist. Do not top-post!
        Message 3 of 12 , Mar 6, 2010
        • 0 Attachment
          On 6 March 2010 00:32, Skammer wrote:
          > When opening a new window it flashes white before applying proper
          > theme colors.

          (Replying to vim_mac.)

          Have you got Quickstart enabled by any chance?

          Björn

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Skammer
          ... I have. I turned it off and it had no effect. Apparently, it s a bug with new renderer. Turning it off eliminated this weird blinking, but scrolling big
          Message 4 of 12 , Mar 6, 2010
          • 0 Attachment
            > Have you got Quickstart enabled by any chance?

            I have. I turned it off and it had no effect.

            Apparently, it's a bug with new renderer. Turning it off eliminated
            this weird blinking, but scrolling big files became painfully slow :(

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • björn
            ... Ok, it may be that something in your rc-files cause this. Can you try renaming them temporarily to see if that makes any difference? If so, can you
            Message 5 of 12 , Mar 6, 2010
            • 0 Attachment
              On 6 March 2010 15:56, Skammer wrote:
              >> Have you got Quickstart enabled by any chance?
              >
              > I have. I turned it off and it had no effect.

              Ok, it may be that something in your rc-files cause this. Can you try
              renaming them temporarily to see if that makes any difference? If so,
              can you figure out what lines cause it?

              > Apparently, it's a bug with new renderer. Turning it off eliminated
              > this weird blinking, but scrolling big files became painfully slow :(

              Ok, I suspected as much. It shouldn't be too hard to fix, only I need
              some way to reproduce it (I don't see any flashes).

              Björn

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • J Irving
              ... I m also seeing this issue, and have isolated the problem to my guioptions. With the following testrc file: set guioptions=gmLtT set bg=dark hi normal
              Message 6 of 12 , Mar 6, 2010
              • 0 Attachment
                On Mar 6, 10:00 am, björn <bjorn.winck...@...> wrote:
                > On 6 March 2010 15:56, Skammer wrote:
                >
                > >> Have you got Quickstart enabled by any chance?
                >
                > > I have. I turned it off and it had no effect.
                >
                > Ok, it may be that something in your rc-files cause this.  Can you try
                > renaming them temporarily to see if that makes any difference?  If so,
                > can you figure out what lines cause it?

                I'm also seeing this issue, and have isolated the problem to my
                guioptions.

                With the following testrc file:

                set guioptions=gmLtT
                set bg=dark
                hi normal guibg=black guifg=white

                and the following invocation:

                mvim --noplugin -U /dev/null -u ./testrc

                I get a white flash when MacVim starts. If I switch off the
                experimental renderer, or comment out the guioptions line, this goes
                away. I tried removing the guioptions one by one, but couldn't find a
                single option which caused it. Perhaps it's an interaction between
                multiple options. I will do a little research to see if I can make
                sense of it.

                > > Apparently, it's a bug with new renderer. Turning it off eliminated
                > > this weird blinking, but scrolling big files became painfully slow :(
                >
                > Ok, I suspected as much.  It shouldn't be too hard to fix, only I need
                > some way to reproduce it (I don't see any flashes).

                Hopefully the above rc file will do the trick.

                cheers, J

                --
                You received this message from the "vim_mac" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • J Irving
                ... A quick follow up to my last message (which doesn t seem to have posted yet). I switched guioptions back to their default (egmrt) and found that the
                Message 7 of 12 , Mar 6, 2010
                • 0 Attachment
                  On Mar 6, 10:00 am, björn <bjorn.winck...@...> wrote:
                  > On 6 March 2010 15:56, Skammer wrote:
                  >
                  > >> Have you got Quickstart enabled by any chance?
                  >
                  > > I have. I turned it off and it had no effect.
                  >
                  > Ok, it may be that something in your rc-files cause this.  Can you try
                  > renaming them temporarily to see if that makes any difference?  If so,
                  > can you figure out what lines cause it?

                  A quick follow up to my last message (which doesn't seem to have
                  posted yet).

                  I switched guioptions back to their default (egmrt) and found that the
                  flashing stopped. Simply removing "r" caused it to come back. I've
                  confirmed that adding "r" to my original set of options causes the
                  flashing to go away (and of course the scrollbar to appear).

                  HTH

                  cheers, J

                  --
                  You received this message from the "vim_mac" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • björn
                  ... Ah good, now I can reproduce the flashing as well (set go-=r in .gvimrc did the trick). I ll have this fixed for the next snapshot. Thanks for telling me
                  Message 8 of 12 , Mar 7, 2010
                  • 0 Attachment
                    On 7 March 2010 06:04, J Irving wrote:
                    >
                    > I switched guioptions back to their default (egmrt) and found that the
                    > flashing stopped.  Simply removing "r" caused it to come back.  I've
                    > confirmed that adding "r" to my original set of options causes the
                    > flashing to go away (and of course the scrollbar to appear).

                    Ah good, now I can reproduce the flashing as well (set go-=r in
                    .gvimrc did the trick). I'll have this fixed for the next snapshot.
                    Thanks for telling me how to reproduce the problem.

                    Björn

                    --
                    You received this message from the "vim_mac" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  Your message has been successfully submitted and would be delivered to recipients shortly.