Loading ...
Sorry, an error occurred while loading the content.

MacVim.app snapshot 52

Expand Messages
  • björn
    I have uploaded a new snapshot of MacVim.app to http://code.google.com/p/macvim/wiki/Snapshot This is mostly a bug fix release and many of the fixes are to the
    Message 1 of 12 , Mar 5, 2010
    • 0 Attachment
      I have uploaded a new snapshot of MacVim.app to

      http://code.google.com/p/macvim/wiki/Snapshot

      This is mostly a bug fix release and many of the fixes are to the Core Text
      renderer. I think most of the really obvious display issues in Core Text
      should be fixed now (one exception: dragging to resize a window sometimes
      causese display tearing, but I can't decide whether this is a problem that only
      occurs on my Mac).

      The "Find Pasteboard" interaction has changed slightly to make it easier to
      pull searches from MacVim into other apps. Previously, if you hit * on top of
      some word, e.g. "test", and then hit Cmd+g in another app, then that app would
      search for "\<test\>" and consequently fail to find anything. I have fixed
      this and some other common problems (related to using the "Find Dialog").

      I also want to mention that I have rearranged the Services menu so that it
      works better on Snow Leopard (hopefully I did not break anything on Leopard and
      Tiger). There are now two entries: "New MacVim Buffer With Selection" which
      opens a new buffer with whatever text is selected, and "New MacVim Buffer Here"
      which opens a new buffer and sets the pwd to that of the file or folder you had
      selected (in Finder). Note that on Snow Leopard you can access the Services
      menus by right-clicking, which makes them a whole lot easier to use than on
      Leopard and Tiger (e.g. try right-clicking a file in Finder, or select some
      text in Safari and right-click the selection). (The "Open Selected File"
      Service has been deprecated since it was not very useful and it was kind of
      confusing as to what it really did.)

      A warning: it is possible that this release will break Ruby plugins due to a
      patch to mainline Vim (which changed return types of certain functions from
      String to Fixnum). For example, the LustyExplorer plugin broke because of this
      (but has subsequently been patched). At any rate, if you have any problems
      with Ruby plugins after updating to snapshot 52 you should contact the plugin
      maintainer.

      Changes since snapshot 51:
      - Ctrl+Tab works (Core Text)
      - Improve Cmd+g behavior in other apps when repeating a search that
      originated in MacVim
      - Support "a" flag in 'guioptions'
      - Use device colors instead of calibrated colors (fixes a bug where the
      background color in full-screen mode would not match the background color
      of the view)
      - Get rid of some occasional warning messages on stdout
      - Fix drawing issues related to :vsp and 'guioptions' (Core Text)
      - Avoid white flashing on new window and zoom (Core Text)
      - Scrollbars are placed properly (Core Text)
      - Allow manual resizing of window across multiple screens
      - Fix Alt+Space mappings in keyboard layouts (e.g. French Dvorak)
      - Add wide font support (Core Text)
      - Fix memory leak in ATSUI renderer
      - Resize view properly when showing toolbar
      - Fix issues with Chinese IM (pressing "o" in normal mode no longer inserts
      "o" into the buffer)
      - Fix Services for Snow Leopard. There are now two services:
      * New MacVim Buffer With Selected
      * New MacVim Buffer Here
      - Support "%" flag in 'viminfo'
      - Opening encrypted files from Spotlight works
      - Do not reuse "unused windows" (unless the appropriate option in the
      Preferences is set)
      - Support 'exrc' option when opening files from Finder
      - Add support for :winpos
      - Update Vim sources and runtime files


      Björn

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Cássio Marques
      I ve built it from source here and the process went ok, but when trying to run it, I am not able to type anything, I can t even get into insert mode. I m
      Message 2 of 12 , Mar 5, 2010
      • 0 Attachment
        I've built it from source here and the process went ok, but when trying to run it, I am not able to type anything, I can't even get into insert mode. I'm running OSX 10.5.8.

        I've been using MacVim stable since I started to use a Mac, but now I want all the new features from the snapshots :)

        Do you have any idea of what may be causing it? In the meanwhile, I've checkout tag snapshot-51 from git and will try and see if it runs ok after building.

        Anyway, when will we see a new stable version?

        Thanks for such a nice project!

        On Fri, Mar 5, 2010 at 1:12 PM, björn <bjorn.winckler@...> wrote:
        I have uploaded a new snapshot of MacVim.app to

        http://code.google.com/p/macvim/wiki/Snapshot

        This is mostly a bug fix release and many of the fixes are to the Core Text
        renderer.  I think most of the really obvious display issues in Core Text
        should be fixed now (one exception: dragging to resize a window sometimes
        causese display tearing, but I can't decide whether this is a problem that only
        occurs on my Mac).

        The "Find Pasteboard" interaction has changed slightly to make it easier to
        pull searches from MacVim into other apps.  Previously, if you hit * on top of
        some word, e.g. "test", and then hit Cmd+g in another app, then that app would
        search for "\<test\>" and consequently fail to find anything.  I have fixed
        this and some other common problems (related to using the "Find Dialog").

        I also want to mention that I have rearranged the Services menu so that it
        works better on Snow Leopard (hopefully I did not break anything on Leopard and
        Tiger).  There are now two entries: "New MacVim Buffer With Selection" which
        opens a new buffer with whatever text is selected, and "New MacVim Buffer Here"
        which opens a new buffer and sets the pwd to that of the file or folder you had
        selected (in Finder).  Note that on Snow Leopard you can access the Services
        menus by right-clicking, which makes them a whole lot easier to use than on
        Leopard and Tiger (e.g. try right-clicking a file in Finder, or select some
        text in Safari and right-click the selection).  (The "Open Selected File"
        Service has been deprecated since it was not very useful and it was kind of
        confusing as to what it really did.)

        A warning: it is possible that this release will break Ruby plugins due to a
        patch to mainline Vim (which changed return types of certain functions from
        String to Fixnum).  For example, the LustyExplorer plugin broke because of this
        (but has subsequently been patched).  At any rate, if you have any problems
        with Ruby plugins after updating to snapshot 52 you should contact the plugin
        maintainer.

        Changes since snapshot 51:
         - Ctrl+Tab works (Core Text)
         - Improve Cmd+g behavior in other apps when repeating a search that
           originated in MacVim
         - Support "a" flag in 'guioptions'
         - Use device colors instead of calibrated colors (fixes a bug where the
           background color in full-screen mode would not match the background color
           of the view)
         - Get rid of some occasional warning messages on stdout
         - Fix drawing issues related to :vsp and 'guioptions' (Core Text)
         - Avoid white flashing on new window and zoom (Core Text)
         - Scrollbars are placed properly (Core Text)
         - Allow manual resizing of window across multiple screens
         - Fix Alt+Space mappings in keyboard layouts (e.g. French Dvorak)
         - Add wide font support (Core Text)
         - Fix memory leak in ATSUI renderer
         - Resize view properly when showing toolbar
         - Fix issues with Chinese IM (pressing "o" in normal mode no longer inserts
           "o" into the buffer)
         - Fix Services for Snow Leopard.  There are now two services:
             * New MacVim Buffer With Selected
             * New MacVim Buffer Here
         - Support "%" flag in 'viminfo'
         - Opening encrypted files from Spotlight works
         - Do not reuse "unused windows" (unless the appropriate option in the
           Preferences is set)
         - Support 'exrc' option when opening files from Finder
         - Add support for :winpos
         - Update Vim sources and runtime files


        Björn

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php



        --
        Cássio Marques

        Blog: http://cassiomarques.wordpress.com

        If you're writing code and you're not testing it, the code is wrong. I don't care if it does the right thing, and people need to understand this. If it works by accident, you're still wrong.
        Bryan Liles - Ruby Hoedown 2008

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Cássio Marques
        OH, I m having the very same issue with snapshot-51 :-( And I can t see any output at the terminal about errors that may be occurring. 2010/3/5 Cássio Marques
        Message 3 of 12 , Mar 5, 2010
        • 0 Attachment
          OH, I'm having the very same issue with snapshot-51 :-(

          And I can't see any output at the terminal about errors that may be occurring.

          2010/3/5 Cássio Marques <cassiommc@...>
          I've built it from source here and the process went ok, but when trying to run it, I am not able to type anything, I can't even get into insert mode. I'm running OSX 10.5.8.

          I've been using MacVim stable since I started to use a Mac, but now I want all the new features from the snapshots :)

          Do you have any idea of what may be causing it? In the meanwhile, I've checkout tag snapshot-51 from git and will try and see if it runs ok after building.

          Anyway, when will we see a new stable version?

          Thanks for such a nice project!


          On Fri, Mar 5, 2010 at 1:12 PM, björn <bjorn.winckler@...> wrote:
          I have uploaded a new snapshot of MacVim.app to

          http://code.google.com/p/macvim/wiki/Snapshot

          This is mostly a bug fix release and many of the fixes are to the Core Text
          renderer.  I think most of the really obvious display issues in Core Text
          should be fixed now (one exception: dragging to resize a window sometimes
          causese display tearing, but I can't decide whether this is a problem that only
          occurs on my Mac).

          The "Find Pasteboard" interaction has changed slightly to make it easier to
          pull searches from MacVim into other apps.  Previously, if you hit * on top of
          some word, e.g. "test", and then hit Cmd+g in another app, then that app would
          search for "\<test\>" and consequently fail to find anything.  I have fixed
          this and some other common problems (related to using the "Find Dialog").

          I also want to mention that I have rearranged the Services menu so that it
          works better on Snow Leopard (hopefully I did not break anything on Leopard and
          Tiger).  There are now two entries: "New MacVim Buffer With Selection" which
          opens a new buffer with whatever text is selected, and "New MacVim Buffer Here"
          which opens a new buffer and sets the pwd to that of the file or folder you had
          selected (in Finder).  Note that on Snow Leopard you can access the Services
          menus by right-clicking, which makes them a whole lot easier to use than on
          Leopard and Tiger (e.g. try right-clicking a file in Finder, or select some
          text in Safari and right-click the selection).  (The "Open Selected File"
          Service has been deprecated since it was not very useful and it was kind of
          confusing as to what it really did.)

          A warning: it is possible that this release will break Ruby plugins due to a
          patch to mainline Vim (which changed return types of certain functions from
          String to Fixnum).  For example, the LustyExplorer plugin broke because of this
          (but has subsequently been patched).  At any rate, if you have any problems
          with Ruby plugins after updating to snapshot 52 you should contact the plugin
          maintainer.

          Changes since snapshot 51:
           - Ctrl+Tab works (Core Text)
           - Improve Cmd+g behavior in other apps when repeating a search that
             originated in MacVim
           - Support "a" flag in 'guioptions'
           - Use device colors instead of calibrated colors (fixes a bug where the
             background color in full-screen mode would not match the background color
             of the view)
           - Get rid of some occasional warning messages on stdout
           - Fix drawing issues related to :vsp and 'guioptions' (Core Text)
           - Avoid white flashing on new window and zoom (Core Text)
           - Scrollbars are placed properly (Core Text)
           - Allow manual resizing of window across multiple screens
           - Fix Alt+Space mappings in keyboard layouts (e.g. French Dvorak)
           - Add wide font support (Core Text)
           - Fix memory leak in ATSUI renderer
           - Resize view properly when showing toolbar
           - Fix issues with Chinese IM (pressing "o" in normal mode no longer inserts
             "o" into the buffer)
           - Fix Services for Snow Leopard.  There are now two services:
               * New MacVim Buffer With Selected
               * New MacVim Buffer Here
           - Support "%" flag in 'viminfo'
           - Opening encrypted files from Spotlight works
           - Do not reuse "unused windows" (unless the appropriate option in the
             Preferences is set)
           - Support 'exrc' option when opening files from Finder
           - Add support for :winpos
           - Update Vim sources and runtime files


          Björn

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php



          --
          Cássio Marques

          Blog: http://cassiomarques.wordpress.com

          If you're writing code and you're not testing it, the code is wrong. I don't care if it does the right thing, and people need to understand this. If it works by accident, you're still wrong.
          Bryan Liles - Ruby Hoedown 2008



          --
          Cássio Marques

          Blog: http://cassiomarques.wordpress.com

          If you're writing code and you're not testing it, the code is wrong. I don't care if it does the right thing, and people need to understand this. If it works by accident, you're still wrong.
          Bryan Liles - Ruby Hoedown 2008

          --
          You received this message from the "vim_mac" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • björn
          ... Have you tried downloading snapshot 52 and trying it instead of building from sources? Also, be sure to check this page:
          Message 4 of 12 , Mar 5, 2010
          • 0 Attachment
            2010/3/5 Cássio Marques:
            > I've built it from source here and the process went ok, but when trying to
            > run it, I am not able to type anything, I can't even get into insert mode.
            > I'm running OSX 10.5.8.
            > I've been using MacVim stable since I started to use a Mac, but now I want
            > all the new features from the snapshots :)
            > Do you have any idea of what may be causing it? In the meanwhile, I've
            > checkout tag snapshot-51 from git and will try and see if it runs ok after
            > building.

            Have you tried downloading snapshot 52 and trying it instead of
            building from sources? Also, be sure to check this page:

            http://code.google.com/p/macvim/wiki/ReportingBugs

            to rule out any problems with your rc-files etc.

            > Anyway, when will we see a new stable version?

            I was thinking I'd release a new stable version when Vim 7.3 is
            released. Note that there is not much difference between "stable" and
            "snapshot": the former is just a snapshot that has been used for a
            long time.

            > Thanks for such a nice project!

            I'm glad you like it. :-)

            Björn

            --
            You received this message from the "vim_mac" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Cássio Marques
            Yes, before building from sources I downloaded the pre-build MacVim and I ran into the same problem. I ll take a look at the the instructions in this link you
            Message 5 of 12 , Mar 5, 2010
            • 0 Attachment
              Yes, before building from sources I downloaded the pre-build MacVim and I ran into the same problem. I'll take a look at the the instructions in this link you gave me.

              If i find out what's happening, I'll come back here and tell, maybe it will be useful to others.

              Thank you!

              On Fri, Mar 5, 2010 at 3:00 PM, björn <bjorn.winckler@...> wrote:
              2010/3/5 Cássio Marques:
              > I've built it from source here and the process went ok, but when trying to
              > run it, I am not able to type anything, I can't even get into insert mode.
              > I'm running OSX 10.5.8.
              > I've been using MacVim stable since I started to use a Mac, but now I want
              > all the new features from the snapshots :)
              > Do you have any idea of what may be causing it? In the meanwhile, I've
              > checkout tag snapshot-51 from git and will try and see if it runs ok after
              > building.

              Have you tried downloading snapshot 52 and trying it instead of
              building from sources?  Also, be sure to check this page:

              http://code.google.com/p/macvim/wiki/ReportingBugs

              to rule out any problems with your rc-files etc.

              > Anyway, when will we see a new stable version?

              I was thinking I'd release a new stable version when Vim 7.3 is
              released.  Note that there is not much difference between "stable" and
              "snapshot": the former is just a snapshot that has been used for a
              long time.

              > Thanks for such a nice project!

              I'm glad you like it. :-)

              Björn

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php



              --
              Cássio Marques

              Blog: http://cassiomarques.wordpress.com

              If you're writing code and you're not testing it, the code is wrong. I don't care if it does the right thing, and people need to understand this. If it works by accident, you're still wrong.
              Bryan Liles - Ruby Hoedown 2008

              --
              You received this message from the "vim_mac" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Cássio Marques
              Hey Bjorn, I ve renamed my .vim folder and .vimrc file (I don t have a .gvimrc file) and after that I still can t type anything in MacVim. When using the old,
              Message 6 of 12 , Mar 5, 2010
              • 0 Attachment
                Hey Bjorn,

                I've renamed my .vim folder and .vimrc file (I don't have a .gvimrc file) and after that I still can't type anything in MacVim. When using the old, stable release, I can.

                This is very frustrating, since I built snapshot 51 (which I think is aroud for a while now) and I can't use it either, even without any configuration file. Any clue of what may be happening or something else I can't try?

                Thank you very much!

                2010/3/5 Cássio Marques <cassiommc@...>
                Yes, before building from sources I downloaded the pre-build MacVim and I ran into the same problem. I'll take a look at the the instructions in this link you gave me.

                If i find out what's happening, I'll come back here and tell, maybe it will be useful to others.

                Thank you!


                On Fri, Mar 5, 2010 at 3:00 PM, björn <bjorn.winckler@...> wrote:
                2010/3/5 Cássio Marques:
                > I've built it from source here and the process went ok, but when trying to
                > run it, I am not able to type anything, I can't even get into insert mode.
                > I'm running OSX 10.5.8.
                > I've been using MacVim stable since I started to use a Mac, but now I want
                > all the new features from the snapshots :)
                > Do you have any idea of what may be causing it? In the meanwhile, I've
                > checkout tag snapshot-51 from git and will try and see if it runs ok after
                > building.

                Have you tried downloading snapshot 52 and trying it instead of
                building from sources?  Also, be sure to check this page:

                http://code.google.com/p/macvim/wiki/ReportingBugs

                to rule out any problems with your rc-files etc.

                > Anyway, when will we see a new stable version?

                I was thinking I'd release a new stable version when Vim 7.3 is
                released.  Note that there is not much difference between "stable" and
                "snapshot": the former is just a snapshot that has been used for a
                long time.

                > Thanks for such a nice project!

                I'm glad you like it. :-)

                Björn

                --
                You received this message from the "vim_mac" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php



                --
                Cássio Marques

                Blog: http://cassiomarques.wordpress.com

                If you're writing code and you're not testing it, the code is wrong. I don't care if it does the right thing, and people need to understand this. If it works by accident, you're still wrong.
                Bryan Liles - Ruby Hoedown 2008



                --
                Cássio Marques

                Blog: http://cassiomarques.wordpress.com

                If you're writing code and you're not testing it, the code is wrong. I don't care if it does the right thing, and people need to understand this. If it works by accident, you're still wrong.
                Bryan Liles - Ruby Hoedown 2008

                --
                You received this message from the "vim_mac" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • björn
                ... (Replying to vim_mac.) Have you got Quickstart enabled by any chance? Björn -- You received this message from the vim_mac maillist. Do not top-post!
                Message 7 of 12 , Mar 6, 2010
                • 0 Attachment
                  On 6 March 2010 00:32, Skammer wrote:
                  > When opening a new window it flashes white before applying proper
                  > theme colors.

                  (Replying to vim_mac.)

                  Have you got Quickstart enabled by any chance?

                  Björn

                  --
                  You received this message from the "vim_mac" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • Skammer
                  ... I have. I turned it off and it had no effect. Apparently, it s a bug with new renderer. Turning it off eliminated this weird blinking, but scrolling big
                  Message 8 of 12 , Mar 6, 2010
                  • 0 Attachment
                    > Have you got Quickstart enabled by any chance?

                    I have. I turned it off and it had no effect.

                    Apparently, it's a bug with new renderer. Turning it off eliminated
                    this weird blinking, but scrolling big files became painfully slow :(

                    --
                    You received this message from the "vim_mac" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  • björn
                    ... Ok, it may be that something in your rc-files cause this. Can you try renaming them temporarily to see if that makes any difference? If so, can you
                    Message 9 of 12 , Mar 6, 2010
                    • 0 Attachment
                      On 6 March 2010 15:56, Skammer wrote:
                      >> Have you got Quickstart enabled by any chance?
                      >
                      > I have. I turned it off and it had no effect.

                      Ok, it may be that something in your rc-files cause this. Can you try
                      renaming them temporarily to see if that makes any difference? If so,
                      can you figure out what lines cause it?

                      > Apparently, it's a bug with new renderer. Turning it off eliminated
                      > this weird blinking, but scrolling big files became painfully slow :(

                      Ok, I suspected as much. It shouldn't be too hard to fix, only I need
                      some way to reproduce it (I don't see any flashes).

                      Björn

                      --
                      You received this message from the "vim_mac" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                    • J Irving
                      ... I m also seeing this issue, and have isolated the problem to my guioptions. With the following testrc file: set guioptions=gmLtT set bg=dark hi normal
                      Message 10 of 12 , Mar 6, 2010
                      • 0 Attachment
                        On Mar 6, 10:00 am, björn <bjorn.winck...@...> wrote:
                        > On 6 March 2010 15:56, Skammer wrote:
                        >
                        > >> Have you got Quickstart enabled by any chance?
                        >
                        > > I have. I turned it off and it had no effect.
                        >
                        > Ok, it may be that something in your rc-files cause this.  Can you try
                        > renaming them temporarily to see if that makes any difference?  If so,
                        > can you figure out what lines cause it?

                        I'm also seeing this issue, and have isolated the problem to my
                        guioptions.

                        With the following testrc file:

                        set guioptions=gmLtT
                        set bg=dark
                        hi normal guibg=black guifg=white

                        and the following invocation:

                        mvim --noplugin -U /dev/null -u ./testrc

                        I get a white flash when MacVim starts. If I switch off the
                        experimental renderer, or comment out the guioptions line, this goes
                        away. I tried removing the guioptions one by one, but couldn't find a
                        single option which caused it. Perhaps it's an interaction between
                        multiple options. I will do a little research to see if I can make
                        sense of it.

                        > > Apparently, it's a bug with new renderer. Turning it off eliminated
                        > > this weird blinking, but scrolling big files became painfully slow :(
                        >
                        > Ok, I suspected as much.  It shouldn't be too hard to fix, only I need
                        > some way to reproduce it (I don't see any flashes).

                        Hopefully the above rc file will do the trick.

                        cheers, J

                        --
                        You received this message from the "vim_mac" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php
                      • J Irving
                        ... A quick follow up to my last message (which doesn t seem to have posted yet). I switched guioptions back to their default (egmrt) and found that the
                        Message 11 of 12 , Mar 6, 2010
                        • 0 Attachment
                          On Mar 6, 10:00 am, björn <bjorn.winck...@...> wrote:
                          > On 6 March 2010 15:56, Skammer wrote:
                          >
                          > >> Have you got Quickstart enabled by any chance?
                          >
                          > > I have. I turned it off and it had no effect.
                          >
                          > Ok, it may be that something in your rc-files cause this.  Can you try
                          > renaming them temporarily to see if that makes any difference?  If so,
                          > can you figure out what lines cause it?

                          A quick follow up to my last message (which doesn't seem to have
                          posted yet).

                          I switched guioptions back to their default (egmrt) and found that the
                          flashing stopped. Simply removing "r" caused it to come back. I've
                          confirmed that adding "r" to my original set of options causes the
                          flashing to go away (and of course the scrollbar to appear).

                          HTH

                          cheers, J

                          --
                          You received this message from the "vim_mac" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php
                        • björn
                          ... Ah good, now I can reproduce the flashing as well (set go-=r in .gvimrc did the trick). I ll have this fixed for the next snapshot. Thanks for telling me
                          Message 12 of 12 , Mar 7, 2010
                          • 0 Attachment
                            On 7 March 2010 06:04, J Irving wrote:
                            >
                            > I switched guioptions back to their default (egmrt) and found that the
                            > flashing stopped.  Simply removing "r" caused it to come back.  I've
                            > confirmed that adding "r" to my original set of options causes the
                            > flashing to go away (and of course the scrollbar to appear).

                            Ah good, now I can reproduce the flashing as well (set go-=r in
                            .gvimrc did the trick). I'll have this fixed for the next snapshot.
                            Thanks for telling me how to reproduce the problem.

                            Björn

                            --
                            You received this message from the "vim_mac" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php
                          Your message has been successfully submitted and would be delivered to recipients shortly.