Loading ...
Sorry, an error occurred while loading the content.
 

Re: Trailing ^M characters in .vimrc?

Expand Messages
  • Maximilian Nickel
    ... You can open that file, enter set fileformat=mac and write it again. This should convert all line-endings to a Mac-friendly format. Regards, Max -- You
    Message 1 of 3 , Feb 28, 2010
      On Sat, Feb 27, 2010 at 9:39 AM, Jonathan <jonathan.weed@...> wrote:
      > Apologies if this is an obvious problem, but the solutions I've been
      > looking at don't seem to work.
      >
      > When I load MacVim (via mvim from the terminal), the following error
      > messages appear:
      >
      >>Error detected while processing /Users/jweed/.vimrc:
      >>line    2:
      >>E488: Trailing characters: nocompatible^M
      >>line    5:
      >>E474: Invalid argument: columns=80^M
      >>line    6:
      >>E474: Invalid argument: wrapmargin=8^M
      >>line    7:
      >>E492: Not an editor command: ^M
      >
      > Based on information I've found online, this seems to be a problem
      > with line encodings. The only solutions I've found suggest fixing this
      > problem by running a substitute command: %s/\r/\r/g. I've tried this
      > (from inside MacVim) and it seems to work fine, but when I restart
      > mvim the same error occurs and my .vimrc options are not set.
      >
      > Any suggestions? For reference, my .vimrc appears below, as it appears
      > when I open it in macvim.
      >
      > Thanks, Jonathan
      >

      You can open that file, enter "set fileformat=mac" and write it again.
      This should convert all line-endings to a Mac-friendly format.

      Regards,
      Max

      --
      You received this message from the "vim_mac" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Tony Mechelynck
      ... See :help :source-crnl If you want to use a single vimrc on Unix-like Vim (which can only handle LF-only ends-of-lines) and on Mac-Classic-like Vim (which
      Message 2 of 3 , Mar 1, 2010
        On Feb 27, 9:39 am, Jonathan <jonathan.w...@...> wrote:
        > Apologies if this is an obvious problem, but the solutions I've been
        > looking at don't seem to work.
        >
        > When I load MacVim (via mvim from the terminal), the following error
        > messages appear:
        >
        > >Error detected while processing /Users/jweed/.vimrc:
        > >line    2:
        > >E488: Trailing characters: nocompatible^M
        > >line    5:
        > >E474: Invalid argument: columns=80^M
        > >line    6:
        > >E474: Invalid argument: wrapmargin=8^M
        > >line    7:
        > >E492: Not an editor command: ^M
        >
        > Based on information I've found online, this seems to be a problem
        > with line encodings. The only solutions I've found suggest fixing this
        > problem by running a substitute command: %s/\r/\r/g. I've tried this
        > (from inside MacVim) and it seems to work fine, but when I restart
        > mvim the same error occurs and my .vimrc options are not set.
        >
        > Any suggestions? For reference, my .vimrc appears below, as it appears
        > when I open it in macvim.
        >
        > Thanks, Jonathan
        >

        See :help :source-crnl

        If you want to use a single vimrc on Unix-like Vim (which can only
        handle LF-only ends-of-lines) and on Mac-Classic-like Vim (which can
        handle either LF-only or CR-only but only if 'fileformats' [plural] is
        not empty) you may have to (1) make sure that your vimrc was written
        with 'fileformat' (singular) set to "unix" (use :setlocal ff=unix just
        before writing it) and (2) invoke Vim with --cmd "set ffs=mac,unix" on
        the command-line.

        See also
        :help 'fileformat'
        :help 'fileformats'
        :help --cmd


        Best regards,
        Tony.
        --
        On account of being a democracy and run by the people, we are the only
        nation in the world that has to keep a government four years, no
        matter
        what it does.
        -- Will Rogers

        --
        You received this message from the "vim_mac" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.