Loading ...
Sorry, an error occurred while loading the content.

Re: MacVim and Input Methods

Expand Messages
  • Yongwei Wu
    ... Hi, Björn, it did the magic! You are so sweet. :-) ... OK, this is the complete test case: 1) Go to System Preferences International Input Menu, and
    Message 1 of 3 , Jan 17, 2010
    • 0 Attachment
      2010/1/17 björn <bjorn.winckler@...>:
      > 2010/1/17 Yongwei Wu:
      >> I noticed an issue specific to MacVim. When near the right margin, a
      >> Chinese phrase may be shifted entirely to the next line, instead of
      >> being broken in the middle (I have formatoptions=mMtcql).
      >>
      >> E.g. when I have:
      >>
      >> ..........汉字
      >>
      >> and I try to input another Chinese phrase, say 输入. I need to input
      >> some "shuru", and then a space to convert it into Chinese. The ideal
      >> result should be:
      >>
      >> ..........汉字输
      >> 入
      >>
      >> While the console vim can give me this result, three different Chinese
      >> input methods all give me this result:
      >>
      >> Before pressing space:
      >> ..........汉字
      >> shuru
      >>
      >> After pressing space:
      >> ..........汉字
      >> 输入
      >>
      >> I.e. line breaking occurred before the input is finished.
      >>
      >> Does anybody have a clue here?
      >>
      >> Best regards,
      >>
      >> Yongwei
      >
      > Hi Yongwei,
      >
      > It is probably the "new" IM code that is causing this. Please try
      > quitting MacVim completely, then open Terminal and type:
      >
      > defaults write org.vim.MacVim MMUseInlineIm 0

      Hi, Björn, it did the magic! You are so sweet. :-)

      > Then restart MacVim and see what happens.
      >
      > Can you also please tell me what keystrokes to type in order to enter
      > the examples in your original post (and which input method you used)
      > so that I can try it out myself?

      OK, this is the complete test case:

      1) Go to System Preferences > International > Input Menu, and choose
      Simplified Chinese.
      2) Open a MacVim window, and input ":setlocal tw=10 fo=mMtcql".
      3) Copy into it "....汉字".
      4) Move to the end of the line, enter Insert mode by pressing "a", and
      choose ITABC as the input method.
      5) Enter "shuru<SP><SP>" (TWO spaces are specific to this input
      method).

      You can see "输入" on one line or two lines, depending on the
      MMUseInlineIm setting.

      Best regards,

      Yongwei

      --
      Wu Yongwei
      URL: http://wyw.dcweb.cn/
    Your message has been successfully submitted and would be delivered to recipients shortly.