Loading ...
Sorry, an error occurred while loading the content.

Re: Input gets slow, almost hangs, while editing ruby files if "foldmethod" is set to "syntax"

Expand Messages
  • björn
    ... I ll have a look...but can you please give me a minimal setup to reproduce the bug first? (Copy&paste a minimal vimrc/gvimrc that reproduces the problem.)
    Message 1 of 5 , Dec 27, 2009
    • 0 Attachment
      2009/12/26 Skammer:
      > Text input gets extremely slow while editing this file
      > http://github.com/nakajima/slidedown/blob/master/lib/slidedown.rb
      > While trying to find the cause I turned off folding and everything
      > started to work fine.
      > I'm using the latest MacVim snapshot.
      >
      > A few days ago I tried vim-cocoa http://code.google.com/p/vim-cocoa/
      > The input speed didn't drop even when code folding was enabled, so I
      > think there is something wrong with macvim rather then with my setup.
      >
      > Is there any way to fix this?

      I'll have a look...but can you please give me a minimal setup to
      reproduce the bug first? (Copy&paste a minimal vimrc/gvimrc that
      reproduces the problem.)

      Björn

      --
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
    • björn
      ... Skammer: could this possibly be the following bug that you have come across? http://groups.google.com/group/vim_dev/browse_thread/thread/5d6332bc3c269ed9
      Message 2 of 5 , Jan 5, 2010
      • 0 Attachment
        2009/12/27 björn:
        > 2009/12/26 Skammer:
        >> Text input gets extremely slow while editing this file
        >> http://github.com/nakajima/slidedown/blob/master/lib/slidedown.rb
        >> While trying to find the cause I turned off folding and everything
        >> started to work fine.
        >> I'm using the latest MacVim snapshot.
        >>
        >> A few days ago I tried vim-cocoa http://code.google.com/p/vim-cocoa/
        >> The input speed didn't drop even when code folding was enabled, so I
        >> think there is something wrong with macvim rather then with my setup.
        >>
        >> Is there any way to fix this?
        >
        > I'll have a look...but can you please give me a minimal setup to
        > reproduce the bug first? (Copy&paste a minimal vimrc/gvimrc that
        > reproduces the problem.)

        Skammer: could this possibly be the following bug that you have come across?

        http://groups.google.com/group/vim_dev/browse_thread/thread/5d6332bc3c269ed9

        (Does the vim-cocoa version you tried with include patch 274?)

        Björn

        --
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
      • Jjgod Jiang
        Hi, ... The vim-cocoa binary I released does not include patch 274. - Jiang -- You received this message from the vim_mac maillist. For more information,
        Message 3 of 5 , Jan 5, 2010
        • 0 Attachment
          Hi,

          On Tue, Jan 5, 2010 at 8:03 PM, björn <bjorn.winckler@...> wrote:
          > (Does the vim-cocoa version you tried with include patch 274?)

          The vim-cocoa binary I released does not include patch 274.

          - Jiang

          --
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
        • Christian Kruse
          Hi there, ... It seems as if the bug is already fixed. I clone d the latest git version and built it on my Mac with following configure flags: ./configure
          Message 4 of 5 , Jan 20, 2010
          • 0 Attachment
            Hi there,

            Am 26.12.2009 um 21:17 schrieb Skammer:

            > Is there any way to fix this?

            It seems as if the bug is already fixed. I clone'd the latest git version and built it on my Mac with following configure flags:

            ./configure --with-features=huge --enable-rubyinterp --with-macarchs=x86_64 --with-macsdk=10.6

            and it works like a charm.

            LG,
            CK
          Your message has been successfully submitted and would be delivered to recipients shortly.