Loading ...
Sorry, an error occurred while loading the content.

Re: Not so responsive for large files

Expand Messages
  • björn
    ... Have you tried simply cleaning out the entire project and rebuilding (make clean; make)? I see variations of this problem every now and then and the
    Message 1 of 9 , Dec 2, 2009
    • 0 Attachment
      2009/12/1 Yi Wen:
      > I compiled the MacVim from the commit
      > b469d9629f68b1c20541994863fedd93be2b046d (on Nov 28) using
      > configuration options:
      > --with-features=huge --enable-cscope --enable-pythoninterp --enable-
      > rubyinterp --enable-perlinterp
      > I have Snow Leopard.
      >
      > I am using "Experimental renderer". Enabled transparency. What I am
      > experiencing is that when working with a file more than 200 lines.
      > Things become very slow. The ctags can take 10 seconds to suggest
      > items. moving, editing, everything is slow. Any idea why? I used a
      > snapshot and that was fast. Thanks

      Have you tried simply cleaning out the entire project and rebuilding
      (make clean; make)? I see variations of this problem every now and
      then and the solution is always to start over from scratch.

      Björn

      --
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
    • Yi Wen
      Tried, also tried with different combinations of configuration options, no luck. :( Used vim from MacPorts at the moment and it runs smoothly. Yi ... -- You
      Message 2 of 9 , Dec 2, 2009
      • 0 Attachment
        Tried, also tried with different combinations of configuration
        options, no luck. :(

        Used vim from MacPorts at the moment and it runs smoothly.

        Yi

        On Dec 2, 3:48 am, björn <bjorn.winck...@...> wrote:
        > 2009/12/1 Yi Wen:
        >
        > > I compiled the MacVim from the commit
        > > b469d9629f68b1c20541994863fedd93be2b046d (on Nov 28) using
        > > configuration options:
        > > --with-features=huge --enable-cscope --enable-pythoninterp --enable-
        > > rubyinterp --enable-perlinterp
        > > I have Snow Leopard.
        >
        > > I am using "Experimental renderer". Enabled transparency. What I am
        > > experiencing is that when working with a file more than 200 lines.
        > > Things become very slow. The ctags can take 10 seconds to suggest
        > > items. moving, editing, everything is slow. Any idea why? I used a
        > > snapshot and that was fast. Thanks
        >
        > Have you tried simply cleaning out the entire project and rebuilding
        > (make clean; make)?  I see variations of this problem every now and
        > then and the solution is always to start over from scratch.
        >
        > Björn

        --
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
      • björn
        ... Sorry, I don t know what the problem is...I d recommend you stick with the latest snapshot. Björn -- You received this message from the vim_mac
        Message 3 of 9 , Dec 3, 2009
        • 0 Attachment
          2009/12/2 Yi Wen:
          > Tried, also tried with different combinations of configuration
          > options, no luck. :(
          >
          > Used vim from MacPorts at the moment and it runs smoothly.

          Sorry, I don't know what the problem is...I'd recommend you stick with
          the latest snapshot.

          Björn

          --
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
        • Yi Wen
          I had to go all the way back toAug 2008 s release to get back the speed. really strange. Do you think this has anything to do with leopard upgrade to SL and
          Message 4 of 9 , Jan 31, 2010
          • 0 Attachment
            I had to go all the way back toAug 2008's release to get back the
            speed. really strange. Do you think this has anything to do with
            leopard upgrade to SL and all that? Thanks

            On Dec 3 2009, 11:17 am, björn <bjorn.winck...@...> wrote:
            > 2009/12/2 YiWen:
            >
            > > Tried, also tried with different combinations of configuration
            > > options, no luck. :(
            >
            > > Used vim from MacPorts at the moment and it runs smoothly.
            >
            > Sorry, I don't know what the problem is...I'd recommend you stick with
            > the latest snapshot.
            >
            > Björn

            --
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
          • björn
            ... You still only have issues when compiling yourself, right? Björn -- You received this message from the vim_mac maillist. For more information, visit
            Message 5 of 9 , Feb 1, 2010
            • 0 Attachment
              On 1 February 2010 04:59, Yi Wen <hayafirst@...> wrote:
              > I had to go all the way back toAug 2008's release to get back the
              > speed. really strange. Do you think this has anything to do with
              > leopard upgrade to SL and all that? Thanks

              You still only have issues when compiling yourself, right?

              Björn

              --
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
            • Yi Wen
              Just to be sure, I reinstalled the snapshot on Nov 21st. No. it s very very slow. :( For what it worths, the system info shows: 64-bit Kernel and Extensions:
              Message 6 of 9 , Feb 1, 2010
              • 0 Attachment
                Just to be sure, I reinstalled the snapshot on Nov 21st. No. it's very
                very slow. :(
                For what it worths, the system info shows: 64-bit Kernel and
                Extensions: No

                Thanks

                Yi

                On Feb 1, 9:17 am, björn <bjorn.winck...@...> wrote:
                > On 1 February 2010 04:59, Yi Wen <hayafi...@...> wrote:
                >
                > > I had to go all the way back toAug 2008's release to get back the
                > > speed. really strange. Do you think this has anything to do with
                > > leopard upgrade to SL and all that? Thanks
                >
                > You still only have issues when compiling yourself, right?
                >
                > Björn

                --
                You received this message from the "vim_mac" maillist.
                For more information, visit http://www.vim.org/maillist.php
              • björn
                ... Unfortunately I have no idea what s going on. Have you followed the steps here: http://code.google.com/p/macvim/wiki/ReportingBugs Has anybody else run
                Message 7 of 9 , Feb 4, 2010
                • 0 Attachment
                  On 1 February 2010 20:01, Yi Wen wrote:
                  > Just to be sure, I reinstalled the snapshot on Nov 21st. No. it's very
                  > very slow. :(
                  > For what it worths, the system info shows: 64-bit Kernel and
                  > Extensions:     No

                  Unfortunately I have no idea what's going on. Have you followed the steps here:

                  http://code.google.com/p/macvim/wiki/ReportingBugs

                  Has anybody else run MacVim with a 64-bit kernel (not that I think
                  that is the problem)? (I can't boot mine in 64 bit mode.)

                  Björn

                  --
                  You received this message from the "vim_mac" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                • Yi Wen
                  I tried all steps but the first step. I will try that later. Mine, I think is actually not in 64 bits kennel, since 64-bit Kernel and Extensions show No Thanks
                  Message 8 of 9 , Feb 5, 2010
                  • 0 Attachment
                    I tried all steps but the first step. I will try that later.

                    Mine, I think is actually not in 64 bits kennel, since 64-bit Kernel
                    and Extensions show No

                    Thanks

                    Yi

                    On Feb 4, 3:24 pm, björn <bjorn.winck...@...> wrote:
                    > On 1 February 2010 20:01, Yi Wen wrote:
                    >
                    > > Just to be sure, I reinstalled the snapshot on Nov 21st. No. it's very
                    > > very slow. :(
                    > > For what it worths, the system info shows: 64-bit Kernel and
                    > > Extensions:     No
                    >
                    > Unfortunately I have no idea what's going on.  Have you followed the steps here:
                    >
                    > http://code.google.com/p/macvim/wiki/ReportingBugs
                    >
                    > Has anybody else run MacVim with a 64-bit kernel (not that I think
                    > that is the problem)?  (I can't boot mine in 64 bit mode.)
                    >
                    > Björn

                    --
                    You received this message from the "vim_mac" maillist.
                    For more information, visit http://www.vim.org/maillist.php
                  Your message has been successfully submitted and would be delivered to recipients shortly.