Loading ...
Sorry, an error occurred while loading the content.
 

Re: PATH environment variable

Expand Messages
  • björn
    ... Yes, it is almost certainly a problem with the shell. Unfortunately I m not the right person to help with shell-related problems (maybe somebody else has
    Message 1 of 4 , Dec 1, 2009
      2009/11/27 Rémi Prévost:
      > On Nov 27, 5:07 pm, björn wrote:
      >> It is enabled by default.  To make sure you haven't accidentally
      >> disabled it, open up Terminal and enter
      >>
      >> defaults read org.vim.MacVim
      >>
      >> and look for an entry named "MMLoginShell" (which should be set to "1"
      >> or there shouldn't be one at all).
      >
      > I ran the command and the option you mentionned wasn't there. I read
      > somewhere that MacVim runs "bash" then itself. Could I get this
      > problem because I'm using zsh instead of bash? Thanks!

      Yes, it is almost certainly a problem with the shell. Unfortunately
      I'm not the right person to help with shell-related problems (maybe
      somebody else has a clue?). One thing you could try is to open
      Terminal.app and enter:

      defaults write org.vim.MacVim MMLoginShellCommand "/bin/zsh"

      and replace the "/bin/zsh" with the correct path to your zsh
      interpreter. You'll have to quit MacVim (Cmd+q, its not enough to
      just close a window) and restart it for this to take effect.

      Read up on ":h macvim-login-shell"...maybe that will help.

      Björn

      --
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.