Loading ...
Sorry, an error occurred while loading the content.

PATH environment variable

Expand Messages
  • Rémi Prévost
    I know this has been discussed before (in this mailing list and blog posts) but I can t seem to find a clear answer to my problem. I have a custom $PATH
    Message 1 of 4 , Nov 27, 2009
    • 0 Attachment
      I know this has been discussed before (in this mailing list and blog
      posts) but I can't seem to find a clear answer to my problem.

      I have a custom $PATH variable defined in my .zshrc file. However,
      when I launch MacVim.app and do a `echo $PATH`, it looks like a
      default $PATH to me. I know there once was a "Launch MacVim from a
      shell" option, but it seems unavailable now.

      What would be the best way to tell MacVim to pick up my custom $PATH
      variable?

      Thanks!

      - Rémi

      --
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
    • björn
      ... It is enabled by default. To make sure you haven t accidentally disabled it, open up Terminal and enter defaults read org.vim.MacVim and look for an entry
      Message 2 of 4 , Nov 27, 2009
      • 0 Attachment
        2009/11/27 Rémi Prévost:
        >
        > I have a custom $PATH variable defined in my .zshrc file. However,
        > when I launch MacVim.app and do a `echo $PATH`, it looks like a
        > default $PATH to me. I know there once was a "Launch MacVim from a
        > shell" option, but it seems unavailable now.

        It is enabled by default. To make sure you haven't accidentally
        disabled it, open up Terminal and enter

        defaults read org.vim.MacVim

        and look for an entry named "MMLoginShell" (which should be set to "1"
        or there shouldn't be one at all).

        Björn

        --
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
      • Rémi Prévost
        ... I ran the command and the option you mentionned wasn t there. I read somewhere that MacVim runs bash then itself. Could I get this problem because I m
        Message 3 of 4 , Nov 27, 2009
        • 0 Attachment
          On Nov 27, 5:07 pm, björn <bjorn.winck...@...> wrote:
          > It is enabled by default.  To make sure you haven't accidentally
          > disabled it, open up Terminal and enter
          >
          > defaults read org.vim.MacVim
          >
          > and look for an entry named "MMLoginShell" (which should be set to "1"
          > or there shouldn't be one at all).

          I ran the command and the option you mentionned wasn't there. I read
          somewhere that MacVim runs "bash" then itself. Could I get this
          problem because I'm using zsh instead of bash? Thanks!

          --
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
        • björn
          ... Yes, it is almost certainly a problem with the shell. Unfortunately I m not the right person to help with shell-related problems (maybe somebody else has
          Message 4 of 4 , Dec 1, 2009
          • 0 Attachment
            2009/11/27 Rémi Prévost:
            > On Nov 27, 5:07 pm, björn wrote:
            >> It is enabled by default.  To make sure you haven't accidentally
            >> disabled it, open up Terminal and enter
            >>
            >> defaults read org.vim.MacVim
            >>
            >> and look for an entry named "MMLoginShell" (which should be set to "1"
            >> or there shouldn't be one at all).
            >
            > I ran the command and the option you mentionned wasn't there. I read
            > somewhere that MacVim runs "bash" then itself. Could I get this
            > problem because I'm using zsh instead of bash? Thanks!

            Yes, it is almost certainly a problem with the shell. Unfortunately
            I'm not the right person to help with shell-related problems (maybe
            somebody else has a clue?). One thing you could try is to open
            Terminal.app and enter:

            defaults write org.vim.MacVim MMLoginShellCommand "/bin/zsh"

            and replace the "/bin/zsh" with the correct path to your zsh
            interpreter. You'll have to quit MacVim (Cmd+q, its not enough to
            just close a window) and restart it for this to take effect.

            Read up on ":h macvim-login-shell"...maybe that will help.

            Björn

            --
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
          Your message has been successfully submitted and would be delivered to recipients shortly.