Loading ...
Sorry, an error occurred while loading the content.

Re: Something Wrong With Input Method

Expand Messages
  • Kazuki Sakamoto
    Hi, ... Please try the following in Terminal.app. $ defaults write org.vim.MacVim MMUseInlineIm 0 sakamoto
    Message 1 of 4 , Nov 11, 2009
    • 0 Attachment
      Hi,

      On Wed, Nov 11, 2009 at 8:59 PM, linluxiang <linluxiang@...> wrote:
      > In snapshop 45, the character "o" is received only by the Input Method. And I think this is the right way. The version 50 maybe has a bug.

      Please try the following in Terminal.app.

      $ defaults write org.vim.MacVim MMUseInlineIm 0

      sakamoto

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • björn
      2009/11/11 linluxiang ... Indeed, that looks like a bug and I ll take a look at it. In the meantime you can follow Sakamoto s tip to revert back to the old
      Message 2 of 4 , Nov 11, 2009
      • 0 Attachment
        2009/11/11 linluxiang>
        >
        > Hi Björn,
        >  I recently changed my MacVim from snapshot 45 to snapshop 50. And I found there was a bug in the new version.
        > I am Chinese so I use Input Method to input Chinese in MacVim.
        > 1. I enter the normal mode with my Input Method on
        > 2. I press some key, such "o".
        > 3. The character "o" is received both by MacVim and Input Method.
        > 4. The MacVim execute command "o" and then start a new line.
        > 5. The mode changed from normal to IM Insert.
        > (see screenshot 1)
        > In snapshop 45, the character "o" is received only by the Input Method. And I think this is the right way. The version 50 maybe has a bug.

        Indeed, that looks like a bug and I'll take a look at it. In the
        meantime you can follow Sakamoto's tip to revert back to the old IM
        code and things should work the way they did in snap 45.

        Thanks for the report,
        Björn

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • linluxiang
        Hi ... Thanks very much. It work well now. ... Where Python Happens! --~--~---------~--~----~------------~-------~--~----~ You received this message from the
        Message 3 of 4 , Nov 11, 2009
        • 0 Attachment
          Hi

          > Please try the following in Terminal.app.
          >
          > $ defaults write org.vim.MacVim MMUseInlineIm 0

          Thanks very much.
          It work well now.
          -----------------------------------
          Where Python Happens!


          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        Your message has been successfully submitted and would be delivered to recipients shortly.