Loading ...
Sorry, an error occurred while loading the content.

Re: Problems with some simbols in MacVim

Expand Messages
  • Israel Chauca Fuentes
    I also use the spanish layout and termencoding is set to utf-8, but I don t have any trouble with # or any other key. Israel ...
    Message 1 of 8 , Nov 10, 2009
    • 0 Attachment
      I also use the spanish layout and termencoding is set to utf-8, but I
      don't have any trouble with # or any other key.

      Israel

      On Nov 10, 2009, at 7:39 PM, Pablo Giménez wrote:

      > Just checking, now is printing characters but not the proper ones.
      > In the spanish layout you have to press Option(Alt)+3 to get the #
      > symbol.
      > I am getting a different one, is like if MacVim doesn´t like the
      > spanish
      > keyboard layout.
      > thx
      >
      > El 11 de noviembre de 2009 01:26, Pablo Giménez
      > <pablogipi@...>escribió:
      >
      >> Hi.
      >> I am using MacVim with a spanish keyboard layout.
      >> I always use the termencoding=utf-8 option.
      >> My problem is that I can´t use some symbols like for example the #,
      >> basically it doesn´t appear whe I typed them.
      >> All the symbols works properly in other tools is just MacVim,
      >> Is this related with some utf problem like this:
      >> http://old.nabble.com/MacVim-file-encoding-and-Quicklook-td17289501.html
      >> Or is just a limitation of MacVim with thespanish keyboard layout.
      >> thx
      >>
      >>
      >> PD: is the problem described in the above link solved?
      >>
      >> --
      >> Un saludo
      >> Best Regards
      >> Pablo Giménez
      >>
      >
      >
      >
      > --
      > Un saludo
      > Best Regards
      > Pablo Giménez
      >
      > >


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Pablo Giménez
      Thanks Israel. Just checking seems that in the Mac the spanish keyboard layout is in using the latin encoding rather than unicode. I don t know if this can
      Message 2 of 8 , Nov 11, 2009
      • 0 Attachment
        Thanks Israel.
        Just checking seems that in the Mac the spanish keyboard layout is in using the latin encoding rather than unicode. I don't know if this can cause the problem.

        2009/11/11 Israel Chauca Fuentes <israelchauca@...>

        I also use the spanish layout and termencoding is set to utf-8, but I
        don't have any trouble with # or any other key.

        Israel

        On Nov 10, 2009, at 7:39 PM, Pablo Giménez wrote:

        > Just checking, now is printing characters but not the proper ones.
        > In the spanish layout you have  to press Option(Alt)+3 to get the  #
        > symbol.
        > I am getting a different one, is like if MacVim doesn´t like the
        > spanish
        > keyboard layout.
        > thx
        >
        > El 11 de noviembre de 2009 01:26, Pablo Giménez
        > <pablogipi@...>escribió:
        >
        >> Hi.
        >> I am using MacVim with a spanish keyboard layout.
        >> I always use the termencoding=utf-8 option.
        >> My problem is that I can´t use some symbols like for example the #,
        >> basically it doesn´t appear whe I typed them.
        >> All the symbols works properly in other tools is just MacVim,
        >> Is this related with some utf problem like this:
        >> http://old.nabble.com/MacVim-file-encoding-and-Quicklook-td17289501.html
        >> Or is just a limitation of MacVim with thespanish keyboard layout.
        >> thx
        >>
        >>
        >> PD: is the problem described in the above link solved?
        >>
        >> --
        >> Un saludo
        >> Best Regards
        >> Pablo Giménez
        >>
        >
        >
        >
        > --
        > Un saludo
        > Best Regards
        > Pablo Giménez
        >
        > >






        --
        Un saludo
        Best Regards
        Pablo Giménez

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---

      • björn
        Hi Pablo, My replies are a little out of order, I hope you can cope. ... All input that reaches MacVim is Unicode (UTF-16) ... No, you have to press Shift+3 to
        Message 3 of 8 , Nov 11, 2009
        • 0 Attachment
          Hi Pablo,

          My replies are a little out of order, I hope you can cope.

          2009/11/11 Pablo Giménez:
          > Just checking seems that in the Mac the spanish keyboard layout is in using
          > the latin encoding rather than unicode. I don't know if this can cause the
          > problem.

          All input that reaches MacVim is Unicode (UTF-16)

          >> > Just checking, now is printing characters but not the proper ones.
          >> > In the spanish layout you have  to press Option(Alt)+3 to get the  #
          >> > symbol.

          No, you have to press Shift+3 to get # using Spanish layout.

          Just open up "Keyboard Viewer" and you can see where all the keys are
          (go to "Input Sources" in the "Language & Text" System Preference
          pane, click "Show Input menu in menu bar", and in the list view tick
          the "Keyboard & Character Viewer" item at the top, then you can open
          the keyboard viewer from the language menu that sits next to the clock
          on the menu bar).

          >> >> I am using MacVim with a spanish keyboard layout.
          >> >> I always use the termencoding=utf-8 option.

          This option is forcibly set to utf-8 anyway and is ignored, so you
          don't have to set it.

          >> >> My problem is that I can´t use some symbols like for example the #,
          >> >> basically it doesn´t appear whe I typed them.
          >> >> All the symbols works properly in other tools is just MacVim,

          I don't understand the problem. Please be more specific (step-by-step
          instructions).

          >> >> Is this related with some utf problem like this:
          >> >>
          >> >> http://old.nabble.com/MacVim-file-encoding-and-Quicklook-td17289501.html

          No, that does not sound related.

          >> >> Or is just a limitation of MacVim with thespanish keyboard layout.

          No, there is no limitation that I am aware of.

          >> >> PD: is the problem described in the above link solved?

          No, still waiting for a patch. (hint, hint)

          Björn

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Pablo Giménez
          2009/11/11 björn ... Sorry Bjorn but in the Spanish layout # is Option+3, I am sure, uou you can see it in the keyboard viewer and
          Message 4 of 8 , Nov 12, 2009
          • 0 Attachment
            2009/11/11 björn <bjorn.winckler@...>

            Hi Pablo,

            My replies are a little out of order, I hope you can cope.

            2009/11/11 Pablo Giménez:
            > Just checking seems that in the Mac the spanish keyboard layout is in using
            > the latin encoding rather than unicode. I don't know if this can cause the
            > problem.

            All input that reaches MacVim is Unicode (UTF-16)

            >> > Just checking, now is printing characters but not the proper ones.
            >> > In the spanish layout you have  to press Option(Alt)+3 to get the  #
            >> > symbol.

            No, you have to press Shift+3 to get # using Spanish layout.
            Sorry Bjorn but in the Spanish layout # is Option+3, I am sure, uou you can see it in the keyboard viewer and I type it everyday :)
            If I open the vim shipped with MacOSX from terminal, it recognizes the Option+3 as the # character. So this only affects MacVim.
             But ... after some testing I realized that the problem is that I am using set macmeta, to use some keymaps with the M modifier.
            This seems to cause that MacVim is not passing the Option(alt) modifier properly for some key combinations, like the Option+3.
            Without macmeta the keyboard works perfectly, but I need the macmeta :)

            Just open up "Keyboard Viewer" and you can see where all the keys are
            (go to "Input Sources" in the "Language & Text" System Preference
            pane, click "Show Input menu in menu bar", and in the list view tick
            the "Keyboard & Character Viewer" item at the top, then you can open
            the keyboard viewer from the language menu that sits next to the clock
            on the menu bar).

            >> >> I am using MacVim with a spanish keyboard layout.
            >> >> I always use the termencoding=utf-8 option.

            This option is forcibly set to utf-8 anyway and is ignored, so you
            don't have to set it.

            >> >> My problem is that I can´t use some symbols like for example the #,
            >> >> basically it doesn´t appear whe I typed them.
            >> >> All the symbols works properly in other tools is just MacVim,

            I don't understand the problem.  Please be more specific (step-by-step
            instructions).

            >> >> Is this related with some utf problem like this:
            >> >>
            >> >> http://old.nabble.com/MacVim-file-encoding-and-Quicklook-td17289501.html

            No, that does not sound related.

            >> >> Or is just a limitation of MacVim with thespanish keyboard layout.

            No, there is no limitation that I am aware of.

            >> >> PD: is the problem described in the above link solved?

            No, still waiting for a patch. (hint, hint)

            Björn





            --
            Un saludo
            Best Regards
            Pablo Giménez

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---

          • björn
            ... Ok, I see that if you use the Spanish - ISO layout it is Alt+3. I tested with the layout Spanish which does use Shift+3. How confusing. :-/ ...
            Message 5 of 8 , Nov 13, 2009
            • 0 Attachment
              2009/11/13 Pablo Giménez:
              >> >> > Just checking, now is printing characters but not the proper ones.
              >> >> > In the spanish layout you have  to press Option(Alt)+3 to get the  #
              >> >> > symbol.
              >>
              >> No, you have to press Shift+3 to get # using Spanish layout.
              >
              > Sorry Bjorn but in the Spanish layout # is Option+3, I am sure, uou you can
              > see it in the keyboard viewer and I type it everyday :)

              Ok, I see that if you use the "Spanish - ISO" layout it is Alt+3. I
              tested with the layout "Spanish" which does use Shift+3. How
              confusing. :-/

              > If I open the vim shipped with MacOSX from terminal, it recognizes the
              > Option+3 as the # character. So this only affects MacVim.
              >  But ... after some testing I realized that the problem is that I am using
              > set macmeta, to use some keymaps with the M modifier.
              > This seems to cause that MacVim is not passing the Option(alt) modifier
              > properly for some key combinations, like the Option+3.
              > Without macmeta the keyboard works perfectly, but I need the macmeta :)

              Sorry, there is nothing I can do about that. Either you let Mac OS X
              interpret Alt-presses ('macmeta' off), or you let Vim handle it
              ('macmeta' on)...you can't have both. My suggestion is to rebind keys
              that use Alt to use e.g. Cmd (<D-..>) instead and turn 'macmeta' off.
              At any rate, there is no bug here.

              Björn

              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • Pablo Giménez
              2009/11/13 björn ... Yep I know I have to rebuild some of my shortcuts for the mac. Thanks Bjorn ... -- Un saludo Best Regards
              Message 6 of 8 , Nov 13, 2009
              • 0 Attachment
                2009/11/13 björn <bjorn.winckler@...>

                2009/11/13 Pablo Giménez:
                >> >> > Just checking, now is printing characters but not the proper ones.
                >> >> > In the spanish layout you have  to press Option(Alt)+3 to get the  #
                >> >> > symbol.
                >>
                >> No, you have to press Shift+3 to get # using Spanish layout.
                >
                > Sorry Bjorn but in the Spanish layout # is Option+3, I am sure, uou you can
                > see it in the keyboard viewer and I type it everyday :)

                Ok, I see that if you use the "Spanish - ISO" layout it is Alt+3.  I
                tested with the layout "Spanish" which does use Shift+3.  How
                confusing. :-/

                > If I open the vim shipped with MacOSX from terminal, it recognizes the
                > Option+3 as the # character. So this only affects MacVim.
                >  But ... after some testing I realized that the problem is that I am using
                > set macmeta, to use some keymaps with the M modifier.
                > This seems to cause that MacVim is not passing the Option(alt) modifier
                > properly for some key combinations, like the Option+3.
                > Without macmeta the keyboard works perfectly, but I need the macmeta :)

                Sorry, there is nothing I can do about that.  Either you let Mac OS X
                interpret Alt-presses ('macmeta' off), or you let Vim handle it
                ('macmeta' on)...you can't have both.  My suggestion is to rebind keys
                that use Alt to use e.g. Cmd (<D-..>) instead and turn 'macmeta' off.
                At any rate, there is no bug here.
                Yep I know I have to rebuild some of my shortcuts for the mac.
                Thanks Bjorn

                Björn





                --
                Un saludo
                Best Regards
                Pablo Giménez

                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_mac" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---

              Your message has been successfully submitted and would be delivered to recipients shortly.