Loading ...
Sorry, an error occurred while loading the content.

^W+movement key - strange behaviour on Snow Leopard

Expand Messages
  • Shirk
    Hi, ^W+movement key acts strange since upgrading to Snow Leopard. It used to switch between split windows but now it just moves the cursor to the next word.
    Message 1 of 4 , Oct 9, 2009
    • 0 Attachment
      Hi,

      ^W+movement key acts strange since upgrading to Snow Leopard.
      It used to switch between split windows but now it just moves the
      cursor to the next word.
      Correct me if I'm wrong but this used to work before SL and I didn't
      change my config since upgrading.

      For the records:
      I'm using the current git master compiled for x86_64.

      Cheers,
      Shirk

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • björn
      ... Works fine over here...try the snapshot I just released and see how that treats you. Björn --~--~---------~--~----~------------~-------~--~----~ You
      Message 2 of 4 , Oct 9, 2009
      • 0 Attachment
        2009/10/9 Shirk:
        >
        > ^W+movement key acts strange since upgrading to Snow Leopard.
        > It used to switch between split windows but now it just moves the
        > cursor to the next word.
        > Correct me if I'm wrong but this used to work before SL and I didn't
        > change my config since upgrading.

        Works fine over here...try the snapshot I just released and see how
        that treats you.

        Björn

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Shirk
        OK, got it resolved.. it s not the fault of MacVim but of my keyboard layout. I m using the dvorak layout provided here: http://halibrand.de/dvorak/ (german) -
        Message 3 of 4 , Oct 10, 2009
        • 0 Attachment
          OK,

          got it resolved.. it's not the fault of MacVim but of my keyboard
          layout.
          I'm using the dvorak layout provided here: http://halibrand.de/dvorak/
          (german) - this used to work fine with Tiger and Leopard
          but now it seem ^W doesn't send the right modifiers anymore..

          Thank you anyway!

          P.S. - I'm working on the transparency issues on SL, if all turns out
          well I'll submit a patch.

          Cheers,
          Shirk

          On 10 Okt., 00:28, björn <bjorn.winck...@...> wrote:
          > 2009/10/9 Shirk:
          >
          >
          >
          > > ^W+movement key acts strange since upgrading to Snow Leopard.
          > > It used to switch between split windows but now it just moves the
          > > cursor to the next word.
          > > Correct me if I'm wrong but this used to work before SL and I didn't
          > > change my config since upgrading.
          >
          > Works fine over here...try the snapshot I just released and see how
          > that treats you.
          >
          > Björn
          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Tony Mechelynck
          ... If you don t know which (if any) key combo will produce 0x17 (ASCII Ctrl-W) on your keyboard, you can always use the :winc[md] ex- command instead —
          Message 4 of 4 , Nov 7, 2009
          • 0 Attachment
            On Oct 10, 9:45 am, Shirk <sh...@...> wrote:
            > OK,
            >
            > got it resolved.. it's not the fault of MacVim but of my keyboard
            > layout.
            > I'm using the dvorak layout provided here:http://halibrand.de/dvorak/
            > (german) - this used to work fine with Tiger and Leopard
            > but now it seem ^W doesn't send the right modifiers anymore..
            >
            > Thank you anyway!
            >
            > P.S. - I'm working on the transparency issues on SL, if all turns out
            > well I'll submit a patch.

            If you don't know which (if any) key combo will produce 0x17 (ASCII
            Ctrl-W) on your keyboard, you can always use the ":winc[md]" ex-
            command instead — see ":help :wincmd".

            P.S. Pleast bottom-post on the Vim lists (it's possible: you don't
            have to keep the insert cursor above the quote the way the Google
            Groups web interface sets it), see http://groups.google.com/group/vim_use/web/vim-information


            Best regards,
            Tony.
            --
            If God had intended Man to Watch TV, He would have given him Rabbit
            Ears.

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          Your message has been successfully submitted and would be delivered to recipients shortly.