Loading ...
Sorry, an error occurred while loading the content.

Re: Simplified build procedure for MacVim

Expand Messages
  • Nico Weber
    ... Not really. Are you running some theming software that replaced your / System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/
    Message 1 of 12 , Oct 2, 2009
    • 0 Attachment
      >> Thanks for the reply. I have already tried cleaning the directory
      >> before running make and i still got the same error (sorry for
      >> forgetting to mention it).
      >> I even deleted my local repository and re-pulled it to ensure that i
      >> have a clean one before building and the same problem keeps popping
      >> up.
      >>
      >> Whatever i do, it seems that the assertion is always triggered.
      >>
      >> By the way, i don't know if this affects anything (probably not), but
      >> i am running the Snow Leopard kernel in 32bit mode.
      >
      > I guess you could try starting in 64 bit mode and see if it makes any
      > difference...?
      >
      > I'm afraid I don't know what the problem is: lets hope Nico has an
      > idea...Nico?

      Not really. Are you running some theming software that replaced your /
      System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/
      GenericDocumentIcon.icns ? Can you send me that file?

      Nico

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • orestis
      ... I tried to boot in 64bit mode, but i could not get it working. From what i ve read, it seems that apple decided to prevent macbooks (not pros) from booting
      Message 2 of 12 , Oct 3, 2009
      • 0 Attachment
        On Oct 2, 8:07 pm, björn <bjorn.winck...@...> wrote:
        > 2009/10/1 orestis:
        >
        >
        >
        > > Thanks for the reply. I have already tried cleaning the directory
        > > before running make and i still got the same error (sorry for
        > > forgetting to mention it).
        > > I even deleted my local repository and re-pulled it to ensure that i
        > > have a clean one before building and the same problem keeps popping
        > > up.
        >
        > > Whatever i do, it seems that the assertion is always triggered.
        >
        > > By the way, i don't know if this affects anything (probably not), but
        > > i am running the Snow Leopard kernel in 32bit mode.
        >
        > I guess you could try starting in 64 bit mode and see if it makes any
        > difference...?
        >
        > I'm afraid I don't know what the problem is: lets hope Nico has an idea...Nico?
        >
        > Björn

        I tried to boot in 64bit mode, but i could not get it working.
        From what i've read, it seems that apple decided to prevent macbooks
        (not pros) from booting into 64bit mode.
        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • orestis
        ... Hey Nico thanks! I guess that was the problem :) I used candybar to change that icon, and reverting back to the original icon macvim builds just fine. The
        Message 3 of 12 , Oct 3, 2009
        • 0 Attachment
          On Oct 2, 11:37 pm, Nico Weber <nicolaswe...@...> wrote:
          > Not really. Are you running some theming software that replaced your /
          > System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/
          > GenericDocumentIcon.icns ? Can you send me that file?
          >
          > Nico

          Hey Nico thanks!
          I guess that was the problem :) I used candybar to change that icon,
          and reverting back
          to the original icon macvim builds just fine.

          The strange thing is that if i specify the following parameters and
          use the modified icon,
          macvim builds successfully as well :

          export CFLAGS="-march=nocona -O2"
          export CCFLAGS="-march=nocona -O2"

          ./configure --with-features=big \
          --enable-cscope \
          --enable-perlinterp \
          --enable-multibyte \
          --disable-netbeans \
          --with-macsdk=10.5 \
          --with-macarchs=i386

          You can find the icon here: http://uploading.com/files/2e446921/GenericDocumentIcon.icns/
          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Tyson Roberts
          From what I understand, the 32 bit kernel should not affect anything, really. None of the stuff that touches external apps (including 64 bit libraries/apps)
          Message 4 of 12 , Oct 3, 2009
          • 0 Attachment
            From what I understand, the 32 bit kernel should not affect anything, really.  None of the stuff that touches external apps (including 64 bit libraries/apps) is affected by whether the kernel is running in 32/64 bit.  The 32 bit kernel supports 64 bit apps without change.

            Also, it's not just the MBs that are affected - almost all models (with the exception of some of their servers) boot into 32 bit kernel by default, mostly out of respect for the fact that most 3rd parties haven't written 64 bit drivers yet.

            Tyson


            > > By the way, i don't know if this affects anything (probably not), but
            > > i am running the Snow Leopard kernel in 32bit mode.
            >
            > I guess you could try starting in 64 bit mode and see if it makes any
            > difference...?
            >
            > I'm afraid I don't know what the problem is: lets hope Nico has an idea...Nico?
            >
            > Björn

            I tried to boot in 64bit mode, but i could not get it working.
            From what i've read, it seems that apple decided to prevent macbooks
            (not pros) from booting into 64bit mode.



            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---

          • orestis
            Hello Tyson, Yes i am aware of this as some of the apps already run at 64bit mode. What I am saying is that apple decided to turn off 64bit mode on macbooks
            Message 5 of 12 , Oct 3, 2009
            • 0 Attachment
              Hello Tyson,

              Yes i am aware of this as some of the apps already run at 64bit mode.
              What I am saying is that apple decided to turn off 64bit mode on
              macbooks completely.

              So even if i change the boot flags as stated here (http://netkas.org/?
              p=127)
              or holding down the keys "6" and "4" during boot, i always get into
              32bit mode.

              What i was thinking was that the automated build process might had a
              bug into
              picking the right libraries / paths and so on, as the configure script
              uses uname to get information about the system...

              However, as it seems the problem was due to a modified icon. (thanks
              Nico).

              On Oct 3, 11:20 am, Tyson Roberts <nallo...@...> wrote:
              > From what I understand, the 32 bit kernel should not affect anything,
              > really.  None of the stuff that touches external apps (including 64 bit
              > libraries/apps) is affected by whether the kernel is running in 32/64 bit.
              > The 32 bit kernel supports 64 bit apps without change.
              >
              > Also, it's not just the MBs that are affected - almost all models (with the
              > exception of some of their servers) boot into 32 bit kernel by default,
              > mostly out of respect for the fact that most 3rd parties haven't written 64
              > bit drivers yet.
              >
              > Tyson
              >
              > > > By the way, i don't know if this affects anything (probably not), but
              > > > > i am running the Snow Leopard kernel in 32bit mode.
              >
              > > > I guess you could try starting in 64 bit mode and see if it makes any
              > > > difference...?
              >
              > > > I'm afraid I don't know what the problem is: lets hope Nico has an
              > > idea...Nico?
              >
              > > > Björn
              >
              > > I tried to boot in 64bit mode, but i could not get it working.
              > > From what i've read, it seems that apple decided to prevent macbooks
              > > (not pros) from booting into 64bit mode.
              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • Tyson Roberts
              Yeah, I m in the same situation on my MBP - set the flags and did the 6/4 trick to no avail. I suspect that might change in the future, but in any case, not
              Message 6 of 12 , Oct 3, 2009
              • 0 Attachment
                Yeah, I'm in the same situation on my MBP - set the flags and did the 6/4 trick to no avail.

                I suspect that might change in the future, but in any case, not really worried.  I apologize,
                was not meaning to preach to the choir on this one. 

                Anyway, I digress - back to MacVim stuff!

                - Tyson

                On Sat, Oct 3, 2009 at 7:50 PM, orestis <arestis@...> wrote:

                Hello Tyson,

                Yes i am aware of this as some of the apps already run at 64bit mode.
                What I am saying is that apple decided to turn off 64bit mode on
                macbooks completely.

                So even if i change the boot flags as stated here (http://netkas.org/?
                p=127
                )
                or holding down the keys "6" and "4" during boot, i always get into
                32bit mode.

                What i was thinking was that the automated build process might had a
                bug into
                picking the right libraries / paths and so on, as the configure script
                uses uname to get information about the system...

                However, as it seems the problem was due to a modified icon. (thanks
                Nico).

                On Oct 3, 11:20 am, Tyson Roberts <nallo...@...> wrote:
                > From what I understand, the 32 bit kernel should not affect anything,
                > really.  None of the stuff that touches external apps (including 64 bit
                > libraries/apps) is affected by whether the kernel is running in 32/64 bit.
                > The 32 bit kernel supports 64 bit apps without change.
                >
                > Also, it's not just the MBs that are affected - almost all models (with the
                > exception of some of their servers) boot into 32 bit kernel by default,
                > mostly out of respect for the fact that most 3rd parties haven't written 64
                > bit drivers yet.
                >
                > Tyson
                >
                > > > By the way, i don't know if this affects anything (probably not), but
                > > > > i am running the Snow Leopard kernel in 32bit mode.
                >
                > > > I guess you could try starting in 64 bit mode and see if it makes any
                > > > difference...?
                >
                > > > I'm afraid I don't know what the problem is: lets hope Nico has an
                > > idea...Nico?
                >
                > > > Björn
                >
                > > I tried to boot in 64bit mode, but i could not get it working.
                > > From what i've read, it seems that apple decided to prevent macbooks
                > > (not pros) from booting into 64bit mode.



                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_mac" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---

              Your message has been successfully submitted and would be delivered to recipients shortly.