Loading ...
Sorry, an error occurred while loading the content.

Unknown class 'SUUpdater'

Expand Messages
  • travisjeffery
    I m running MacVim from a fresh build off of the Git rep and I get this output when I got run MacVim with mvim command: 2009-10-02 16:21:39.037
    Message 1 of 2 , Oct 2, 2009
    • 0 Attachment
      I'm running MacVim from a fresh build off of the Git rep and I get
      this output when I got run MacVim with mvim command:

      2009-10-02 16:21:39.037 MacVim[34718:903] Unknown class 'SUUpdater',
      using 'NSObject' instead. Encountered in Interface Builder file at
      path /Users/travis/Documents/repos/macvim/src/MacVim/build/Release/
      MacVim.app/Contents/Resources/English.lproj/MainMenu.nib.
      2009-10-02 16:21:39.354 MacVim[34718:903] Could not connect the action
      checkForUpdates: to target of class NSObject

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • björn
      ... It s nothing to worry about: the Sparkle framework (automatic updating) is missing a binary for the x86_64 architecture. I ll be updating Sparkle next, I
      Message 2 of 2 , Oct 2, 2009
      • 0 Attachment
        2009/10/2 travisjeffery:
        >
        > I'm running MacVim from a fresh build off of the Git rep and I get
        > this output when I got run MacVim with mvim command:
        >
        > 2009-10-02 16:21:39.037 MacVim[34718:903] Unknown class 'SUUpdater',
        > using 'NSObject' instead. Encountered in Interface Builder file at
        > path /Users/travis/Documents/repos/macvim/src/MacVim/build/Release/
        > MacVim.app/Contents/Resources/English.lproj/MainMenu.nib.
        > 2009-10-02 16:21:39.354 MacVim[34718:903] Could not connect the action
        > checkForUpdates: to target of class NSObject

        It's nothing to worry about: the Sparkle framework (automatic
        updating) is missing a binary for the x86_64 architecture. I'll be
        updating Sparkle next, I just have to decide whether to just fetch new
        Sparkle binaries, or add the source as a git submodule, or ...

        Björn

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.