Loading ...
Sorry, an error occurred while loading the content.
 

encoding

Expand Messages
  • Doris Wagner
    hi list, I am using vim from the terminal (mac os 10.5); I often use german umlauts; now, when I write the umlaut ö with another editor, in my case with
    Message 1 of 4 , Sep 30, 2009
      hi list,

      I am using vim from the terminal (mac os 10.5); I often use german
      umlauts;

      now, when I write the umlaut ö with another editor, in my case with
      texshop, and open the file with vim, there ist no ö displayed, but
      <9a>;
      apparently, something with the encoding is wrong;

      my .vimrc-settings are as in

      http://hoepfl.de/articles/2007/01/vimderbar.html

      recommended, that is:

      set encoding=utf-8
      set fileencoding=
      setglobal fileencoding=utf-8
      set fileencodings=ucs-bom,utf-8,latin1 set termencoding=latin1


      so can anyone help me?

      tia
      doris
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • björn
      ... Hi Doris, It seems that texshop is not using UTF-8 so either tell it to use UTF-8 or set the proper file encoding in Vim. I don t know which is the
      Message 2 of 4 , Oct 1 8:27 AM
        2009/9/30 Doris Wagner:
        >
        > hi list,
        >
        > I am using vim from the terminal (mac os 10.5); I often use german
        > umlauts;
        >
        > now, when I write the umlaut ö with another editor, in my case with
        > texshop, and open the file with vim, there ist no ö displayed, but
        > <9a>;
        > apparently, something with the encoding is wrong;
        >
        > my .vimrc-settings are as in
        >
        > http://hoepfl.de/articles/2007/01/vimderbar.html
        >
        > recommended, that is:
        >
        > set encoding=utf-8
        > set fileencoding=
        > setglobal fileencoding=utf-8
        > set fileencodings=ucs-bom,utf-8,latin1 set termencoding=latin1
        >
        >
        > so can anyone help me?

        Hi Doris,

        It seems that texshop is not using UTF-8 so either tell it to use
        UTF-8 or set the proper file encoding in Vim. I don't know which is
        the correct one though...maybe somebody else on the list knows, or ask
        on vim_use.

        Björn

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Tyson Roberts
        Be sure to do a look at the man page for encoding in vim - it s nowhere near as straight forward as you might expect, and there are some strange special cases
        Message 3 of 4 , Oct 1 9:30 AM
          Be sure to do a look at the man page for encoding in vim - it's nowhere near as straight forward as you might expect, and there are some strange special cases you might be running into where one encoding will override others at unexpected times.


          On Fri, Oct 2, 2009 at 12:27 AM, björn <bjorn.winckler@...> wrote:

          2009/9/30 Doris Wagner:
          >
          > hi list,
          >
          > I am using vim from the terminal (mac os 10.5); I often use german
          > umlauts;
          >
          > now, when I write the umlaut ö with another editor, in my case with
          > texshop, and open the file with vim, there ist no ö displayed, but
          > <9a>;
          > apparently, something with the encoding is wrong;
          >
          > my .vimrc-settings are as in
          >
          > http://hoepfl.de/articles/2007/01/vimderbar.html
          >
          > recommended, that is:
          >
          > set encoding=utf-8
          > set fileencoding=
          > setglobal fileencoding=utf-8
          > set fileencodings=ucs-bom,utf-8,latin1 set termencoding=latin1
          >
          >
          > so can anyone help me?

          Hi Doris,

          It seems that texshop is not using UTF-8 so either tell it to use
          UTF-8 or set the proper file encoding in Vim.  I don't know which is
          the correct one though...maybe somebody else on the list knows, or ask
          on vim_use.

          Björn




          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---

        • Tony Mechelynck
          ... Ox9A is not an o-umlaut in Latin1 or UTF-8: in Latin1 it is the control character SCI (Single Character Introducer), and in UTF-8, the _codepoint_ U+009A
          Message 4 of 4 , Oct 31 3:25 PM
            On 30/09/09 17:07, Doris Wagner wrote:
            >
            > hi list,
            >
            > I am using vim from the terminal (mac os 10.5); I often use german
            > umlauts;
            >
            > now, when I write the umlaut ö with another editor, in my case with
            > texshop, and open the file with vim, there ist no ö displayed, but
            > <9a>;
            > apparently, something with the encoding is wrong;
            >
            > my .vimrc-settings are as in
            >
            > http://hoepfl.de/articles/2007/01/vimderbar.html
            >
            > recommended, that is:
            >
            > set encoding=utf-8
            > set fileencoding=
            > setglobal fileencoding=utf-8
            > set fileencodings=ucs-bom,utf-8,latin1 set termencoding=latin1
            >
            >
            > so can anyone help me?
            >
            > tia
            > doris

            Ox9A is not an o-umlaut in Latin1 or UTF-8: in Latin1 it is the control
            character SCI (Single Character Introducer), and in UTF-8, the
            _codepoint_ U+009A (encoded on disk as 0xC2 0x9A) is the same control
            character, while the _byte_ 0x9A can only be the second or further byte
            of a multibyte sequence.

            I suspect that Texshop is using macroman as its encoding, but only you
            can ascertain that, by trial and error, as follows (in Vim):

            (in the vimrc)
            ...
            if has('multi_byte')
            if &enc !~? '^u'
            if &tenc == ""
            let &tenc = &enc
            endif
            set enc=utf-8
            endif
            if 0
            " the following is optional
            " (check the help before uncommenting)
            set fencs=ucs-bom,utf-8,latin1
            setg bomb fenc=latin1
            endif
            endif
            ...

            (at the keyboard)
            :e ++enc=macroman filename.enc

            replacing "filename.enc" by the filename, of course. (You may want to
            have pre-recorded, using Texshop, a "test file" containing as many
            non-ASCII different characters as you can dream of.)

            If it still isn't that, you'll have to try other charsets (Windows-1252,
            maybe?) as the argument of the ++enc modifier.

            See ":help ++opt"


            Best regards,
            Tony.
            --
            Rule of the Great:
            When people you greatly admire appear to be thinking deep
            thoughts, they probably are thinking about lunch.

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          Your message has been successfully submitted and would be delivered to recipients shortly.