Loading ...
Sorry, an error occurred while loading the content.
 

Re: weird behavior with 'nmap el' in init file

Expand Messages
  • björn
    ... Oh. That makes no sense to me... :? I tried reproducing on my machine but both the and the mapping work as they should (no .gvimrc and
    Message 1 of 4 , Sep 12, 2009
      2009/8/30 David Lam:
      > On Sat, Aug 29, 2009 at 1:14 AM, björn <bjorn.winckler@...> wrote:
      >>
      >> 2009/8/28 David Lam:
      >> > hmm dunno if its just me, but using MacVim 1-234,  if i have
      >> >
      >> > nmap <M-f> el
      >> >
      >> > in my init file, it unexpectedly seems to do something like C-f
      >> > instead...
      >> > i.e. it scrolls forward in the file some number of lines
      >> >
      >> > however if i hit : and map the key again while within Vim, i get the
      >> > expected behavior
      >> >
      >> > anyhoo,  i've been using this for awhile on the regular Vim (i.e. not on
      >> > mac)... anyone have any ideas?
      >>
      >> Hi David,
      >>
      >> 1. In order for Meta mappings <M-..> to work on the Mac you need to
      >> set the 'macmeta' option since Mac OS X translates Meta-key
      >> combinations (on my machine, <M-f> turns into ƒ).  However, you say
      >> that it does work if you don't remap in vimrc so I'm a bit confused.
      >>
      >> Failing that:
      >>
      >> 2. Have you tried commenting out all other lines in your [g]vimrc and
      >> then uncommenting one at a time and restarting to see if there is some
      >> combination of settings that causes this?
      >>
      >> 3. Have you tried updating to the latest snapshot?  (I'm not sure what
      >> version 1-234 means, the version info is in the About box under the
      >> MacVim menu.)
      >>
      >> Björn
      >
      > ahhhh ok, following your advice i can reproduce the behaviour in Snapshot 49
      > with just this in the init file:
      >
      > if has("gui_running")
      >     set macmeta
      > endif
      >
      > nmap <space> <C-f>
      > nmap <M-f> el
      >
      >
      > ...and if you comment out the <space> mapping, the <M-f> seems to work
      > normally again!   Doing the remap of <M-f> again inside Vim also fixes the
      > problem

      Oh. That makes no sense to me... :?

      I tried reproducing on my machine but both the <Space> and the <M-f>
      mapping work as they should (no .gvimrc and .vimrc only containing the
      lines you mentioned).

      Björn

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.