Loading ...
Sorry, an error occurred while loading the content.

Re: MacVim build error: PhaseScriptExecution

Expand Messages
  • björn
    ... Ah, I was just about to suggest this...glad you figured it out. ... I guess it *should* but it seems a bit difficult to hook custom scripts into the
    Message 1 of 7 , Sep 3, 2009
    • 0 Attachment
      2009/9/3 Robin <robince@...>:
      > Just got home and got time to have a look at this myself. In fact the
      > loadfont module wasn't cleaned properly and so I guess was built with
      > an old version of python.
      > Doing "make clean" then make in icons seemed to fix this.

      Ah, I was just about to suggest this...glad you figured it out.

      > I had tried xcodebuild clean in MacVim beforehand... shouldn't this
      > call make clean in icons?

      I guess it *should* but it seems a bit difficult to hook custom
      scripts into the "clean" phase in Xcode (I'm not even sure if it is
      possible at all). What does happen is that when you clean the project
      the icons _inside_ the app bundle are deleted, causing the icon script
      to run again when you build (at least this way, if you modify the icon
      generating script the icons will be rebuilt after a clean).

      Björn

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.