Loading ...
Sorry, an error occurred while loading the content.
 

Re: MacVim.app - Snapshot 49

Expand Messages
  • Zvezdan Petkovic
    ... Does this snapshot include the patch for the vimgrep bug that was present in snapshot 48? --~--~---------~--~----~------------~-------~--~----~ You
    Message 1 of 15 , Aug 19 3:32 PM
      On Aug 15, 2009, at 7:26 PM, björn wrote:
      > There are (essentially) no other differences between snapshots 48
      > and 49.

      Does this snapshot include the patch for the vimgrep bug that was
      present in snapshot 48?


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • caruso_g
      It seems like if I type shift+L/M/H in sequence they don t work, while inserting another kye (let s k) in between they do work. A bug? ...
      Message 2 of 15 , Aug 20 6:54 AM
        It seems like if I type "shift+L/M/H" in sequence they don't work,
        while inserting another kye (let's k) in between they do work.
        A bug?

        On Aug 20, 12:32 am, Zvezdan Petkovic <zpetko...@...> wrote:
        > On Aug 15, 2009, at 7:26 PM, björn wrote:
        >
        > > There are (essentially) no other differences between snapshots 48  
        > > and 49.
        >
        > Does this snapshot include the patch for the vimgrep bug that was  
        > present in snapshot 48?
        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • björn
        ... We don t know if the bug has been patched, but Bram did release a patch which probably fixes this bug and this patch is included (in both 48 and 49
        Message 3 of 15 , Aug 20 1:44 PM
          2009/8/20 Zvezdan Petkovic:
          >
          > On Aug 15, 2009, at 7:26 PM, björn wrote:
          >> There are (essentially) no other differences between snapshots 48
          >> and 49.
          >
          > Does this snapshot include the patch for the vimgrep bug that was
          > present in snapshot 48?

          We don't know if the bug has been patched, but Bram did release a
          patch which probably fixes this bug and this patch is included (in
          both 48 and 49 actually...you probably meant 47).

          Björn

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • björn
          ... I m sorry but I don t follow. Are you saying you can t type LMH ? Have you made sure your .vimrc/.gvimrc/.vim are not interfering? Björn
          Message 4 of 15 , Aug 20 1:45 PM
            2009/8/20 caruso_g:
            >
            > It seems like if I type "shift+L/M/H" in sequence they don't work,
            > while inserting another kye (let's k) in between they do work.
            > A bug?

            I'm sorry but I don't follow. Are you saying you can't type "LMH"?
            Have you made sure your .vimrc/.gvimrc/.vim are not interfering?

            Björn

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • caruso_g
            Sorry, I will be more clear. If I want to move to the beginning of the document, then in the middle of the window, then to the end of it, I am not able to
            Message 5 of 15 , Aug 20 4:00 PM
              Sorry, I will be more clear.
              If I want to move to the beginning of the document, then in the middle
              of the window, then to the end of it, I am not able to type:
              shift+h
              shift+m
              shift+l

              but I have to insert a command like k (or whatelse):
              shift+h
              k
              shift+m
              k
              shift+l

              To make it move.

              On Aug 20, 10:45 pm, björn <bjorn.winck...@...> wrote:
              > 2009/8/20 caruso_g:
              >
              >
              >
              > > It seems like if I type "shift+L/M/H" in sequence they don't work,
              > > while inserting another kye (let's k) in between they do work.
              > > A bug?
              >
              > I'm sorry but I don't follow.  Are you saying you can't type "LMH"?
              > Have you made sure your .vimrc/.gvimrc/.vim are not interfering?
              >
              > Björn
              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • caruso_g
              Sorry: …I am not able to type: should be …I am just able to get the first move but not able to make the cursor move to the next position by just
              Message 6 of 15 , Aug 20 4:08 PM
                Sorry:

                "…I am not able to type: " should be "…I am just able to get the first
                move but not able to make the cursor move to the next position by just
                typing: "

                On Aug 21, 1:00 am, caruso_g <peppecar...@...> wrote:
                > Sorry, I will be more clear.
                > If I want to move to the beginning of the document, then in the middle
                > of the window, then to the end of it, I am not able to type:
                > shift+h
                > shift+m
                > shift+l
                >
                > but I have to insert a command like k (or whatelse):
                > shift+h
                > k
                > shift+m
                > k
                > shift+l
                >
                > To make it move.
                >
                > On Aug 20, 10:45 pm, björn <bjorn.winck...@...> wrote:
                >
                >
                >
                > > 2009/8/20 caruso_g:
                >
                > > > It seems like if I type "shift+L/M/H" in sequence they don't work,
                > > > while inserting another kye (let's k) in between they do work.
                > > > A bug?
                >
                > > I'm sorry but I don't follow.  Are you saying you can't type "LMH"?
                > > Have you made sure your .vimrc/.gvimrc/.vim are not interfering?
                >
                > > Björn
                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_mac" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • Zvezdan Petkovic
                ... You are right. It was 47. Thanks, I m glad that the patch is included. Zvezdan --~--~---------~--~----~------------~-------~--~----~ You received this
                Message 7 of 15 , Aug 20 4:34 PM
                  On Aug 20, 2009, at 4:44 PM, björn wrote:
                  > 2009/8/20 Zvezdan Petkovic:
                  >> Does this snapshot include the patch for the vimgrep bug that was
                  >> present in snapshot 48?
                  >
                  > We don't know if the bug has been patched, but Bram did release a
                  > patch which probably fixes this bug and this patch is included (in
                  > both 48 and 49 actually...you probably meant 47).

                  You are right. It was 47.
                  Thanks, I'm glad that the patch is included.

                  Zvezdan


                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_mac" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                • björn
                  ... Please don t top-post on this list...your posts become increasingly hard to follow as the thread grows. Reply under the relevant part of the text and cut
                  Message 8 of 15 , Aug 21 9:59 AM
                    2009/8/21 caruso_g:
                    >
                    > Sorry, I will be more clear.
                    > If I want to move to the beginning of the document, then in the middle
                    > of the window, then to the end of it, I am not able to type:
                    > shift+h
                    > shift+m
                    > shift+l
                    >
                    > but I have to insert a command like k (or whatelse):
                    > shift+h
                    > k
                    > shift+m
                    > k
                    > shift+l
                    >
                    > To make it move.

                    Please don't top-post on this list...your posts become increasingly
                    hard to follow as the thread grows. Reply under the relevant part of
                    the text and cut away everything else. Thank you.

                    I cannot reproduce this problem...please follow the instructions on this page

                    http://code.google.com/p/macvim/wiki/ReportingBugs

                    and report back if there is still a problem.

                    Björn

                    --~--~---------~--~----~------------~-------~--~----~
                    You received this message from the "vim_mac" maillist.
                    For more information, visit http://www.vim.org/maillist.php
                    -~----------~----~----~----~------~----~------~--~---
                  • Chris McGrath
                    ... I just updated to 49 recently and it s broken mappings I have based on C-c. Rolling back to 48 makes it work again. The mappings in my .vimrc are: nnoremap
                    Message 9 of 15 , Sep 18, 2009
                      On Aug 16, 12:26 am, björn <bjorn.winck...@...> wrote:
                      > Hi,
                      >
                      > There were problems with some Ctrl keys (Ctrl-h, Ctrl-o, Ctrl-@) in
                      > the latest snapshot (as well as some arrow key bugs on Tiger) so I
                      > fixed these and built a new snapshot.  Get yours at:
                      >

                      I just updated to 49 recently and it's broken mappings I have based on
                      C-c. Rolling back to 48 makes it work again.

                      The mappings in my .vimrc are:

                      nnoremap <C-c>g :call Run_spec_file("no")<cr>
                      nnoremap <C-c>c :call Run_spec_file("yes")<cr>

                      I'm running 10.5.8.

                      On 48 they run the command, on 49 I see g or c in the incomplete
                      command display (I have set showcmd in .vimrc)

                      Thanks for all your work on MacVim, I don't know what I'd do without
                      it!

                      Cheers,

                      Chris


                      --~--~---------~--~----~------------~-------~--~----~
                      You received this message from the "vim_mac" maillist.
                      For more information, visit http://www.vim.org/maillist.php
                      -~----------~----~----~----~------~----~------~--~---
                    • björn
                      ... I can t reproduce this problem with snap 49. I tried nnoremap g :echo g and when I type g Vim responds by echoing g as expected. Have
                      Message 10 of 15 , Sep 18, 2009
                        2009/9/18 Chris McGrath:
                        >
                        > I just updated to 49 recently and it's broken mappings I have based on
                        > C-c. Rolling back to 48 makes it work again.
                        >
                        > The mappings in my .vimrc are:
                        >
                        > nnoremap <C-c>g :call Run_spec_file("no")<cr>
                        > nnoremap <C-c>c :call Run_spec_file("yes")<cr>
                        >
                        > I'm running 10.5.8.
                        >
                        > On 48 they run the command, on 49 I see g or c in the incomplete
                        > command display (I have set showcmd in .vimrc)

                        I can't reproduce this problem with snap 49. I tried

                        nnoremap <C-c>g :echo "g"<CR>

                        and when I type <C-c>g Vim responds by echoing "g" as expected. Have
                        you tried the usual dance as described here:

                        http://code.google.com/p/macvim/wiki/ReportingBugs

                        ?

                        If that doesn't do the trick I'd like to get the full debug logs when
                        the problem appears:

                        1. In Terminal, enter

                        defaults write org.vim.MacVim MMLogToStdErr 1
                        defaults write org.vim.MacVim MMLogLevel 7

                        2. Start MacVim with "mvim" from Terminal (it will spew out masses of
                        debug logs) and reproduce the bug. Cut&paste the relevant debug
                        output and post it here.

                        3. Disable debug logging when you are done:

                        defaults delete org.vim.MacVim MMLogToStdErr
                        defaults delete org.vim.MacVim MMLogLevel


                        > Thanks for all your work on MacVim, I don't know what I'd do without
                        > it!

                        I'm glad you like it. :-)

                        Thanks,
                        Björn

                        --~--~---------~--~----~------------~-------~--~----~
                        You received this message from the "vim_mac" maillist.
                        For more information, visit http://www.vim.org/maillist.php
                        -~----------~----~----~----~------~----~------~--~---
                      • Chris McGrath
                        ... Yep, the results below are with deleted preferences, and a .vimrc containing only: nnoremap g :echo g ... From 49, the relevant bit seems to be:
                        Message 11 of 15 , Sep 18, 2009
                          On Fri, Sep 18, 2009 at 5:28 PM, björn <bjorn.winckler@...> wrote:
                          >
                          > I can't reproduce this problem with snap 49.  I tried
                          >
                          > nnoremap <C-c>g :echo "g"<CR>
                          >
                          > and when I type <C-c>g Vim responds by echoing "g" as expected.  Have
                          > you tried the usual dance as described here:
                          >
                          > http://code.google.com/p/macvim/wiki/ReportingBugs

                          Yep, the results below are with deleted preferences, and a .vimrc
                          containing only:

                          nnoremap <C-c>g :echo "g"<CR>

                          > ?
                          >
                          > If that doesn't do the trick I'd like to get the full debug logs when
                          > the problem appears:

                          From 49, the relevant bit seems to be:

                          Fri Sep 18 17:44:16 shiny.local MacVim[87172] <Debug>:
                          -[MMTextViewHelper performKeyEquivalent:]@264:
                          Fri Sep 18 17:44:16 shiny.local MacVim[87172] <Debug>:
                          -[MMTextViewHelper keyDown:]@115: NSEvent: type=KeyDown loc=(0,783)
                          time=183565.7 flags=0x40101 win=0x0 winNum=107917 ctxt=0x1042f
                          chars="" unmodchars="c" repeat=0 keyCode=34
                          Fri Sep 18 17:44:16 shiny.local MacVim[87172] <Debug>:
                          -[MMTextViewHelper doCommandBySelector:]@215: noop:
                          Fri Sep 18 17:44:16 shiny.local MacVim[87172] <Debug>:
                          -[MMVimController sendMessage:data:]@344: msg=KeyDownMsgID
                          (isInitialized=1)
                          Fri Sep 18 17:44:16 shiny.local Vim[87170] <Debug>: -[MMBackend
                          processInput:data:]@1139: Got INT, str[0]=0x3
                          Fri Sep 18 17:44:16 shiny.local Vim[87170] <Debug>: -[MMBackend
                          flushQueue:]@593: Flushing queue: SetVimStateMsgID BatchDrawMsgID
                          Fri Sep 18 17:44:16 shiny.local MacVim[87172] <Debug>:
                          -[MMAppController processInput:forIdentifier:]@1240: QUEUE for
                          identifier=1: <<< SetVimStateMsgID BatchDrawMsgID >>>
                          Fri Sep 18 17:44:16 shiny.local MacVim[87172] <Debug>:
                          -[MMTextViewHelper keyDown:]@115: NSEvent: type=KeyDown loc=(0,783)
                          time=183566.0 flags=0x100 win=0x0 winNum=107917 ctxt=0x1042f chars="g"
                          unmodchars="g" repeat=0 keyCode=32
                          Fri Sep 18 17:44:16 shiny.local MacVim[87172] <Debug>:
                          -[MMVimController sendMessage:data:]@344: msg=KeyDownMsgID
                          (isInitialized=1)
                          Fri Sep 18 17:44:16 shiny.local Vim[87170] <Debug>: -[MMBackend
                          flushQueue:]@593: Flushing queue: SetVimStateMsgID BatchDrawMsgID
                          Fri Sep 18 17:44:16 shiny.local MacVim[87172] <Debug>:
                          -[MMAppController processInput:forIdentifier:]@1240: QUEUE for
                          identifier=1: <<< SetVimStateMsgID BatchDrawMsgID >>>
                          Fri Sep 18 17:44:16 shiny.local Vim[87170] <Debug>:
                          -[MMBackend(Private) processInputQueue]@1732: (1) KeyDownMsgID
                          Fri Sep 18 17:44:16 shiny.local Vim[87170] <Debug>:
                          -[MMBackend(Private) doKeyDown:keyCode:modifiers:]@1936: key='g'
                          code=0 mods=0 length=1
                          Fri Sep 18 17:44:16 shiny.local Vim[87170] <Debug>:
                          -[MMBackend(Private) doKeyDown:keyCode:modifiers:]@1974: add byte
                          [0/1]: 0x67

                          And from 48:

                          Fri Sep 18 17:49:45 shiny.local MacVim[87229] <Debug>:
                          -[MMTextViewHelper performKeyEquivalent:]@264:
                          Fri Sep 18 17:49:45 shiny.local MacVim[87229] <Debug>:
                          -[MMTextViewHelper keyDown:]@115: NSEvent: type=KeyDown loc=(0,783)
                          time=183895.5 flags=0x40101 win=0x0 winNum=108153 ctxt=0x11e53
                          chars="" unmodchars="c" repeat=0 keyCode=34
                          Fri Sep 18 17:49:45 shiny.local MacVim[87229] <Debug>:
                          -[MMTextViewHelper doCommandBySelector:]@215: noop:
                          Fri Sep 18 17:49:45 shiny.local MacVim[87229] <Debug>:
                          -[MMVimController sendMessage:data:]@344: msg=KeyDownMsgID
                          (isInitialized=1)
                          Fri Sep 18 17:49:45 shiny.local Vim[87227] <Debug>:
                          -[MMBackend(Private) processInputQueue]@1731: (1) KeyDownMsgID
                          Fri Sep 18 17:49:45 shiny.local Vim[87227] <Debug>:
                          -[MMBackend(Private) doKeyDown:keyCode:modifiers:]@1935: key=''
                          code=0x22 mods=0x4 length=1
                          Fri Sep 18 17:49:45 shiny.local Vim[87227] <Debug>:
                          -[MMBackend(Private) doKeyDown:keyCode:modifiers:]@1973: add byte
                          [0/1]: 0x3
                          Fri Sep 18 17:49:45 shiny.local Vim[87227] <Debug>: -[MMBackend
                          flushQueue:]@593: Flushing queue: SetVimStateMsgID BatchDrawMsgID
                          Fri Sep 18 17:49:45 shiny.local MacVim[87229] <Debug>:
                          -[MMAppController processInput:forIdentifier:]@1240: QUEUE for
                          identifier=1: <<< SetVimStateMsgID BatchDrawMsgID >>>
                          Fri Sep 18 17:49:46 shiny.local MacVim[87229] <Debug>:
                          -[MMTextViewHelper keyDown:]@115: NSEvent: type=KeyDown loc=(0,783)
                          time=183895.8 flags=0x100 win=0x0 winNum=108153 ctxt=0x11e53 chars="g"
                          unmodchars="g" repeat=0 keyCode=32
                          Fri Sep 18 17:49:46 shiny.local MacVim[87229] <Debug>:
                          -[MMVimController sendMessage:data:]@344: msg=KeyDownMsgID
                          (isInitialized=1)
                          Fri Sep 18 17:49:46 shiny.local Vim[87227] <Debug>:
                          -[MMBackend(Private) processInputQueue]@1731: (1) KeyDownMsgID
                          Fri Sep 18 17:49:46 shiny.local Vim[87227] <Debug>:
                          -[MMBackend(Private) doKeyDown:keyCode:modifiers:]@1935: key='g'
                          code=0 mods=0 length=1
                          Fri Sep 18 17:49:46 shiny.local Vim[87227] <Debug>:
                          -[MMBackend(Private) doKeyDown:keyCode:modifiers:]@1973: add byte
                          [0/1]: 0x67
                          Fri Sep 18 17:49:46 shiny.local Vim[87227] <Debug>: -[MMBackend
                          flushQueue:]@593: Flushing queue: SetVimStateMsgID
                          SetPreEditPositionMsgID SetPreEditPositionMsgID
                          SetPreEditPositionMsgID BatchDrawMsgID
                          Fri Sep 18 17:49:46 shiny.local MacVim[87229] <Debug>:
                          -[MMAppController processInput:forIdentifier:]@1240: QUEUE for
                          identifier=1: <<< SetVimStateMsgID SetPreEditPositionMsgID
                          SetPreEditPositionMsgID SetPreEditPositionMsgID BatchDrawMsgID >>>
                          Fri Sep 18 17:49:46 shiny.local Vim[87227] <Debug>: -[MMBackend
                          flushQueue:]@593: Flushing queue: SetVimStateMsgID BatchDrawMsgID


                          Thanks for your help.

                          Cheers,

                          Chris

                          --~--~---------~--~----~------------~-------~--~----~
                          You received this message from the "vim_mac" maillist.
                          For more information, visit http://www.vim.org/maillist.php
                          -~----------~----~----~----~------~----~------~--~---
                        • björn
                          ... Ok, now I see what the problem is. I ve patched the bug and pushed to the repo. The fix will be included in snap 50 when it is released (or you could
                          Message 12 of 15 , Sep 18, 2009
                            2009/9/18 Chris McGrath:
                            >
                            > On Fri, Sep 18, 2009 at 5:28 PM, björn <bjorn.winckler@...> wrote:
                            >>
                            >> I can't reproduce this problem with snap 49.  I tried
                            >>
                            >> nnoremap <C-c>g :echo "g"<CR>
                            >>
                            >> and when I type <C-c>g Vim responds by echoing "g" as expected.  Have
                            >> you tried the usual dance as described here:
                            >>
                            >> http://code.google.com/p/macvim/wiki/ReportingBugs
                            >
                            > Yep, the results below are with deleted preferences, and a .vimrc
                            > containing only:
                            >
                            > nnoremap <C-c>g :echo "g"<CR>
                            >
                            >> ?
                            >>
                            >> If that doesn't do the trick I'd like to get the full debug logs when
                            >> the problem appears:
                            >
                            > From 49, the relevant bit seems to be:
                            > -snip-

                            Ok, now I see what the problem is. I've patched the bug and pushed to
                            the repo. The fix will be included in snap 50 when it is released (or
                            you could download and build your own).

                            Thanks for reporting this bug,
                            Björn

                            --~--~---------~--~----~------------~-------~--~----~
                            You received this message from the "vim_mac" maillist.
                            For more information, visit http://www.vim.org/maillist.php
                            -~----------~----~----~----~------~----~------~--~---
                          • Chris McGrath
                            ... Excellent, will do. ... Thanks again for MacVim ... Cheers, Chris --~--~---------~--~----~------------~-------~--~----~ You received this message from the
                            Message 13 of 15 , Sep 19, 2009
                              On Fri, Sep 18, 2009 at 6:27 PM, björn <bjorn.winckler@...> wrote:
                              >
                              > Ok, now I see what the problem is.  I've patched the bug and pushed to
                              > the repo.  The fix will be included in snap 50 when it is released (or
                              > you could download and build your own).

                              Excellent, will do.

                              > Thanks for reporting this bug,

                              Thanks again for MacVim

                              > Björn
                              >

                              Cheers,

                              Chris

                              --~--~---------~--~----~------------~-------~--~----~
                              You received this message from the "vim_mac" maillist.
                              For more information, visit http://www.vim.org/maillist.php
                              -~----------~----~----~----~------~----~------~--~---
                            Your message has been successfully submitted and would be delivered to recipients shortly.