Loading ...
Sorry, an error occurred while loading the content.

Re: TwitVim Problem

Expand Messages
  • Meikel Brandmeyer
    Hi, ... TwitVim works fine for me. Although that doesn t help... :/ Sincerely Meikel --~--~---------~--~----~------------~-------~--~----~ You received this
    Message 1 of 11 , Jul 2, 2009
    • 0 Attachment
      Hi,

      On Jul 2, 7:17 am, Nico Weber <nicolaswe...@...> wrote:

      > Can you send the output of `:messages`? Does TwitVim require python2.5  
      > by chance? MacVim supports only python 2.4 at the moment.

      TwitVim works fine for me. Although that doesn't help... :/

      Sincerely
      Meikel

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Steve Huff
      ... TwitVim 0.4.1 works for me with snapshot 45 on 10.5 PPC, using the following settings: credentials (base64) let twitvim_login_b64 =
      Message 2 of 11 , Jul 2, 2009
      • 0 Attachment
        On Jul 2, 2009, at 1:17 AM, Nico Weber wrote:

        > Can you send the output of `:messages`? Does TwitVim require python2.5
        > by chance? MacVim supports only python 2.4 at the moment.


        TwitVim 0.4.1 works for me with snapshot 45 on 10.5 PPC, using the
        following settings:

        " credentials (base64)
        let twitvim_login_b64 = "<my base64-encoded credentials here>"

        " use native support
        let twitvim_enable_perl = 1
        let twitvim_enable_python = 1

        i turned on Perl support because i use the same .vimrc on other
        systems with Vims that have perl support.

        -steve

        --
        http://five.sentenc.es


        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Niklas Lindström
        Hi Nico, just a side question.. ... [...] ... 2.5.1 (r251:54863, Jan 13 2009, 10:26:13) [GCC 4.0.1 (Apple Inc. build 5465)] AFAIK, 10.5 has these by default in
        Message 3 of 11 , Jul 2, 2009
        • 0 Attachment
          Hi Nico,

          just a side question..

          On Thu, Jul 2, 2009 at 7:17 AM, Nico Weber<nicolasweber@...> wrote:
          >
          [...]
          > Can you send the output of `:messages`? Does TwitVim require python2.5
          > by chance? MacVim supports only python 2.4 at the moment.

          My build of MacVim (--enable-pythoninterp) uses Python 2.5 on OS X 10.5:

          :py import sys; print sys.version
          2.5.1 (r251:54863, Jan 13 2009, 10:26:13)
          [GCC 4.0.1 (Apple Inc. build 5465)]

          AFAIK, 10.5 has these by default in
          </System/Library/Frameworks/Python.framework/Versions/>:
          2.3
          2.5
          Current -> 2.5

          Did you mean something else or am I confused?

          Best regards,
          Niklas

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Xin Dong
          Hi, The error message is: Error detected while processing function 17_get_timeline.. 17_run_curl.. 17_python_curl: Line 37: Traceback (most
          Message 4 of 11 , Jul 2, 2009
          • 0 Attachment
            Hi,

            The error message is:
            Error detected while processing function
            <SNR>17_get_timeline..<SNR>17_run_curl..<SNR>17_python_curl:
            Line 37:
            Traceback (most recent call last):
            File "<string>", line 18, in ?
            File "<string>", line 8, in make_base64
            AttributedError: 'module' object has no attribute 'b64encode'

            I think the version of python is the cause of the problem. My system
            (10.5) uses python 2.5.1. Is there any way to solve this problem?

            Thanks

            On Jul 2, 12:17 am, Nico Weber <nicolaswe...@...> wrote:
            > Hi,
            >
            > On 01.07.2009, at 20:51, jordi collell wrote:
            >
            > > Hello, I have to append one question to this...
            > > How to view error messages, that flash too quick?
            >
            > `:messages`. See `:h :messages`.
            >
            > > On 2 jul, 03:26, Xin Dong <xdong...@...> wrote:
            > >> Hi,
            >
            > >> Recently I use TwitVim as my Twitter client, which is very  
            > >> convenient.
            > >> I can use it in gvim under ubuntu, I can also use it using vim in Mac
            > >> OS X, however, I can't use it under MacVim. The error message flashed
            > >> very fast. I can see it is related to python module base64.
            >
            > Can you send the output of `:messages`? Does TwitVim require python2.5  
            > by chance? MacVim supports only python 2.4 at the moment.
            >
            > Nico
            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Xin Dong
            Hi Steve, Does your TwitVim use perl or python? I checked my vim version, it is compiled without perl support. Xin ...
            Message 5 of 11 , Jul 2, 2009
            • 0 Attachment
              Hi Steve,

              Does your TwitVim use perl or python? I checked my vim version, it is
              compiled without perl support.

              Xin

              On Jul 2, 10:52 am, Steve Huff <hakamad...@...> wrote:
              > On Jul 2, 2009, at 1:17 AM, Nico Weber wrote:
              >
              > > Can you send the output of `:messages`? Does TwitVim require python2.5
              > > by chance? MacVim supports only python 2.4 at the moment.
              >
              > TwitVim 0.4.1 works for me with snapshot 45 on 10.5 PPC, using the  
              > following settings:
              >
              >      " credentials (base64)
              >      let twitvim_login_b64 = "<my base64-encoded credentials here>"
              >
              >      " use native support
              >      let twitvim_enable_perl = 1
              >      let twitvim_enable_python = 1
              >
              > i turned on Perl support because i use the same .vimrc on other  
              > systems with Vims that have perl support.
              >
              > -steve
              >
              > --http://five.sentenc.es
              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • Steve Huff
              ... perhaps try setting let twitvim_enable_python = 0 to force TwitVim to use command-line curl (installed in OS X by default)? -steve --
              Message 6 of 11 , Jul 2, 2009
              • 0 Attachment
                On Jul 2, 2009, at 2:44 PM, Xin Dong wrote:

                > I think the version of python is the cause of the problem. My system
                > (10.5) uses python 2.5.1. Is there any way to solve this problem?


                perhaps try setting

                let twitvim_enable_python = 0

                to force TwitVim to use command-line curl (installed in OS X by
                default)?

                -steve

                --
                http://five.sentenc.es


                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_mac" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • Xin Dong
                I now disabled python, the curl works. Thanks. I found another problem the g to open the url is not working. Anyone has any idea? Xin ...
                Message 7 of 11 , Jul 2, 2009
                • 0 Attachment
                  I now disabled python, the curl works. Thanks.

                  I found another problem the "\g" to open the url is not working.
                  Anyone has any idea?

                  Xin

                  On Jul 2, 4:25 pm, Steve Huff <hakamad...@...> wrote:
                  > On Jul 2, 2009, at 2:44 PM, Xin Dong wrote:
                  >
                  > > I think the version of python is the cause of the problem. My system
                  > > (10.5) uses python 2.5.1. Is there any way to solve this problem?
                  >
                  > perhaps try setting
                  >
                  >         let twitvim_enable_python = 0
                  >
                  > to force TwitVim to use command-line curl (installed in OS X by  
                  > default)?
                  >
                  > -steve
                  >
                  > --http://five.sentenc.es
                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_mac" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                • john mckenzie
                  ... In plain vim, I changed the value for let twitvim_browser_cmd to open instead of Firefox.exe and this made it work. However it clears the twitvim
                  Message 8 of 11 , Oct 7, 2010
                  • 0 Attachment
                    On Jul 2 2009, 11:19 pm, Xin Dong <xdong...@...> wrote:

                    > I found another problem the "\g" to open the url is not working.
                    > Anyone has any idea?
                    >

                    In plain vim, I changed the value for let twitvim_browser_cmd to
                    'open' instead of "Firefox.exe" and this made it work. However it
                    clears the twitvim buffer seemingly irrevocably, so my entire timeline
                    disappears, and :RefreshTwitter etc. won't bring it back.

                    This does not work in MacVim at all however.

                    -- John

                    --
                    You received this message from the "vim_mac" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  Your message has been successfully submitted and would be delivered to recipients shortly.