Loading ...
Sorry, an error occurred while loading the content.

Re: Vim Turns Into GVim And Freezes

Expand Messages
  • björn
    ... This looks like the forever bouncing dock icon bug reported here: http://code.google.com/p/macvim/issues/detail?id=56 The solution is to download the
    Message 1 of 14 , Jun 18, 2009
    • 0 Attachment
      2009/6/14 Sorin Ionescu:
      >
      > MacVim starts two instances of Vim. Vim in the console is just one
      > instance. In case of MacVim, when I type the dot, only one of the
      > instances turns into GVim. "Activity Monitor" says "Not Responding". I
      > didn't capture this in the video.  In case of Vim, it turns into GVim
      > and bounces the icon. It doesn't actually freeze though. Activity
      > Monitor thinks that because when you click on the icon, no menu pops
      > up. So, it thinks it's frozen.
      >
      > Yes, I have tried to remove the plugins. I removed all of them. No
      > luck. I have tried to use someone else's vimrc that has the same ruby
      > autocmds to see if my vimrc has a conflict.
      >
      > The line that causes this to happen is
      > autocmd FileType ruby,eruby let g:rubycomplete_buffer_loading = 1

      This looks like the "forever bouncing dock icon bug" reported here:

      http://code.google.com/p/macvim/issues/detail?id=56

      The solution is to download the latest snapshot. Please report back
      if that doesn't fix the problem.

      Björn

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • björn
      ... Hmmm...on second though, the code that should fix this is in the Git repo but not in the latest snapshot but do try the latest snapshot anyway. If that
      Message 2 of 14 , Jun 18, 2009
      • 0 Attachment
        2009/6/18 björn:
        > 2009/6/14 Sorin Ionescu:
        >>
        >> MacVim starts two instances of Vim. Vim in the console is just one
        >> instance. In case of MacVim, when I type the dot, only one of the
        >> instances turns into GVim. "Activity Monitor" says "Not Responding". I
        >> didn't capture this in the video.  In case of Vim, it turns into GVim
        >> and bounces the icon. It doesn't actually freeze though. Activity
        >> Monitor thinks that because when you click on the icon, no menu pops
        >> up. So, it thinks it's frozen.
        >>
        >> Yes, I have tried to remove the plugins. I removed all of them. No
        >> luck. I have tried to use someone else's vimrc that has the same ruby
        >> autocmds to see if my vimrc has a conflict.
        >>
        >> The line that causes this to happen is
        >> autocmd FileType ruby,eruby let g:rubycomplete_buffer_loading = 1
        >
        > This looks like the "forever bouncing dock icon bug" reported here:
        >
        > http://code.google.com/p/macvim/issues/detail?id=56
        >
        > The solution is to download the latest snapshot.  Please report back
        > if that doesn't fix the problem.

        Hmmm...on second though, the code that should fix this is in the Git
        repo but not in the latest snapshot but do try the latest snapshot
        anyway. If that doesn't work you could try building from source (or I
        can do it for you and post it).

        Björn

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Sorin Ionescu
        I am running the latest snapshot. Please build it for me and post it. I do not have XCode installed. ... --~--~---------~--~----~------------~-------~--~----~
        Message 3 of 14 , Jun 18, 2009
        • 0 Attachment
          I am running the latest snapshot. Please build it for me and post it.
          I do not have XCode installed.



          2009/6/18 björn <bjorn.winckler@...>:
          >
          > 2009/6/18 björn:
          >> 2009/6/14 Sorin Ionescu:
          >>>
          >>> MacVim starts two instances of Vim. Vim in the console is just one
          >>> instance. In case of MacVim, when I type the dot, only one of the
          >>> instances turns into GVim. "Activity Monitor" says "Not Responding". I
          >>> didn't capture this in the video.  In case of Vim, it turns into GVim
          >>> and bounces the icon. It doesn't actually freeze though. Activity
          >>> Monitor thinks that because when you click on the icon, no menu pops
          >>> up. So, it thinks it's frozen.
          >>>
          >>> Yes, I have tried to remove the plugins. I removed all of them. No
          >>> luck. I have tried to use someone else's vimrc that has the same ruby
          >>> autocmds to see if my vimrc has a conflict.
          >>>
          >>> The line that causes this to happen is
          >>> autocmd FileType ruby,eruby let g:rubycomplete_buffer_loading = 1
          >>
          >> This looks like the "forever bouncing dock icon bug" reported here:
          >>
          >> http://code.google.com/p/macvim/issues/detail?id=56
          >>
          >> The solution is to download the latest snapshot.  Please report back
          >> if that doesn't fix the problem.
          >
          > Hmmm...on second though, the code that should fix this is in the Git
          > repo but not in the latest snapshot but do try the latest snapshot
          > anyway.  If that doesn't work you could try building from source (or I
          > can do it for you and post it).
          >
          > Björn
          >
          > >
          >

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • björn
          ... This is a Leopard/Intel only binary: http://bjorn.winckler.googlepages.com/MacVim-090618-debug.tbz Use it only for testing if this bug has been fixed.
          Message 4 of 14 , Jun 18, 2009
          • 0 Attachment
            2009/6/18 Sorin Ionescu:
            >
            > I am running the latest snapshot. Please build it for me and post it.
            > I do not have XCode installed.

            This is a Leopard/Intel only binary:

            http://bjorn.winckler.googlepages.com/MacVim-090618-debug.tbz

            Use it only for testing if this bug has been fixed.

            Björn

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Sorin Ionescu
            I am running Mac OS X 10.5.7 on Intel. It crashes immediately upon launch. Process: Vim [859] Path:
            Message 5 of 14 , Jun 18, 2009
            • 0 Attachment
              I am running Mac OS X 10.5.7 on Intel. It crashes immediately upon launch.

              Process: Vim [859]
              Path: /Users/sorin/Downloads/MacVim.app/Contents/MacOS/Vim
              Identifier: Vim
              Version: ??? (???)
              Code Type: X86 (Native)
              Parent Process: MacVim [858]

              Interval Since Last Report: 121659 sec
              Crashes Since Last Report: 10
              Per-App Interval Since Last Report: 0 sec
              Per-App Crashes Since Last Report: 7

              Date/Time: 2009-06-18 13:38:46.824 -0400
              OS Version: Mac OS X 10.5.7 (9J61)
              Report Version: 6
              Anonymous UUID: 65FACA0F-CFBC-43C7-B5C2-1E3B46432D5F

              Exception Type: EXC_BREAKPOINT (SIGTRAP)
              Exception Codes: 0x0000000000000002, 0x0000000000000000
              Crashed Thread: 0

              Dyld Error Message:
              Library not loaded: /usr/local/lib/libintl.3.dylib
              Referenced from: /Users/sorin/Downloads/MacVim.app/Contents/MacOS/Vim
              Reason: image not found




              2009/6/18 björn <bjorn.winckler@...>:
              >
              > 2009/6/18 Sorin Ionescu:
              >>
              >> I am running the latest snapshot. Please build it for me and post it.
              >> I do not have XCode installed.
              >
              > This is a Leopard/Intel only binary:
              >
              > http://bjorn.winckler.googlepages.com/MacVim-090618-debug.tbz
              >
              > Use it only for testing if this bug has been fixed.
              >
              > Björn
              >
              > >
              >

              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • björn
              ... I accidentally linked it against a library that you don t have. This build will work better:
              Message 6 of 14 , Jun 18, 2009
              • 0 Attachment
                2009/6/18 Sorin Ionescu <sorin.ionescu@...>:
                >
                > I am running Mac OS X 10.5.7 on Intel. It crashes immediately upon launch.

                I accidentally linked it against a library that you don't have. This
                build will work better:

                http://bjorn.winckler.googlepages.com/MacVim-090618b-debug.tbz

                Björn

                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_mac" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • Sorin Ionescu
                It launched. The bouncing icon is gone, but completion is now totally broken. Autocompletion doesn t work when I type the dot. And, If I type CTRL+X CTRL+V, I
                Message 7 of 14 , Jun 18, 2009
                • 0 Attachment
                  It launched. The bouncing icon is gone, but completion is now totally
                  broken.
                  Autocompletion doesn't work when I type the dot. And, If I type CTRL+X
                  CTRL+V, I get rubbish.


                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_mac" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                • björn
                  ... I only compiled with a minimal amount of features which is why things don t work. However, maybe the bug you experience depend on these extra features, so
                  Message 8 of 14 , Jun 18, 2009
                  • 0 Attachment
                    2009/6/18 Sorin Ionescu:
                    > It launched. The bouncing icon is gone, but completion is now totally
                    > broken.
                    > Autocompletion doesn't work when I type the dot. And, If I type CTRL+X
                    > CTRL+V, I get rubbish.

                    I only compiled with a minimal amount of features which is why things
                    don't work. However, maybe the bug you experience depend on these
                    extra features, so I've prepared another build that you can try:

                    http://bjorn.winckler.googlepages.com/MacVim-090618c.tbz

                    Let me know how that works,
                    Björn

                    --~--~---------~--~----~------------~-------~--~----~
                    You received this message from the "vim_mac" maillist.
                    For more information, visit http://www.vim.org/maillist.php
                    -~----------~----~----~----~------~----~------~--~---
                  • Sorin Ionescu
                    Now, I m getting completion, but a lot of stuff is missing from the completion output that I used to see when I had the bouncing icon. Do you compile it like a
                    Message 9 of 14 , Jun 18, 2009
                    • 0 Attachment
                      Now, I'm getting completion, but a lot of stuff is missing from the
                      completion output that I used to see when I had the bouncing icon. Do
                      you compile it like a MacVim official release with everything
                      necessary enabled? --vim-ruby

                      Thank you


                      2009/6/18 björn <bjorn.winckler@...>:
                      >
                      > 2009/6/18 Sorin Ionescu:
                      >> It launched. The bouncing icon is gone, but completion is now totally
                      >> broken.
                      >> Autocompletion doesn't work when I type the dot. And, If I type CTRL+X
                      >> CTRL+V, I get rubbish.
                      >
                      > I only compiled with a minimal amount of features which is why things
                      > don't work.  However, maybe the bug you experience depend on these
                      > extra features, so I've prepared another build that you can try:
                      >
                      > http://bjorn.winckler.googlepages.com/MacVim-090618c.tbz
                      >
                      > Let me know how that works,
                      > Björn
                      >
                      > >
                      >

                      --~--~---------~--~----~------------~-------~--~----~
                      You received this message from the "vim_mac" maillist.
                      For more information, visit http://www.vim.org/maillist.php
                      -~----------~----~----~----~------~----~------~--~---
                    • björn
                      ... Well, that satisfies me at least...it seems pretty certain that the bouncing icon bug is fixed so you ll just have to wait for the next snapshot to get a
                      Message 10 of 14 , Jun 18, 2009
                      • 0 Attachment
                        2009/6/18 Sorin Ionescu:
                        > Now, I'm getting completion, but a lot of stuff is missing from the
                        > completion output that I used to see when I had the bouncing icon. Do
                        > you compile it like a MacVim official release with everything
                        > necessary enabled? --vim-ruby

                        Well, that satisfies me at least...it seems pretty certain that the
                        bouncing icon bug is fixed so you'll just have to wait for the next
                        snapshot to get a complete build.

                        Thanks for testing the builds,
                        Björn

                        --~--~---------~--~----~------------~-------~--~----~
                        You received this message from the "vim_mac" maillist.
                        For more information, visit http://www.vim.org/maillist.php
                        -~----------~----~----~----~------~----~------~--~---
                      • Sorin Ionescu
                        Thank you, That s okay. I ll wait if you can t build one. Cheers ... --~--~---------~--~----~------------~-------~--~----~ You received this message from the
                        Message 11 of 14 , Jun 18, 2009
                        • 0 Attachment
                          Thank you,

                          That's okay. I'll wait if you can't build one.

                          Cheers


                          2009/6/18 björn <bjorn.winckler@...>:
                          >
                          > 2009/6/18 Sorin Ionescu:
                          >> Now, I'm getting completion, but a lot of stuff is missing from the
                          >> completion output that I used to see when I had the bouncing icon. Do
                          >> you compile it like a MacVim official release with everything
                          >> necessary enabled? --vim-ruby
                          >
                          > Well, that satisfies me at least...it seems pretty certain that the
                          > bouncing icon bug is fixed so you'll just have to wait for the next
                          > snapshot to get a complete build.
                          >
                          > Thanks for testing the builds,
                          > Björn
                          >
                          > >
                          >

                          --~--~---------~--~----~------------~-------~--~----~
                          You received this message from the "vim_mac" maillist.
                          For more information, visit http://www.vim.org/maillist.php
                          -~----------~----~----~----~------~----~------~--~---
                        Your message has been successfully submitted and would be delivered to recipients shortly.