Loading ...
Sorry, an error occurred while loading the content.

Re: i_Ctrl-O in MacVim

Expand Messages
  • Petro Verkhogliad
    ... Ah, thank you. I was at fault here. I was checking :imap and vim said there was no maps defined. But checking the way you suggested pointed to the
    Message 1 of 3 , May 19, 2009
    • 0 Attachment
      On May 19, 2:28 pm, Kent Sibilev <ksr...@...> wrote:
      > On Tue, May 19, 2009 at 2:12 PM, Petro Verkhogliad <vpe...@...> wrote:
      >
      > > Hi,
      >
      > > i_Ctrl-O or ctrl-o in insert mode is supposed to let the user run a
      > > single normal mode command. Right now when I do ctrl-o in insert mode,
      > > a new line is created below the current line and the cursor is moved
      > > to the start of that line (as if i am in normal mode and pressed
      > > 'o').
      >
      > > The Changelog for MacVim says that this issue has been fixed, meaning
      > > that ctrl-o should allow me to run a single command in normal mode. I
      > > am wondering if this command is working properly for anyone right
      > > now.
      >
      > > I am using MacVim Snapshot 45 on OS X 10.5.7. The MacVim updater says
      > > that my version is the most recent.
      >
      > > Thanks,
      > > Petro
      >
      > Hm, it works fine for me. Make sure that none of your plugins
      > overrides this mapping:
      >
      > :verbose imap <c-o>

      Ah, thank you. I was at fault here. I was checking :imap <ctrl-o> and
      vim said there was no maps defined. But checking the way you suggested
      pointed to the problem.

      Thanks,
      Petro
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.